Announcement

Collapse
No announcement yet.

Rpi3 HS4 non US Locale

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Rpi3 HS4 non US Locale

    I have upgraded to HS4 on a Raspberry Pi3. Unfortunately I chose to do this on 6th June so everything appeared to be OK. Carried out my initial tests and added a Virtual device which switches ON once a day and switches OFF once a day, nothing else is connected and no plug-ins added. Next day checked the logs and was confronted by US date and time formats.
    Searched the Forum and several entries suggested where and how to change these to non US format.
    I looked at and modified /usr/local/Homeseer/go, /usr/local/HomeSeer/autostart_hs, /etc/rc.config, /etc/rc.local plus ran Raspi-config and re-booted. I am not a Linux expert but can blunder my way around but I cannot find where to make further changes.

    On one of the early HS4 versions there was 24hour clock option but this has now disappeared, maybe there is still a non US date and time format bug some three months later.

    Can some of the Linux experts here point me to the files that I need to change please.
    I am using my test HS4 before I embark on my live system.
    Thanking you in advance
    Jo

    Update:
    Have found that the editing required permissions which my access method program did not show had failed. Used Putty and edited the files using

    sudo nano /usr/local/Homeseer/go and /usr/local/HomeSeer/autostart_hs and changing from US to my locale and then rebooted. also edited /usr/local/HomeSeer/Config/locations.csv to alter my misspelled location. My raspi-config showed the locale as GB but I think this gets ignored by HS. More than an hour chasing my tail. I have promoted myself to Blunder + class.
    The logs still show date and time in US format. Suspect this is a long awaited bug fix.

    Thanks

    Jo

    Update:

    Log date and time format issue is a know bug

    HS-579 - Selection popup for dates in log not complying to regional formats and merged with HS-672.

    Jo

    #2
    Update:

    After updating to 4.1.8.0 all previous date/time/location changes reverted back to US.

    Thanks

    Jo

    Comment


      #3
      Update:

      Started anew with a fresh HS4 image. Then upgraded to 4.1.8.0 plus sudo nano /usr/local/Homeseer/go and /usr/local/HomeSeer/autostart_hs and changing from US to my locale and then rebooted. also edited /usr/local/HomeSeer/Config/locations.csv to alter my misspelled location.

      Both date and time in the logs are correct non US format. ie dd/mm/yy and 24 hours.

      Maybe someone out there can explain it.

      Cheers

      Jo

      Comment


        #4
        So just to confirm - we'll have to make these locale changes each time HSx is updated?
        Malcolm

        Comment

        Working...
        X