No announcement yet.

Moving HS3 Zee S2 data to new HomeTroller Pi G2 Hub (HS4-Pi) - Solved!

  • Filter
  • Time
  • Show
Clear All
new posts

    Moving HS3 Zee S2 data to new HomeTroller Pi G2 Hub (HS4-Pi) - Solved!

    I have an existing Homeseer Zee S2 controller running HS3.0.0.351 beta and just purchase a new HomeTroller Pi G2 Hub running HS4-Pi. I have backed up the Homeseer Data on the Zee S2 controller and attempted to import the zip file on to the G2 hub. It appears to bring over the existing data as I am able to see the list of devices. But when I try to turn off a light, nothing happens. My guess is it has to do with the HomeID (Network) being different that the Zee S2 controller.

    If there a way to import the data and have it run correctly on the new G2 Hub. Or is there a conversion option that needs to do be performed.


    Yes, The most simple process is move the little Z-Wave board to your new G2 Hub.
    you can also from your Zee S2 backup the interface and restore to G2 Hub. on web interface, Plugins--Z-Wave--Controller Management--Z-Wave Interface--Internal--Backup this interface.


      PFL... Thanks ... backing up the interface prior to doing a backup on the Zee S2 allowed me to restore the interface to the G2 Hub after restoring the backup zip file.

      Much appreciated...


        I am trying to do the same thing - load my HS3 devices, events, etc. into a brand new HS4 Pi Hub.

        I searched the board and can't figure this out.

        I have been running an HS3 ZEE for years with no issues. I tried to upgrade to HS4 but after numerous failed attempts,
        I just bought a new HS4 Pi Hub G2 Lite Edition (Linux)

        I registered the new license and I can access and run both the HS3 and HS4 web interfaces via my home iMac (I do not have a windows PC)
        Obviously the HS4 contains no devices or events events.

        I backed up the HS3 and that zip file ( is sitting in my downloads folder on my iMac and is about 35MB.
        The 4 files in that zip can also be seen in the pics.

        However,I can't get the HS4 to restore to my HS3 data.

        I ran the local restore on the HS$ and selected Upload Backup. I selected the zip file from above and it seemed go load. Took about 5 minutes.
        When it completed, I selected the file (via radio button timestamp) and then hit the Execute button.
        It seemed to run for a few seconds then came back with the error

        "An error occurred while prepping for the restore: Error unzipping backup file: Could not find file "/usr/local/HomeSeer/RestoreConfig/"

        I then changed the "Save To" location from default to /usr/local/HomeSeer/RestoreConfig - (stupidly 🤔) thinking this may have been the issue.

        Did the upload again and then got this message.

        "An error occured while preping for the restore: Error unzipping backup file:
        Could not find file "/usr/local/HomeSeer/RestoreConfig/"

        I am UNiX illiterate 😀 so anything to do with logging into the Pi Hub itself (would have no idea how to) and running comands may be futile.

        Some posts have have said their restores from an HS3 zip to a brand new HS4 system seemed to work fine.
        I'm at a loss as to why it's not working.

        Any help is greatly appreciated. 🙏

        Old System

        Current Date/Time: 1/4/2022 8:56:46 PM
        HomeSeer Version: HS3 ZEE S2 Edition
        Linux version: Linux HomeTrollerZeeS2V7 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l GNU/Linux System Uptime: 1 Day 1 Hour 34 Minutes 14 Seconds
        IP Address:
        Number of Devices: 53
        Number of Events: 22
        Available Threads: 399
        HSTouch Enabled: True
        Event Threads: 0
        Event Trigger Eval Queue: 0
        Event Trigger Priority Eval Queue: 0
        Device Exec Queue: 0
        HSTouch Event Queue: 0
        Email Send Queue: 0

        Enabled Plug-Ins
        1.2020.705.1301: MyQ Z-Wave

        New System

        Date/time=1/4/2022 8:32:36 PM CST
        Version=HomeSeer HS4 Pi Hub G2 Lite Edition (Linux)
        MONO Version=Mono JIT compiler version (tarball Mon Feb 22 17:44:05 UTC 2021)

        License ID=XXXXXXX
        MyHS Subscription=Basic
        MyHS Subscription Backup Interval=No Backup
        MyHS Subscription Max Cameras=1
        Confguration File=/usr/local/HomeSeer/Data/HomeSeerData.json
        Uptime=0 Days 0 Hours 9 Minutes 32 Seconds
        User/Access=xxxxxxxxxx (Admin)
        Lan (HTPiHubG2v3)
        Client (
        WAN ()
        Device Count=2
        Event Count=1
        Last Event Ran=, Ran at 1/1/0001 12:00:00 AM
        # of unique event scripts=0
        Plugins Enabled=Z-Wave:,Z-Wave UI:
        Modules/Threads=77 Modules, 43 Threads
        Available Threads=399
        HomeSeer Memory Used=76 Mbytes
        Plugins Installed=Z-Wave,Z-Wave UI
        Disk Size=28.33GB