Announcement

Collapse
No announcement yet.

HS4-Pi Frequent Reboots with Z-Wave PlugIn

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Richel
    replied
    Originally posted by Rupp View Post

    Polling in general isn't good for a Z-Wave network as it creates too much traffic and too much polling can crash a Z-Wave interface. You shouldn't need to poll most newer Z-Wave devices so this option is best left off.
    Is there a way to assess traffic on a Z-Wave network?

    Leave a comment:


  • NutsyHome
    replied
    Originally posted by Rupp View Post

    Polling in general isn't good for a Z-Wave network as it creates too much traffic and too much polling can crash a Z-Wave interface. You shouldn't need to poll most newer Z-Wave devices so this option is best left off.
    I've been running HS and Z-Wave for 15+ years, so maybe this is a legacy setting that finally acted up to the point of disruption. So far things are going well after a full day with Polling turned off.

    Leave a comment:


  • Rupp
    replied
    Originally posted by NutsyHome View Post
    I "might" have found the cause. When I unchecked "Enable Polling" on the Z-Wave Config page, the resets seem to have stopped (running for 18 hours without further problems).

    Of course, this doesn't explain Why such an obscure setting is able to so reliably crash HS4 on a regular basis. I'll see what happens over the next few days, and wait comes back from the Help Desk.
    Polling in general isn't good for a Z-Wave network as it creates too much traffic and too much polling can crash a Z-Wave interface. You shouldn't need to poll most newer Z-Wave devices so this option is best left off.

    Leave a comment:


  • NutsyHome
    replied
    I "might" have found the cause. When I unchecked "Enable Polling" on the Z-Wave Config page, the resets seem to have stopped (running for 18 hours without further problems).

    Of course, this doesn't explain Why such an obscure setting is able to so reliably crash HS4 on a regular basis. I'll see what happens over the next few days, and wait comes back from the Help Desk.

    Leave a comment:


  • concordseer
    replied
    Probably best route. You’ll need to to turn on Debug in the plugin to help them resolve this issue. Always best to keep your system regularly updated too as you’ve seen.

    Leave a comment:


  • NutsyHome
    replied
    That didn't fix it. Zee ran fine for 12+ hours overnight with the ZWave plugin turned off. Within minutes of turning it on this morning, the Zee reset/rebooted itself

    I've submitted a Help Desk ticket...

    Leave a comment:


  • NutsyHome
    replied
    Originally posted by concordseer View Post
    Close HS from the web UI and do a system update.
    sudo systemctl stop homeseer.service
    sudo apt update
    sudo apt upgrade -y
    Once completed reboot your unit and test your system again and report back
    Wow, it had a LOT of things to update! I'm starting slowly, just letting the Zee run without any plugins for tonight, then will start turning things back on and see if it's stable.

    Leave a comment:


  • concordseer
    replied
    Close HS from the web UI and do a system update.

    sudo systemctl stop homeseer.service

    sudo apt update

    sudo apt upgrade -y

    Once completed reboot your unit and test your system again and report back

    Leave a comment:


  • NutsyHome
    replied
    Have you tried to do a system update recently.
    If you mean a Linux-level system update, no. (If needed, what's the command for that?)

    Originally posted by concordseer View Post
    Use the following commands to do those checks in a terminal session. Copy/paste each line below one at time and press return. Copy/paste the output of each command here.

    cat /etc/os-release
    PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
    NAME="Raspbian GNU/Linux"
    VERSION_ID="10" VERSION="10 (buster)"
    VERSION_CODENAME=buster
    ID=raspbian
    ID_LIKE=debian
    HOME_URL="http://www.raspbian.org/"
    SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
    BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

    uname -r
    4.19.118-v7+

    sudo mono --version
    Mono JIT compiler version 6.10.0.104 (tarball Fri Jun 26 19:59:14 UTC 2020)
    Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
    TLS: __thread
    SIGSEGV: normal
    Notifications: epoll
    Architecture: armel,vfp+hard
    Disabled: none
    Misc: softdebug
    Interpreter: yes
    LLVM: yes(610)
    Suspend: preemptive
    GC: sgen (concurrent by default)

    Leave a comment:


  • concordseer
    replied
    Use the following commands to do those checks in a terminal session. Copy/paste each line below one at time and press return. Copy/paste the output of each command here.

    cat /etc/os-release

    uname -r

    sudo mono --version











    Leave a comment:


  • concordseer
    replied
    The log you’ve posted is of little use. Could you post what version of Raspbian you have installed along with what Linux kernel is in use and what version of Mono is installed.

    Have you tried to do a system update recently.

    Leave a comment:


  • NutsyHome
    started a topic HS4-Pi Frequent Reboots with Z-Wave PlugIn

    HS4-Pi Frequent Reboots with Z-Wave PlugIn

    This started recently... HS4-Pi (4.2.7.0), whenever the Z-Wave PlugIn (3.0.9.0) is running, the Pi will reset/reboot frequently, sometimes every few minutes. If I disable the PlugIn, everything else runs fine. There are no errors in the Log after restart, Log content on restart...

    SOLUTION: Turn off (uncheck) "Enable Polling" under Plugins -> Z-Wave -> Config
    Code:
     [LEFT][FONT=B612 Mono][COLOR=#000000][FONT=Roboto][SIZE=16px]2/2/2022 6:17:54 PM[/SIZE][/FONT][/COLOR][/FONT] 
    
    [FONT=B612 Mono][COLOR=#000000]HomeSeer[/COLOR][/FONT]
    [FONT=B612 Mono][COLOR=#000000]Startup[/COLOR][/FONT]
    [FONT=B612 Mono][COLOR=#000000]************************************************************ ********************[/COLOR][/FONT]
    [LEFT][FONT=B612 Mono][COLOR=#000000][FONT=Roboto][SIZE=16px]2/2/2022 6:17:54 PM[/SIZE][/FONT][/COLOR][/FONT][/LEFT]
     
    
    [FONT=B612 Mono][COLOR=#000000]HomeSeer[/COLOR][/FONT]
    [FONT=B612 Mono][COLOR=#000000]Startup[/COLOR][/FONT]
    [FONT=B612 Mono][COLOR=#000000]HomeSeer version 4.2.7.0 Edition: HomeSeer HS4 Pi Hub G2 Lite Starting Now[/COLOR][/FONT]
    [LEFT][FONT=B612 Mono][COLOR=#000000][FONT=Roboto][SIZE=16px]2/2/2022 6:17:54 PM[/SIZE][/FONT][/COLOR][/FONT][/LEFT]
     
    
    [FONT=B612 Mono][COLOR=#000000]HomeSeer[/COLOR][/FONT]
    [FONT=B612 Mono][COLOR=#000000]Startup[/COLOR][/FONT]
    [FONT=B612 Mono][COLOR=#000000]************************************************************ ********************[/COLOR][/FONT]
    [LEFT][FONT=B612 Mono][COLOR=#000000][FONT=Roboto][SIZE=16px]2/2/2022 6:17:54 PM[/SIZE][/FONT][/COLOR][/FONT][/LEFT]
     
    
    [FONT=B612 Mono][COLOR=#000000]HomeSeer[/COLOR][/FONT]
    [FONT=B612 Mono][COLOR=#000000]Startup[/COLOR][/FONT]
    
    [LEFT][FONT=B612 Mono][COLOR=#000000][FONT=Roboto][SIZE=16px]2/2/2022 6:17:41 PM[/SIZE][/FONT][/COLOR][/FONT][/LEFT]
     
    
    [FONT=B612 Mono][COLOR=#000000]HomeSeer[/COLOR][/FONT]
    [FONT=B612 Mono][COLOR=#000000]Startup[/COLOR][/FONT]
    [FONT=B612 Mono][COLOR=#000000]Settings Loaded.[/COLOR][/FONT]
    [LEFT][FONT=B612 Mono][COLOR=#D58000][FONT=Roboto][SIZE=16px]2/2/2022 6:17:41 PM[/SIZE][/FONT][/COLOR][/FONT][/LEFT]
     
    
    [FONT=B612 Mono][COLOR=#D58000]HomeSeer[/COLOR][/FONT]
    [FONT=B612 Mono][COLOR=#D58000]Warning[/COLOR][/FONT]
    [FONT=B612 Mono][COLOR=#D58000]HomeSeer was not shut down successfully the previous time it was started.[/COLOR][/FONT]
    [LEFT][FONT=B612 Mono][COLOR=#000000][FONT=Roboto][SIZE=16px]2/2/2022 6:17:41 PM[/SIZE][/FONT][/COLOR][/FONT][/LEFT]
     
    
    [FONT=B612 Mono][COLOR=#000000]HomeSeer[/COLOR][/FONT]
    [FONT=B612 Mono][COLOR=#000000]Startup[/COLOR][/FONT]
    [FONT=B612 Mono][COLOR=#000000]Loading Settings[/COLOR][/FONT]
    [/LEFT]
Working...
X