No announcement yet.

Licensing HS4 on Raspberry Pi - can no longer get logged into HS4 - Solved!

  • Filter
  • Time
  • Show
Clear All
new posts

    Licensing HS4 on Raspberry Pi - can no longer get logged into HS4 - Solved!


    I'm new to HomeSeer, but with the Insteon service fiasco I am getting my devices managed by HomeSeer instead.

    I had the trial for HS4 for Raspberry pi trial working well with the Insteon plugin.
    I decided to purchase and license the HS4 for Raspberry after I got it to work yesterday.
    When I went to apply the license one of the questions was to change the system password.
    I tried going through the process 2 or 3 times as the system was saying the initial system password was incorrect.

    I am not able to get logged into the system through the MyHS website or local web logon any longer.
    MyHS is stating that "HomeSeer is not running"
    When I try to access the local URL for HS4 I am prompted with username and password, but can't seem to get logged in no matter what I try for username and password.

    I was able to log into the Raspberry Pi and reset the homeseer logon back to the default logon and have rebooted it several times.

    Does anyone have any ideas on where I should start?
    If I need to rebuild it I will, but I spent quite a bit of time on it yesterday getting the Insteon plugin configured

    Were you using your myHS login to login to the RPi? If so you when you change your license from trial to purchase you would need to login to myHS and change primary system under the manage account option.


      Yes I was using my myHS login to log in when it was working.
      I only see one system listed under MyHS manage and it looks like it has the proper license tied to it


        After looking at the license numbers closely it was not the paid license number
        I was able to use the Change Primary System option to change the license
        I rebooted my RPi, but still can't get logged in.


          If you keyin on your local LAN are you presented with a link. Can you login using that link?


            Thank You Rupp
            I was able to get to the page, but still not login. I was able to get to the maintenance tab on that page though and both "Reset Settings" and "Reinstall HomeSeer"

            It took quite a while to let the process complete, but I was then able to get logged in and re-enable the Insteon plugin.

            Things seem to be back to normal now. as far as being able to logon, see the devices etc.


              As a note I did need to remove and re-add my Alexa integration and devices.
              That isn't a big deal, but just worth mentioning for anyone else that may run into this.

              Also - to get the Insteon plugin installed in the first place I needed to update the trial version of HS4