Announcement

Collapse
No announcement yet.

ISP's router craps out, have to restart HS4.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ISP's router craps out, have to restart HS4.

    So as the title says, I have a cable model that for some reason just drops the internet (not just wireless) everything, it is still running, I can access it's web page etc. but the internet is completely down. I need them to replace it, but I keep putting it off because of the work that will be involved for me when they do.
    Anyway, the weird thing is, after I restart the router everything works, except for HS4, I can't log into it with the APP or from the computer. I reboot HS and everything returns to normal. Just wondering if there is anything I can do to stop that from happening, until I get the router replaced.

    Thank you!

    #2
    Just a guess. If your HS IP address is set by DHCP it is possible that the router is assigning a different IP address for HS each time. It takes a few minutes for HS to send the new IP address to MyHS. If you are not able to access through the app and MyHS, it may know the new IP after a reboot.

    Watch the IP and see if it changes. If my guess is correct, assign a static IP to your Pi and see if that solves the problem.
    HS4 Pro, Windows 10 pro

    Comment


      #3
      Also, if your WAN IP is dynamic it may be changing each reboot as well. If your HS LAN IP isn't changing, try logging into the Pi and running '/usr/local/HomeSeer/register_with_find.sh'.

      Comment


        #4
        Originally posted by randy View Post
        Just a guess. If your HS IP address is set by DHCP it is possible that the router is assigning a different IP address for HS each time. It takes a few minutes for HS to send the new IP address to MyHS. If you are not able to access through the app and MyHS, it may know the new IP after a reboot.

        Watch the IP and see if it changes. If my guess is correct, assign a static IP to your Pi and see if that solves the problem.
        The IP address doesn't change, it remains as it is from the start (I'm using wired not wireless for a network connection). I also have it set as a static address in the router. It's kind of wierd cause it's the only thing that doesn't come back after rebooting the cable router. I also have my Insteon Hub set as static as well not that that matters I don't think for this problem.

        Come to think of it now, after I replied to you, I think I made the address static AFTER the last router crash. So you could be right, but I will have to wait and see now.
        Last edited by Gadgets; May 24, 2022, 07:20 PM. Reason: Edit: added part about static IP

        Comment


          #5
          Originally posted by kenm View Post
          Also, if your WAN IP is dynamic it may be changing each reboot as well. If your HS LAN IP isn't changing, try logging into the Pi and running '/usr/local/HomeSeer/register_with_find.sh'.
          The IP address of the PI running HS doesn't change (it is wired not wireless). It is still what it was from the day I set it up about a month ago (after Insteon flopped). I tried running the command you mentioned, I wasn't sure what to expect. It paused for a while then took me back to the command prompt, no errors or anything appeared.

          Comment


            #6
            Originally posted by Gadgets View Post

            The IP address of the PI running HS doesn't change (it is wired not wireless). It is still what it was from the day I set it up about a month ago (after Insteon flopped). I tried running the command you mentioned, I wasn't sure what to expect. It paused for a while then took me back to the command prompt, no errors or anything appeared.
            What that command does is registers your HS system with find.homeseer.com. After a crash, try running that command and then try to access your HS system using find.homesser.com.

            Comment


              #7
              Originally posted by Gadgets View Post

              The IP address doesn't change, it remains as it is from the start (I'm using wired not wireless for a network connection). I also have it set as a static address in the router. It's kind of wierd cause it's the only thing that doesn't come back after rebooting the cable router. I also have my Insteon Hub set as static as well not that that matters I don't think for this problem.

              Come to think of it now, after I replied to you, I think I made the address static AFTER the last router crash. So you could be right, but I will have to wait and see now.
              If you have the same problem I do, the DNS becomes unreachable. Even putting in 8.8.8.8 as a backup doesn't fix the issue. Rebooting the modem may fix it, but I probably will have to reboot my internal router, too. This whole matter is compounded by my ISP that password protects their router so jealously that it is reset daily and not even the techs have it. They have to beg for the current pass from level 99 guru tech support.
              HomeSeer Version: HS3 Pro Edition 4.2.16.0
              Operating System: Microsoft Windows 10 Pro - Desktop

              Enabled Plug-Ins
              AK Weather 4.0.4.38,AmbientWeather 3.0.1.9,Big6 3.34.0.0,BLBackup 2.0.63.0,BLGData 3.0.55.0,BLLock 3.0.39.0,BLUPS 2.0.26.0,Device History 3.3.1.0,EasyTrigger 3.0.0.76,Harmony Hub 4.0.13.0,HSBuddy 3.30.1003.1,LG ThinQ 4.0.23.0,rnbWeather 4.4.0.0,SDJ-Health 3.1.0.9,TPLinkSmartHome4 2022.10.12.0,UltraCID3 3.0.6681.34300,UltraSighthoundVideo3 3.0.5960.36744,Z-Wave 3.0.10.0

              Comment


                #8
                I have the same problem when my ISP has issues or when I have a power outage. All of my other devices come back up fine after the restart (Arlo, Insteon, wireless router, ISP modem) but the HS4 doesn't get past the blue color indicator. I unplug the HS4 power supply and plug it back in and it comes up fine. I have a static IP for the HS4.

                Is there anyway to do a delayed startup on power fail or have the HS4 wait for the router to come on line? It just looks like a timing issue.


                Version
                HomeSeer HS4 Pi Hub G3 Edition 4.2.12.0 (Linux)

                Plugins Installed
                MNS Insteon 4.0.3.0,Z-Wave 3.0.10.0,Z-Wave UI 1.0.0.0

                Comment


                  #9
                  I've been able to reproduce this on a Pi-400 running HS4-Pi. It's a DHCP issue in that the Pi boots much faster than the router and therefore ends up with a 169.254.x.x self-assigned IP address which HS4 binds to. Setting a DHCP address reservation is not the same as setting a static IP address on the Pi itself. Setting the Pi to "static" and giving it a network config should resolve this issue.

                  EDIT: Here's a link that explains how to modify the Pi to assign a static IP: https://www.makeuseof.com/raspberry-pi-set-static-ip/

                  EDIT2: This explains MikeND 's scenario but not the OPs. Didn't mean to confuse the original issue.

                  Comment


                    #10
                    Gadgets When you get into the failing mode, try logging into the Pi and entering the following command: 'sudo netstat -ltnp |grep ":80"'

                    The double qoutes around :80 are important. This should return the IP address HS4 (.i.e. mono) is bound to.

                    Here's what mine looks like:


                    tcp 0 0 172.29.1.17:80 0.0.0.0:* LISTEN 949/mono

                    Comment


                      #11
                      Originally posted by kenm View Post
                      Gadgets When you get into the failing mode, try logging into the Pi and entering the following command: 'sudo netstat -ltnp |grep ":80"'

                      The double qoutes around :80 are important. This should return the IP address HS4 (.i.e. mono) is bound to.

                      Here's what mine looks like:


                      tcp 0 0 172.29.1.17:80 0.0.0.0:* LISTEN 949/mono
                      OK, I will give that a try, thank you for the help. It is completely random as to when this happens, could be a few days to a couple weeks. For all those also chiming in here, I have all my network stuff including the PI running HS on UPS's and have been home when this happens. One second internet is working the next it's not.

                      I will report back next time it happens with anything new I learn.

                      Comment


                        #12
                        kenm

                        I already had a static IP set up in the PI settings. Please see attached screen shot. Did I do it correctly or is there something else that I should have done?
                        Attached Files

                        Comment


                          #13
                          Originally posted by MikeND View Post
                          kenm

                          I already had a static IP set up in the PI settings. Please see attached screen shot. Did I do it correctly or is there something else that I should have done?
                          Your gateway is on a different subnet than your IP address.

                          Comment


                            #14
                            Your gateway needs to be '192.168.0.1'.

                            Comment


                              #15
                              kenm I can't change that form. I logged a bug about not being able to change the IP address when I made it static. However, at some point, the form finally updated to the new IP address on its own but you can't edit that form. You can try to edit a field but, when you click on Save, nothing happens. When you leave the form, it says "Discard changes?".

                              The person managing the bug said "I recommend leaving DHCP enabled in HS4 and leaving your MAC address reservation."

                              Comment

                              Working...
                              X