Announcement

Collapse
No announcement yet.

ISP's router craps out, have to restart HS4.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Guys the solution is in the link in post number 20. It has been thoroughly outlined there. I’m watching to see how long this thread will continue for.

    Comment


      #47
      Hi concordseer. Thanks again for pointing this out. I have read it. This is not something I'd really like to taken on my own. I'd be worried about causing issues and not having support from Homeseer or updates not working properly etc. I have forwarded your suggestion to Homeseer tech support in hope they could implement it and provide an official update. The main reason I bought the Homeseer Pi was that is was all pre-configured and "supported" by homeseer. I was trying to avoid having to configure my own linux system. We'll see how good their tech support is at responding to suggestions

      Comment


        #48
        Originally posted by ejb068 View Post
        Hi concordseer. Thanks again for pointing this out. I have read it. This is not something I'd really like to taken on my own. I'd be worried about causing issues and not having support from Homeseer or updates not working properly etc. I have forwarded your suggestion to Homeseer tech support in hope they could implement it and provide an official update. The main reason I bought the Homeseer Pi was that is was all pre-configured and "supported" by homeseer. I was trying to avoid having to configure my own linux system. We'll see how good their tech support is at responding to suggestions
        Unfortunately when problems arise with HS on a Linux platform, from time to time it may be necessary to access the OS. It’s unavoidable but it is nothing to be fearful of.

        You have a clearly identifiable problem with a credible solution offered. You will usually find others have experienced similar issues and a quick search will yield a solution in most cases that match your problem.

        The problem usually arises when different users are firing solutions at you from all directions which in many cases are a similar solution coming from a different angle.

        No doubt you’ve realised that the solution in your case is to use the Systemd method for your HS service. This fairly straightforward plain English language link should explain why. Have a read and judge for yourself. You should then be able to decide what best suits your needs.
        https://danielmiessler.com/study/the...v-and-systemd/







        Comment


          #49
          I think the lines get blurred a little bit when it comes to HomeSeer. Since HS4 can be installed on Windows/Linux boxes 'as-a-product', we tend to think of the pre-built, pre-configured hubs/controllers the same way. They are not. These are commercial products that happen to run Linux. My TiVo Edge runs Linux as does my Samsung Q70 series QLED TV. I never expect to have to access the OS to fix a problem with those devices so why should an end-user have to do that on a HomeSeer product?

          I agree that HS should move away from SysV init and it seems like that's been suggested for the last 4-5 years based on the thread you referenced earlier, but it hasn't been done, at least not for the Pi.

          Comment


            #50
            One thing you can do to get around these types of issues is to put a router in between the ISP's router and your network. You can then turn off there WiFi and use your own. That way no matter what happens your network will be unchanged and only the modem side will be. I have been doing that for so long I think everyone is setup that way.

            -Skybolt

            Comment


              #51
              Thanks. That’s what I have now. The isp router is configured as a gateway. HS is coming up faster than the equipment.

              I have had two different Linux gurus tell me to put a Sleep command in rc.local so I’ll try that when I have time to test it

              Comment


                #52
                Not all ISP's allow you access to their equipment to disable WiFi and routing. Adding another router in this case could result in a double NAT situation, which can cause other problems.

                Adding a sleep to rc.lcoal is a workaround until (and if) HST moves to systemd.

                Comment


                  #53
                  Yes. That is correct. I had to call the isp and i had them setup the equipment as a gateway because I was unable to add static IP addresses or control any functions on their router. Their router was not very robust either

                  Comment


                    #54
                    Hi All,

                    I tried the temporary work-around by adding a 2 minute sleep to the rc.local. We lost power yesterday and my device is not working as expected. Same issue as before I added the sleep. Did I do something wrong?

                    BTW. I do have an open ticket with homeseer support to see if they can correct this in their software. So far no commitment, but they have forwarded to the technical team.

                    Code:
                    #!/bin/sh -e
                    
                    #
                    
                    # rc.local
                    
                    #
                    
                    # This script is executed at the end of each multiuser runlevel.
                    
                    # Make sure that the script will [B]"exit 0"[/B] on success or any other
                    
                    # value on error.
                    
                    #
                    
                    # In order to enable or disable this script just change the execution
                    
                    # bits.
                    
                    #
                    
                    # By default this script does nothing.
                    
                    
                    
                    # this sets up the GPIO for the script [B]"gpio"[/B] in /usr/local/bin
                    
                    [B]echo[/B] 52 > /sys/class/gpio/export
                    
                    [B]echo[/B] 53 > /sys/class/gpio/export
                    
                    [B]echo[/B] 35 > /sys/class/gpio/export
                    
                    [B]echo[/B] out > /sys/class/gpio/gpio52/direction
                    
                    [B]echo[/B] out > /sys/class/gpio/gpio53/direction
                    
                    [B]echo[/B] out > /sys/class/gpio/gpio35/direction
                    
                    [B]echo[/B] 1 > /sys/class/gpio/gpio53/value
                    
                    [B]echo[/B] 1 > /sys/class/gpio/gpio35/value
                    
                    [B]echo[/B] 0 > /sys/class/gpio/gpio52/value
                    
                    
                    
                    
                    /usr/local/HomeSeer/led.sh blue
                    
                    # added wait so unit powers up after power failure
                    
                    sleep 2m
                    
                    sudo /usr/local/HomeSeer/autostart_hs &
                    
                    [B]echo[/B] [B]"HomeSeer is starting..."[/B]
                    
                    sudo /usr/local/HomeSeer/register_with_find.sh
                    
                    sudo /etc/init.d/lighttpd start
                    
                    exit 0

                    Comment


                      #55
                      Originally posted by ejb068 View Post
                      Hi All,

                      I tried the temporary work-around by adding a 2 minute sleep to the rc.local. We lost power yesterday and my device is not working as expected. Same issue as before I added the sleep. Did I do something wrong?

                      BTW. I do have an open ticket with homeseer support to see if they can correct this in their software. So far no commitment, but they have forwarded to the technical team.
                      I don't remember if you are using DHCP or static IP. By static I mean set on the device not just a DHCP address reservation?

                      TBH, it wasn't clear that was going to work. I'm now wondering if even moving to systemd will help here.

                      Just as a test, try setting the sleep to 10 minutes or something really crazy like that.

                      Comment


                        #56
                        Well, not so crazy... I set the sleep for 10 minutes and caused a power outage and the Pi came up after 10min with no issue. I think my router(Ubiquiti) does take a long time!

                        Comment


                          #57
                          OK. In the testing profession, that's called a big hammer. So, we know it will eventually come up. That's HUGE. Again, are you using DHCP from your router or are you setting a static IP on the hub?

                          Comment


                            #58
                            Originally posted by kenm View Post
                            OK. In the testing profession, that's called a big hammer. So, we know it will eventually come up. That's HUGE. Again, are you using DHCP from your router or are you setting a static IP on the hub?
                            Yes, DCHP right now. Since it is working, I'm going to leave it at 10min as it is not hurting anything being so long.

                            Comment


                              #59
                              FYI...I changed rc.local to add a Sleep 180 and it works correctly after a power fail restart. My ISP router takes a little over two minutes to startup so the Sleep command makes it wait long enough for the whole network is good before continuing.

                              Thanks to kenm for all the help!

                              Comment


                                #60
                                Originally posted by MikeND View Post
                                FYI...I changed rc.local to add a Sleep 180 and it works correctly after a power fail restart. My ISP router takes a little over two minutes to startup so the Sleep command makes it wait long enough for the whole network is good before continuing.

                                Thanks to kenm for all the help!
                                Glad to hear that fixed it. Since you are using a static IP address, you may not have to wait as long as ejb068 does. It also may be the fact that he's using a Ubuquiti router which takes longer to boot up.

                                Comment

                                Working...
                                X