No announcement yet.

HS4 won't autostart after reboot - Solved!

  • Filter
  • Time
  • Show
Clear All
new posts

    HS4 won't autostart after reboot - Solved!

    Rebooted my HS4 running on a Pi 4. now when it boots, i get an error the /etc/rc.local compatibility failed to load and HS isn't started. I can start it manually from command line and everything runs fine. Anybody know how to fix this?


    I figured it out. I did a restore this morning hoping that would fix things. For whatever reason, when it restored the homeseer folder, it put it back as Homeseer instead of HomeSeer. Autostart script was blowing up cause it couldn't find the /usr/local/HomeSeer path to run the and HSConsole.exe with mono.


      /etc/rc.local is a hold-over from early UNIX systems, from which services can be started upon system boot. This has long been deprecated (since 1990's at least), first in favor of SysV Init, later by systemd.

      rc-local.service is a systemd service that provides backward compatibility for the knuckle-draggers that can't give up the old ways
      $ systemctl status rc-local.service
      ● rc-local.service - /etc/rc.local Compatibility
      Loaded: loaded (/lib/systemd/system/rc-local.service; enabled-runtime; ven>
      Drop-In: /usr/lib/systemd/system/rc-local.service.d
      Active: active (exited) since Wed 2022-05-25 22:21:27 PDT; 4 days ago
      Docs: man:systemd-rc-local-generator(8)
      Tasks: 0 (limit: 4915)
      CPU: 0
      CGroup: /system.slice/rc-local.service
      May 25 22:21:27 HS4Pro systemd[1]: Starting /etc/rc.local Compatibility...
      May 25 22:21:27 HS4Pro systemd[1]: Started /etc/rc.local Compatibility.
      Status "active (exited)" is normal here, since this runs only at boot.

      You might run a check for corruption of the systemd package:
      sudo dpkg -V systemd
      This command only reports variances, so no output means everything is good.