Announcement

Collapse
No announcement yet.

Spurious notifications

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Spurious notifications

    I have this event set up to get an email notification when my garage door is opened and closed. It mostly works, but I'm getting spurious notifications at random times when the door has not moved. Is there a better way to do this?

    #2
    Originally posted by DickB View Post
    I have this event set up to get an email notification when my garage door is opened and closed. It mostly works, but I'm getting spurious notifications at random times when the door has not moved. Is there a better way to do this?
    Have you tried using "This Device had it's Value Set to..." instead of Changes and Becomes?

    Comment


      #3
      No. I will give that a try.

      Comment


        #4
        Well that was worse. Getting a message every minute.

        Comment


          #5
          OK. Change the email action to an HS log message for now. What type of sensor do you have on the door? I have magnetic reed switches and they are very reliable.

          Comment


            #6
            Insteon I/O Linc Garage door. Magnetic reed switches. Worked flawlessly before Insteon shut off their servers.

            Comment


              #7
              OK. "The device had its value set to..." with the value for Open should work. If it is triggering every minute something with the event is not set up correctly. Can you post a screenshot of your event?

              Comment


                #8
                OK

                Click image for larger version

Name:	event.jpg
Views:	45
Size:	69.3 KB
ID:	1560783

                My inbox:


                Click image for larger version

Name:	emails.jpg
Views:	48
Size:	23.7 KB
ID:	1560784
                Attached Files

                Comment


                  #9
                  I can see why that event is triggering every minute. The plugin is likely polling the sensor and setting it every minute. "Changes and Becomes" is a better trigger for this situation but now we have to figure out why you are getting random triggers. Can you post the original event you had setup? This may be a discussion better suited for the Insteon plugin sub-forum since you are using an Insteon I/O Linc.

                  Comment


                    #10
                    Try going back to "Changes and becomes", then when you get the spurious email, check the log to see what is causing the event to trigger.
                    I'm not familiar with Insteon or the plugin, but it may be that the device status is checked once a minute, causing it to be "set".

                    Edit: Just saw that kenm posted the same. I would still check the log when the email comes through though.

                    Comment


                      #11
                      Originally posted by kenm View Post
                      I can see why that event is triggering every minute. The plugin is likely polling the sensor and setting it every minute. "Changes and Becomes" is a better trigger for this situation but now we have to figure out why you are getting random triggers. Can you post the original event you had setup? This may be a discussion better suited for the Insteon plugin sub-forum since you are using an Insteon I/O Linc.
                      The original setup is in my first post. I have set it back to that again.

                      Comment


                        #12
                        Ah, Sorry missed that. I'd suggest copying that event and then disabling it. Change the copy to "not equal to closed" and change the action to log a message with the device value of the sensor when it triggers.

                        EDIT: Here's the syntax for logging the device value: &hs.WriteLogEx("Debug", hs.DeviceValue(1206), True)

                        Change 1206 to the DevRef of the input sensor.

                        Comment

                        Working...
                        X