Announcement

Collapse
No announcement yet.

Schlage Locks with HomeSeer HS4 Pi Hub G3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Schlage Locks with HomeSeer HS4 Pi Hub G3

    I am new to the Homeseer Family and home automation. Recently purchased a HS4 Pi to begin automating some of the functions in my house. First is to manage my door locks. I have the Schlage BE469ZP locks with Firmware Version 0.10.9. My HomeSeer is a HS4 Pi Hub G3 Version 4.2.16.0. To install the lock on the HS I do Devices -> Add New Device -> Z Wave. I press the inclusion button on the lock. When prompted, I enter the 5 digit DSK code for the lock. The lock is discovered, but not detected as a lock. It seems to be just a generic Z Wave device with no function. What are the additional steps required to make this work? Thanks

    #2
    Is there an option to add the lock non-secure?
    HS4Pro Running on a Raspberry Pi4
    67 Z-Wave Nodes, 111 Events, 422 Devices
    Z-Wave, UPB, WiFi
    Plugins: EasyTrigger, weatherXML, OMNI, Z-Wave, Tuya, Device History
    HSTouch Clients: 3 Android, 1 Joggler

    Comment


      #3
      There is no option to add the lock Non-Secure

      Comment


        #4
        Are there any errors logged when you attempted to add the lock? How far from your Z-Wave interface was the lock when you attempted to add it? I'd recommend putting in a support ticket on this issue as well.
        -Rupp
        sigpic

        Comment


          #5
          Thanks for the ideas Rupp. Yes, I does seem like there are some errors (log below). I have tried this now on two identical locks with the same result. One had firmware 0.10.9, the other 0.11.0. The locks are learned as a "Sigma Entry Control" and have no functions. I also have some graber z-wave blinds do not connect either. They are not even detected with I put them in to inclusion mode. I have moved the Homeseer right next to the door, about 1m away, and no change in results. Could it be a z-wave module failure on the Pi?"

          Thanks

          10/27/2022 4:10:42 PM Plugin Debug GetDeviceWithFeaturesByRef - devRef : 35 - found Sigma Entry Control
          10/27/2022 4:10:42 PM Plugin Debug GetDeviceWithFeaturesByRef - devRef : 35
          10/27/2022 4:10:35 PM Legacy-Plugin Z-Wave Node 5 Z-Wave Sigma Entry Control supports having its date/time set. Current TimeZone is MDT with a UTC offset of -6h, 0m and a Current UTC time of 10/27/2022 10:10 PM
          10/27/2022 4:10:32 PM Legacy-Plugin Z-Wave Node 5 is a Z-Wave Plus node. Retrieving ZWPlus Info...
          10/27/2022 4:10:32 PM Legacy-Plugin Z-Wave Node: 5 Supports Class(es): ZWAVEPLUS_INFO, SECURITY, SECURITY_2, TRANSPORT_SERVICE_V2, SUPERVISION, TIME_V2, APPLICATION_STATUS
          10/27/2022 4:10:32 PM Legacy-Plugin Z-Wave Warning If this is an import, you may need to remove and add the device as some devices cannot be added with an import.
          10/27/2022 4:10:32 PM Legacy-Plugin Z-Wave Warning Failed to get a SECURITY SCHEME or verify the key from node 5. Device may not be added properly to HomeSeer.
          10/27/2022 4:10:32 PM Legacy-Plugin Z-Wave Error Z-Wave was unable to negotiate a compatible security scheme with node 5
          10/27/2022 4:10:19 PM Legacy-Plugin Z-Wave Adding using S0 Security, Negotiating or Verifying SECURITY SCHEME for node 5
          10/27/2022 4:10:19 PM Legacy-Plugin Z-Wave S2 Security key negotiation failed, node cannot be added using S2, will try S0 or unsecure...
          10/27/2022 4:10:13 PM Legacy-Plugin Z-Wave Negotiating Security S2 for node 5
          10/27/2022 4:10:13 PM Legacy-Plugin Z-Wave Warning Node 5 does not support the manufacturer specific command class - it is either a really old device or there was a communications problem.
          10/27/2022 4:10:13 PM Legacy-Plugin Z-Wave Synchronize nodes finished. Number of device nodes to be created/added = 1
          10/27/2022 4:10:12 PM Legacy-Plugin Z-Wave HS-ZWPB700: Controller firmware version: 7.17
          10/27/2022 4:10:10 PM Legacy-Plugin Z-Wave Done. Node 5 Added.
          ‚Äč

          Comment


            #6
            What version of the Z-Wave plugin are you running?
            How far from are the locks from your Z-Wave interface when attempting to add them?
            Which Z-Wave interface are you using?
            -Rupp
            sigpic

            Comment


              #7
              Z-Wave Plugin Version 4.0.3.0
              Lock is about 1m (3 feet) away from the Z-Wave interface
              Z-Wave interface HS-ZWPB700

              Comment


                #8
                Do you have other Z-Wave devices already in your Z-Wave network? If not I'd recommend loading the older version of the Z-Wave plugin - Z-Wave Legacy 3.0.10 and test this version of the plugin.
                -Rupp
                sigpic

                Comment


                  #9
                  There should be an option to add unsecure -- are you using z-tool+ or the main HS4 screen to start the inclusion process?

                  Comment

                  Working...
                  X