Announcement

Collapse
No announcement yet.

It was all going so well...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    It was all going so well...

    After putting off this upgrade for some time I decided today to try to upgrade my HomeTroller Zee S2 running HS3 to HS4. I bought myself a Raspberry Pi. Followed these instructions here and all went very smoothly and very soon I was logged in and exploring my new (empty) HS4 system.

    I got the ZWave plugin up and running and added a device to test it. That all went well so I decided I was ready to try transferring my HS3 system over to the new device. For this, I followed the instructions here. I got into Maintenance mode. Performed the HS3 backup and got confirmation of that (and downloaded a local copy).

    Then I moved on to step 2 'Install HS4'. That all seemed to go very quickly only instead of a green notification LED I've got a red one and now if I try to access the system I get this message:

    Error processing HTML file /usr/local/HomeSeer/html/devices.html->Could not find a part of the path "/usr/local/HomeSeer/html/devices.html".

    Very quickly I've realised why I've put this off for so long. :-(

    Before I go and reflash the SD card can anyone suggest where I went wrong please? Thanks
    Malcolm

    #2
    Reading further I see the Pi has two LED lights; pwr and act. My pwr is a solid red and the act one shows no activity. I rebooted it and now it doesn't even appear in https://find.homeseer.com/findhomeseer/
    Malcolm

    Comment


      #3
      I would go simple, first. Conflicting IP addresses, running two computers with HS4 active, how are you accessing the RPi?
      HomeSeer Version: HS3 Pro Edition 4.2.16.0
      Operating System: Microsoft Windows 10 Pro - Desktop

      Enabled Plug-Ins
      AK Weather 4.0.4.38,AmbientWeather 3.0.1.9,Big6 3.34.0.0,BLBackup 2.0.63.0,BLGData 3.0.55.0,BLLock 3.0.39.0,BLUPS 2.0.26.0,Device History 3.3.1.0,EasyTrigger 3.0.0.76,Harmony Hub 4.0.13.0,HSBuddy 3.30.1003.1,LG ThinQ 4.0.23.0,rnbWeather 4.4.0.0,SDJ-Health 3.1.0.9,TPLinkSmartHome4 2022.10.12.0,UltraCID3 3.0.6681.34300,UltraSighthoundVideo3 3.0.5960.36744,Z-Wave 3.0.10.0

      Comment


        #4
        So before step 2 I was able to view and access both systems (on different IP addresses) via myhs.homeseer.com.

        What does the Install HS4 from the maintenance page actually do? I thought it was installing the configuration and files from my HS3 system on the new Pi. That wouldn't change the new Pi's IP address?
        Malcolm

        Comment


          #5
          I raised a support ticket. No response as yet so I went back to the original instructions and reflashed the Pi with the HS4-Pi files. Whilst waiting for Support I started to set up my Plug-ins and Devices (there are hundreds though). I assume when Support does show me how to restore my HS3 system onto the new Pi it will just overwrite what I've achieved so far. Also assumed that if I keep naming conventions the same between the two systems when I copy my Events over these should work too.
          Malcolm

          Comment

          Working...
          X