Announcement

Collapse
No announcement yet.

Date in correct format

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Date in correct format

    How do I get the date to display in the correct format - dd/mm/yyyy? Thanks
    Malcolm

    #2
    So this is driving me mad. I've spent ages Googling. Raised a support ticket. Followed these instructions but still, the date is showing as mm/dd/yyyy. Someone must have found a way to fix this
    Malcolm

    Comment


      #3
      There is no correct format. There is a format that most people used to. You could try this to your format:

      Code:
      date +"Day: %d, Month: %m, Year: %Y"
      the %Y character is replaced with the current year, %m with month, and %d with the day of the month​

      Comment


        #4
        These are the most common formatting characters for the date command:
          • %D – Display date as mm/dd/yy
          • %Y – Year (e.g., 2020)
          • %m – Month (01-12)
          • %B – Long month name (e.g., November)
          • %b – Short month name (e.g., Nov)
          • %d – Day of month (e.g., 01)
          • %j – Day of year (001-366)
          • %u – Day of week (1-7)
          • %A – Full weekday name (e.g., Friday)
          • %a – Short weekday name (e.g., Fri)
          • %H – Hour (00-23)
          • %I – Hour (01-12)
          • %M – Minute (00-59)
          • %S – Second (00-60)

        Comment


          #5
          Originally posted by MalcolmS View Post
          How do I get the date to display in the correct format - dd/mm/yyyy? Thanks
          Where is the date displaying in the non-local format?

          Comment


            #6
            I don't know where this would be applied?
            Malcolm

            Comment


              #7
              Originally posted by drhtmal View Post

              Where is the date displaying in the non-local format?
              Here
              Malcolm

              Comment


                #8
                You need to adjust your locales to reflect your location. Do a bit of searching along the lines of this thread https://forums.homeseer.com/forum/hs...-non-us-locale

                Comment


                  #9
                  Originally posted by concordseer View Post
                  You need to adjust your locales to reflect your location. Do a bit of searching along the lines of this thread https://forums.homeseer.com/forum/hs...-non-us-locale

                  Click image for larger version

Name:	Screenshot 2022-11-27 140615.jpg
Views:	0
Size:	48.3 KB
ID:	1577526
                  Thanks. Already tried that. It doesn't work. Log still shows incorrect date.
                  Malcolm

                  Comment


                    #10
                    I stand corrected. If i untick the "Use 24 HR Time Format" in the Log Settings in HS Setup then the log entries show the correct format dates (and 24 hour times!). Could they make it any more difficult?! The joys of using a product not designed for use outside the market it was developed in I guess.
                    Malcolm

                    Comment


                      #11
                      As a long-time European user of HS, I have come across date format problems since the first version of HS.
                      It is always a pain to have things corrected, as for the camera/recording page, of the HS4 version.
                      Also there has been no plan to support "foreign languages", for the GUI, the plugin SDK, and for the help files.
                      I really feel that nothing has ever been done, even with the help of non-english contributors, that could easily been found.

                      Visit zee e-maison : http://www.e-maison.com

                      Comment

                      Working...
                      X