Announcement

Collapse
No announcement yet.

HS4 Beta 4.2.0.5 is available

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ServiceXp
    replied
    Originally posted by rjh View Post
    I will log this and put in a fix.


    Thank You, After debugging my events for quite some time, I thought I was going crazy.. Well, perhaps that is still true..

    Leave a comment:


  • rjh
    replied
    I will log this and put in a fix.

    Originally posted by ServiceXp View Post
    So is this a bug (I submitted this to HST), or just something that isn't possible now?

    1) Created a Virtual Device, with among others, includes numeric text box features (See pics below).
    2) You cannot use the features in an event as the value return "Missing". (See pics below)
    3) If you go into the old HS3 Device Management page, you can tick the "Include Value" option and you will then be presented with values to choose from.(See pics below)

    4) BUT, you cannot set the features value from an event. Nothing happens.

    Click image for larger version

Name:	2021-09-15_17-40-54.png
Views:	239
Size:	75.4 KB
ID:	1496134

    Click image for larger version

Name:	2021-09-12_15-53-49.png
Views:	251
Size:	352.2 KB
ID:	1496133

    Click image for larger version

Name:	2021-09-12_15-54-05.png
Views:	244
Size:	320.7 KB
ID:	1496135

    Click image for larger version

Name:	2021-09-12_15-54-59.png
Views:	251
Size:	461.4 KB
ID:	1496136

    Leave a comment:


  • ServiceXp
    replied
    So is this a bug (I submitted this to HST), or just something that isn't possible now?

    1) Created a Virtual Device, with among others, includes numeric text box features (See pics below).
    2) You cannot use the features in an event as the value return "Missing". (See pics below)
    3) If you go into the old HS3 Device Management page, you can tick the "Include Value" option and you will then be presented with values to choose from.(See pics below)

    4) BUT, you cannot set the features value from an event. Nothing happens.

    Click image for larger version

Name:	2021-09-15_17-40-54.png
Views:	239
Size:	75.4 KB
ID:	1496134

    Click image for larger version

Name:	2021-09-12_15-53-49.png
Views:	251
Size:	352.2 KB
ID:	1496133

    Click image for larger version

Name:	2021-09-12_15-54-05.png
Views:	244
Size:	320.7 KB
ID:	1496135

    Click image for larger version

Name:	2021-09-12_15-54-59.png
Views:	251
Size:	461.4 KB
ID:	1496136

    Leave a comment:


  • stefxx
    replied
    Originally posted by rjh View Post
    So it looks like for your case you would want to keep the 24HR setting unchecked and use your system format, correct? The 24HR setting was put there for users who only want the log in 24HR format but want the system format for all other output. If someone actually wants the log in 24HR time format but wants the date in a different format (or maybe the system format), I would need to make a change. So far I am not aware of that request. But it does make sense to leave the date in the system format and just force the time to 24HR if the setting is enabled.
    I come from the same country as HansSchouten. I always assumed the log date format was a bug, since I had the "Use 24HR Time Format" enabled as long as I can remember (which in my mind made sense since that is what I wanted). I just disabled it and now the log date AND time format are correct. Thanks!

    I suggest to set the date format according to the system setting, regardless of the "Use 24HR" setting. And maybe make that setting a bit more clear ("Use 24HR time format regardless of system settings"?).

    Thanks!

    Leave a comment:


  • ahuefner
    replied
    This beta release corrected and issue that showed up after installing v4.2. 4.2 caused my UltraM1G plugin to malfunction. With 4.2, TASKs in my ELK security system were automatically activating when the trigger for the event that use to be needed to activate them occurred without any event action. The events that were used to control activation of the ELK TASKS, resulted in a second activation. Some triggers were causing the wrong ELK to be activated. Upgrading to HS4 v4.2.0.5 corrected this condition which requires an event to activate a ELK TASK.

    Leave a comment:


  • rjh
    replied
    It was removed then put back in for 4.2.0.5. If your regional time setting is set to 24HR then you won't see a change with this setting.

    Originally posted by Paul32 View Post
    Checked and unchecked, both is 24hrs.
    P.S. For me it’s not a problem, but the change log suggests that 24hrs should be gone…

    Leave a comment:


  • HansSchouten
    replied
    Originally posted by rjh View Post
    So it looks like for your case you would want to keep the 24HR setting unchecked and use your system format, correct? The 24HR setting was put there for users who only want the log in 24HR format but want the system format for all other output. If someone actually wants the log in 24HR time format but wants the date in a different format (or maybe the system format), I would need to make a change. So far I am not aware of that request. But it does make sense to leave the date in the system format and just force the time to 24HR if the setting is enabled.


    "So it looks like for your case you would want to keep the 24HR setting unchecked and use your system format, correct?" Yes, that's correct!

    You don't have to change anything for me. I leave the 24HR setting unchecked.
    Thanks for your quick response.

    Regards, Hans

    Leave a comment:


  • Paul32
    replied
    Originally posted by rjh View Post
    Did you have the 24 HR log setting in setup unchecked? I tested this with that setting unchecked and it displayed the date correctly (using your format). If you enable the 24 HR log format it formats the date as you are seeing. I guess I could change that to force the date to use the system format but force the time to be 24HR if checked.


    Checked and unchecked, both is 24hrs.
    P.S. For me it’s not a problem, but the change log suggests that 24hrs should be gone…

    Leave a comment:


  • rjh
    replied
    So it looks like for your case you would want to keep the 24HR setting unchecked and use your system format, correct? The 24HR setting was put there for users who only want the log in 24HR format but want the system format for all other output. If someone actually wants the log in 24HR time format but wants the date in a different format (or maybe the system format), I would need to make a change. So far I am not aware of that request. But it does make sense to leave the date in the system format and just force the time to 24HR if the setting is enabled.

    Originally posted by HansSchouten View Post

    Hi Rich, yes i had the 24HR checked. When I uncheck the setting, the logfile display's correctly.

    "I guess I could change that to force the date to use the system format but force the time to be 24HR if checked" , is more clearly.

    Leave a comment:


  • HansSchouten
    replied
    Originally posted by rjh View Post
    Did you have the 24 HR log setting in setup unchecked? I tested this with that setting unchecked and it displayed the date correctly (using your format). If you enable the 24 HR log format it formats the date as you are seeing. I guess I could change that to force the date to use the system format but force the time to be 24HR if checked.


    Hi Rich, yes i had the 24HR checked. When I uncheck the setting, the logfile display's correctly.

    "I guess I could change that to force the date to use the system format but force the time to be 24HR if checked" , is more clearly.
    Attached Files

    Leave a comment:


  • rjh
    replied
    Did you have the 24 HR log setting in setup unchecked? I tested this with that setting unchecked and it displayed the date correctly (using your format). If you enable the 24 HR log format it formats the date as you are seeing. I guess I could change that to force the date to use the system format but force the time to be 24HR if checked.

    Originally posted by HansSchouten View Post

    My windows 10 homeseer server has a regional setting of 24Hrs with a date setting d-M-yyyy.
    Homeseer log display's that as M-d-yyyy. Why? see also screenshots.

    On the General page the date is displayed OK as d-M-yyyy

    HS4 Version 4.2.0.5

    Leave a comment:


  • rjh
    replied
    Yes, that does not make sense, I will have a look.

    Originally posted by HansSchouten View Post

    My windows 10 homeseer server has a regional setting of 24Hrs with a date setting d-M-yyyy.
    Homeseer log display's that as M-d-yyyy. Why? see also screenshots.

    On the General page the date is displayed OK as d-M-yyyy

    HS4 Version 4.2.0.5

    Leave a comment:


  • smithdavee
    replied
    Rich,

    I have had zero problems with the new beta 4.2.0.5, there may be things that crop up but it looks amazing and you squashed a bunch of bugs and concerns. Yes there is more to go, but as Miyagi says patience grasshopper, to all the customers. (Karate Kid), quote

    Leave a comment:


  • HansSchouten
    replied
    Originally posted by rjh View Post
    I checked my windows system and the log is in 12 hr format, so it should be in 12 hr. However, if your regional settings are set to 24HR for the time, that would affect the format. Is that possible in your case?


    My windows 10 homeseer server has a regional setting of 24Hrs with a date setting d-M-yyyy.
    Homeseer log display's that as M-d-yyyy. Why? see also screenshots.

    On the General page the date is displayed OK as d-M-yyyy

    HS4 Version 4.2.0.5
    Attached Files

    Leave a comment:


  • rjh
    replied
    I checked my windows system and the log is in 12 hr format, so it should be in 12 hr. However, if your regional settings are set to 24HR for the time, that would affect the format. Is that possible in your case?

    Originally posted by Paul32 View Post
    I have installed beta 4.2.0.5 on windows.
    But the log is still in 24 hours format, even when it's not selected in setup.
    Or does this means something else?
    HS-1025 24 hour clock format is no longer available for log

    Leave a comment:

Working...
X