Announcement

Collapse
No announcement yet.

HS4 Beta 4.2.1.0 is available

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HS4 Beta 4.2.1.0 is available

    This build is being posted for testing and feedback. See the release notes for changes. This build includes some bug fixes and new features.

    If there are no significant issues with this build we will make this the next official public release.

    Release Notes

    A note about version numbers

    Starting with this release all versions will be in the format #.#.#.0. This indicates a public release (either Beta or formal). Release numbers ending with a value greater than 0, such as 4.2.0.9 are for internal HomeSeer testing, or possibly given to an individual to test.

    Installing:

    Before installing any Beta it is a good idea to back up your system! Run the backup from the tools menu. On Windows you can simply copy the HS4 folder to another folder. Just copy it back if needed.


    * You can install this Beta from within HS4, just go to the General page in Setup (Windows or Linux)

    If you would like to manually install the Windows version, the installer is here:

    https://homeseer.com/updates4/SetupHS4_4_2_1_0.msi

    The Linux tar file is here, or install from setup:

    https://homeseer.com/updates4/linux_4_2_1_0.tar.gz

    Reverting to a previous version on Windows:

    Uninstall HS4 (it will not remove any config files, plugins, etc.). Then install your previous version and install into the same folder as your previous install.

    Reverting to a previous version on Linux:

    On the PI-HUB/ZEE S2/SEL or your own Linux install. You can simply re-install the release version from setup.
    πŸ’‍♂️ Support & Customer Service πŸ™‹‍♂️ Sales Questions πŸ›’ Shop HomeSeer Products

    #2
    rjh ,

    Can we have s refresher on how to install especially on Linux.
    A lot people get confused and at times lash out on those who try help...


    Eman
    TinkerLand : Life's Choices,"No One Size Fits All"

    Comment


      #3
      rjh Rich, in grid view, I see the icons at the top of the card just show the device status. As there is no device name, it is difficult to understand what these relate to? Surely it should be set to show the device name plus the device status for these? Tooltips allow new lines so it should be easy to add?
      Jon

      Comment


        #4
        We have a doc here, if this needs any updates, I can update it:

        https://docs.homeseer.com/display/HS...g+HS4+on+Linux

        Originally posted by Eman View Post
        rjh ,

        Can we have s refresher on how to install especially on Linux.
        A lot people get confused and at times lash out on those who try help...


        Eman
        πŸ’‍♂️ Support & Customer Service πŸ™‹‍♂️ Sales Questions πŸ›’ Shop HomeSeer Products

        Comment


          #5
          Yes, I will add a request to add the device name.

          Originally posted by jon00 View Post
          rjh Rich, in grid view, I see the icons at the top of the card just show the device status. As there is no device name, it is difficult to understand what these relate to? Surely it should be set to show the device name plus the device status for these? Tooltips allow new lines so it should be easy to add?
          πŸ’‍♂️ Support & Customer Service πŸ™‹‍♂️ Sales Questions πŸ›’ Shop HomeSeer Products

          Comment


            #6
            This bug, which has me dead in the water for my project is still not working in this version (Not sure if it was supposed to be fixed in this release or not)
            RJ_Make On YouTube

            Comment


              #7
              Originally posted by rjh View Post
              We have a doc here, if this needs any updates, I can update it:

              https://docs.homeseer.com/display/HS...g+HS4+on+Linux


              Thst's right!

              But more on about upgrading from HS3 to HS4 especially the Raspberry Pi devices or else eveything in general about Linux upgrades.


              Eman.


              TinkerLand : Life's Choices,"No One Size Fits All"

              Comment


                #8
                Small issue when you resize the window width too small, the search box in the upper right-hand corner changes to a yellow "Test 1" icon. Pic below. And, YES, please, updated Linux instructions.

                Click image for larger version

Name:	hs-responsive.JPG
Views:	490
Size:	24.3 KB
ID:	1497981

                Comment


                  #9
                  Originally posted by avpman View Post
                  Small issue when you resize the window width too small, the search box in the upper right-hand corner changes to a yellow "Test 1" icon. Pic below. And, YES, please, updated Linux instructions.

                  Click image for larger version

Name:	hs-responsive.JPG
Views:	490
Size:	24.3 KB
ID:	1497981
                  That has nothing to do with the Homeseer build. That is Jon00 Links. Go to Widgets setup and look for 002 - Mobile Test and if necessary disable.
                  Jon

                  Comment


                    #10
                    There is an issue with VBC vs VBNC. from the HS4 docs = Vbnc is deprecated and will be removed in future updates, use vbc instead.
                    Also, a reminder to check for the correct MONO version and istall the updated MONO version. Initial Linux install loaded V4 when V6 is needed.

                    Originally posted by rjh View Post
                    We have a doc here, if this needs any updates, I can update it:

                    https://docs.homeseer.com/display/HS...g+HS4+on+Linux


                    Comment


                      #11
                      We have a Linux upgrade doc here:

                      https://docs.homeseer.com/display/HS4/Linux

                      Let me know what is missing and I can update the docs.

                      Originally posted by Eman View Post

                      Thst's right!

                      But more on about upgrading from HS3 to HS4 especially the Raspberry Pi devices or else eveything in general about Linux upgrades.


                      Eman.

                      πŸ’‍♂️ Support & Customer Service πŸ™‹‍♂️ Sales Questions πŸ›’ Shop HomeSeer Products

                      Comment


                        #12
                        Originally posted by jon00 View Post

                        That has nothing to do with the Homeseer build. That is Jon00 Links. Go to Widgets setup and look for 002 - Mobile Test and if necessary disable.
                        πŸ‘πŸ‘πŸ‘ Fixed - thanks!

                        Comment


                          #13
                          Originally posted by jon00 View Post

                          That has nothing to do with the Homeseer build. That is Jon00 Links. Go to Widgets setup and look for 002 - Mobile Test and if necessary disable.
                          I’m seeing this as well on an iPhone. Is there a way to disable it on an iPhone? Doesn’t seem to be appearing on my iPad so I assume it has to do with a smaller screen? Thanks Jon.


                          Sent from my iPad using Tapatalk
                          HS4 4.2.6.0 &HSTouch Designer 3.0.80
                          Plugin's:
                          BLBackup, BLOccupied, BLShutdown, EasyTrigger, Ecobee, Nest, AK Bond
                          EnvisaLink DSC, PHLocation, Pushover, SONOS, Blue Iris, UltraRachio3,
                          weatherXML, Jon00 Alexa Helper, Network Monitor, MyQ, Z-Wave

                          Comment


                            #14
                            Originally posted by rjh View Post
                            We have a Linux upgrade doc here:

                            https://docs.homeseer.com/display/HS4/Linux

                            Let me know what is missing and I can update the docs.


                            Smashing!

                            I got this!...Will link it.
                            TinkerLand : Life's Choices,"No One Size Fits All"

                            Comment


                              #15
                              Upgrading from v4.2.0.8 beta to 4.2.1 beta has overwritten my startup.vb file with a default startup.vb. Is this by design or a bug?

                              (Upgraded with the SetupHS4_4_2_1_0.msi file)

                              Comment

                              Working...
                              X