Announcement

Collapse
No announcement yet.

HS4 4.2.18.20 is ready for Beta testing!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Originally posted by langenet View Post
    I don't understand. I have. Big5 on my system - upgraded from HS3 to control my switchbot curtains and don't see this error. What circumstances cause this?
    It's in the HS log file when the plugin starts up.

    Comment


      #47
      Originally posted by logman View Post
      Hey rjh ,

      Found a bug, an aggravating one. After filtering by Floor and Room, I enabled bulk edit. There were about 50 filtered devices that I wanted to move from a temporary "Floor" location to a permanent location. I toggled "Select All" and selected the floor to move them too. After applying I noticed that not only were the 50 filtered devices moved to the new location, but all 6339 devices in the system were also moved to the new "Floor" location. All other previously stored floor location names were wiped clean.

      So it seems when enabling Bulk Edit and toggling "Select All", changes with bulk edit are now applied to every device in the system. It didn't used to work like that, as it only would apply changes to devices that were sorted by the active filter(s).

      Thanks in advance for taking a look.

      --Barry

      rjh Hey Rich,

      A follow up to the above post. The problem with the bulk edit I described above is fixed. However, now there is another issue with bulk edit (which may have already existed but I didn't notice before). Now when a device or group of devices is selected and then, for example, moved to another room, after the bulk move the devices remain selected rather than released from bulk edit. The result is that if another group of devices is selected for bulk editing, the current bulk edit will also get applied to the former group.

      How to replicate:
      • Step 1: Enable bulk edit, select 2 devices and bulk move them to a new room.
      • Step 2: Next select 2 more devices and bulk move those to a different new room.
      • Step 3: Check the last new room created in Step 2 and all 4 devices will be there, and all 4 will still be selected and active for bulk editing.

      Thanks in advance for taking a look at this,


      --Barry

      Comment


        #48
        So if the devices have their location changed you would want them to be unselected? There are times where you would not want this to happen. For example if you want to set a bunch of devices for Alexa and then set the same devices to Google, you will not want to lose your selections. I see what you are saying that if you change the location and you are filtering on a location you don't want the unfiltered devices to stay selected. I think the best way to deal with this to only reset the selections if you use the bulk edit on the category, location or use copy. I would only reset the selection on the devices that were affected by the bulk action, not all the devices.

        Originally posted by logman View Post


        rjh Hey Rich,

        A follow up to the above post. The problem with the bulk edit I described above is fixed. However, now there is another issue with bulk edit (which may have already existed but I didn't notice before). Now when a device or group of devices is selected and then, for example, moved to another room, after the bulk move the devices remain selected rather than released from bulk edit. The result is that if another group of devices is selected for bulk editing, the current bulk edit will also get applied to the former group.

        How to replicate:
        • Step 1: Enable bulk edit, select 2 devices and bulk move them to a new room.
        • Step 2: Next select 2 more devices and bulk move those to a different new room.
        • Step 3: Check the last new room created in Step 2 and all 4 devices will be there, and all 4 will still be selected and active for bulk editing.

        Thanks in advance for taking a look at this,


        --Barry
        💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

        Comment


          #49
          Originally posted by rjh View Post
          So if the devices have their location changed you would want them to be unselected? There are times where you would not want this to happen. For example if you want to set a bunch of devices for Alexa and then set the same devices to Google, you will not want to lose your selections. I see what you are saying that if you change the location and you are filtering on a location you don't want the unfiltered devices to stay selected. I think the best way to deal with this to only reset the selections if you use the bulk edit on the category, location or use copy. I would only reset the selection on the devices that were affected by the bulk action, not all the devices.

          Yes, you've got it exactly. If fact, I think that is how it used to work in the past, where the selected devices were only reset if the devices were moved outside the scope of the filter, which would be out of the current view.

          --Barry

          Comment


            #50
            rjh Any feedback yet from the author if this will be fixed?

            Originally posted by rjh View Post
            I recreated the problem. The problem is that the Big5 plugin is returning TRUE whenever I ask if a device is referenced by one of its actions. I will contact the author.


            Comment


              #51
              The reaction I received is that it's fixed in Big6. Can you update to that version?

              Originally posted by avpman View Post
              rjh Any feedback yet from the author if this will be fixed?


              💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

              Comment


                #52
                Big6, as I understand, isn't an update. It's a complete re-purchase. I have a problem paying twice to get a small, but significant bug fixed. I know - I'm just venting.

                Originally posted by rjh View Post
                The reaction I received is that it's fixed in Big6. Can you update to that version?


                Comment


                  #53
                  Are you referring to the issue where they are reading all the devices? If so, my understanding is that they only do that on startup. So that should not be an issue for you. Or was it a different issue?

                  Originally posted by avpman View Post
                  Big6, as I understand, isn't an update. It's a complete re-purchase. I have a problem paying twice to get a small, but significant bug fixed. I know - I'm just venting.


                  💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

                  Comment


                    #54
                    No, the issue where the plugin returns TRUE incorrectly ",,, returning TRUE whenever I ask if a device is referenced by one of its actions."

                    Originally posted by rjh View Post
                    Are you referring to the issue where they are reading all the devices? If so, my understanding is that they only do that on startup. So that should not be an issue for you. Or was it a different issue?


                    Comment


                      #55
                      Ah, ok, forgot about that one. I checked my email and he said he was waiting for his programmer to return from vacation. I emailed him for an update. It appears we was willing to get that issue fixed.

                      Originally posted by avpman View Post
                      No, the issue where the plugin returns TRUE incorrectly ",,, returning TRUE whenever I ask if a device is referenced by one of its actions."


                      💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

                      Comment


                        #56
                        Make sure you post a request in his forum, the more people that report the issue the more likely he will fix it.

                        Just tell them that this function is always returning True, but it should it only do that if the plugin references the device.

                        ActionReferencesDevice(dev_ref)


                        Originally posted by avpman View Post
                        No, the issue where the plugin returns TRUE incorrectly ",,, returning TRUE whenever I ask if a device is referenced by one of its actions."


                        💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

                        Comment


                          #57
                          Originally posted by avpman View Post
                          No, the issue where the plugin returns TRUE incorrectly ",,, returning TRUE whenever I ask if a device is referenced by one of its actions."


                          Is that because the Big5/Big6 device profiles are preloaded into a device list when an action is being creation?

                          --Barry

                          Comment

                          Working...
                          X