Announcement

Collapse
No announcement yet.

System Crash

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Is the plug-in developer still looking into this issue? I really like the plug-in and the older version(1.0.4.0) is not updating properly with some of my devices. I read where the use of hs.ping is not reliable..

    Comment


    • #32
      I am still trying to find the cause of this.

      I do not see the issue at all on my machine. I have run all versions of the plugin and I do not see the crashes.

      This is a bug in .net 2.0 where the vb.net is garbage collecting the ping object too soon and then when the code accesses it again it throws the error you are seeing. I will attempt a work around and see if it helps.
      The issue is apparently resolved in .net 4.0 but I do not know when HS will be capable of using .net 4.0 compiled plugins.
      Last edited by Blade; November 21st, 2011, 08:52 AM.
      Cheers,
      Bob
      Web site | Help Desk | Feature Requests | Message Board

      Comment


      • #33
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • #34
          For step 6 - Browse to the executale that they are going to run and select it, what executable am i going to select?

          Comment


          • #35
            I would select the HomeSeer.exe file since all plugins run under that process.
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment


            • #36
              Thanks! I'll let you know if I see the errors again after making these changes...

              Comment


              • #37
                OK... I am going to check into a workaround and see if makes any difference. Make sure you are using the newest build because that is the one I am working from.

                Let me know how it goes
                Cheers,
                Bob
                Web site | Help Desk | Feature Requests | Message Board

                Comment


                • #38
                  Please also try this build and see if it helps.

                  BLLAN Beta
                  Cheers,
                  Bob
                  Web site | Help Desk | Feature Requests | Message Board

                  Comment


                  • #39
                    Any news on this?
                    Cheers,
                    Bob
                    Web site | Help Desk | Feature Requests | Message Board

                    Comment


                    • #40
                      I have not installed the newer build but have not seen any errors so far with making the settings changes suggested. I would of seen errors by now.

                      Comment


                      • #41
                        Unfortunately I finally seen the crash, I'll be trying the new build. Will let you know.

                        Comment


                        • #42
                          Well used the beta build and got the crash after about 3 days...
                          Attached Files

                          Comment

                          Working...
                          X