Announcement

Collapse
No announcement yet.

Cannot edit devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot edit devices

    I have used this plugin before, and after moving to another PC I have reinstalled it. Added my 2 phones without problems. I then tried to create events and was surprised when I selected one of the phones and changed state to... I dod not have on/off just invalid stae. I looked at the plugin again and the phones have disappeard completely (They are still there sort of, see pics). I cannot delet or edit them now, uninstalling and reinstalling the plugin did not help, after reinstalling they are there again as per pics
    Attached Files

  • #2
    Did you edit the location or name of the devices?

    Turn on debug logging in the plugin
    Then load the maintain computers page
    Go back to the options page and turn off debug logging

    Attach the BLLAN-Detailed.log file zipped
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      I did not edit the location or names of the devices. I have turned on debugging, then loaded the computers page, gone back to options and debugging was unclicked already. Where do I find the log ?

      Comment


      • #4
        It is in the HS3 root folder
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • #5
          here it is:
          Attached Files

          Comment


          • #6
            What name does the device have for this computer

            06/07/2016 20:12:47 : v2.0.26.0 - Get_Device_Ref_By_Name() started
            06/07/2016 20:12:47 : v2.0.26.0 - Get_Device_Ref_By_Name(): location --> Home
            06/07/2016 20:12:47 : v2.0.26.0 - Get_Device_Ref_By_Name(): name --> Just S5 mini
            06/07/2016 20:12:47 : v2.0.26.0 - Get_Device_Ref_By_Name(): fullName --> Home Just S5 mini
            06/07/2016 20:12:47 : v2.0.26.0 - Get_Device_Ref_By_Name(): devRef --> -1
            06/07/2016 20:12:47 : v2.0.26.0 - Get_Device_Ref_By_Name() finished

            Can you attach your hspi_BLLAN.ini zipped as well
            It is in the config folder
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment


            • #7
              one device was named Just S5 mini, the other one Mike S6

              here is the ini:
              Attached Files

              Comment


              • #8
                Just looked through my log and by chance seen this:

                Jul-06 21:28:41
                BLLAN Info Computer - Home Mike S6 is not connected (Uptime: 2 hrs, 25 mins, 35 secs) Jul-06 21:28:41 BLLAN Info Computer - Home Mike S6 --- 2 PING failures
                Jul-06 19:28:09
                BLLAN Info Computer - Home Just S5 mini --- 1 PING failure

                So they are working, but somehow the devices might be corrupted

                Comment


                • #9
                  Delete the computer in the plugin
                  Then delete the device for it if it exists
                  Then Create the computer again in the plugin and see if that works
                  Cheers,
                  Bob
                  Web site | Help Desk | Feature Requests | Message Board

                  Comment


                  • #10
                    I cannot delete the computers in the plugin, and I had deleted the devices after they have been created as they did not display any on or off, and I could not create events based on them being on or off. So I am completely stuck at the moment, cannot delete or change anything.

                    Comment


                    • #11
                      Ok do this:

                      1. Disable BLLAN
                      2. Delete any devices associated to BLLAN in HS3
                      3. Delete the hspi_BLLAN.ini file in your config folder
                      4. Restart HS3
                      5. Re-enable BLLAN and the plugin will re-create the INI file
                      6. Add your computers. Do not change the names of the devices in HS3

                      Let me know
                      Cheers,
                      Bob
                      Web site | Help Desk | Feature Requests | Message Board

                      Comment


                      • #12
                        Had to do it a couple of times but all seems good now. Thanks

                        Comment

                        Working...
                        X