Announcement

Collapse
No announcement yet.

MIB upload not working?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    MIB upload not working?

    Hi Mat,

    Im just testing your plugin, and Ive tried several MIB files but nothing appears to be loaded. I see the messages: Uploading, Complete, Please wait. The screen refreshes but there is nothing in the MIB List.
    I've added a few devices with corresponding OID's which update OK. I just need to ID some more sensors using the MIBs.

    The MIB's I've tried are:

    QNAP NAS - downloaded direct from the NAS.
    TP-LINK Switch - there is over 100 MIBS available for use; Ive uploaded a few with no success.
    pfSense Router - FREEBSD MIB's. There is about 7 MIB files, downloadable direct ffrom the device.

    I've attached the NAS MIB and a pfSense MIB for your reference. Is it my system thats ropey, or have I just been unlucky with the MIB files?

    Thanks in advance.





    Date/time=29/09/2020 14:55:54 GMT Summer Time
    Version=HS4 Standard Edition 4.1.6.0 (Windows)
    License=Registered
    Confguration File=C:\Program Files (x86)\HomeSeer HS3\Data\HomeSeerData.json
    In Virtual Machine=No MFG: asustek computer inc.
    Antivirus=Windows Defender
    OS=Microsoft Windows 10 Pro - Work Station
    OS Version=10.0.19041
    Uptime=17 Days 18 Hours 6 Minutes 49 Seconds
    Lan IP=192.168.172.178 (Riley)
    Device Count=535
    Event Count=152
    Processor:=Intel64 Family 6 Model 158 Stepping 13 at 2.79 GHz
    Modules/Threads=127 Modules, 136 Threads
    Available Threads=1022
    System Load=196 Processes, 12% Load
    Free/Total Memory=11.02 GBytes / 15.92 GBytes (69% free)
    Free/Total Virtual Memory=9.57 GBytes / 18.30 GBytes (52% free)
    HomeSeer Memory Used=95 Mbytes
    Plugin Memory Used=12 EXE Plug-Ins using 363 Mbytes
    Plugins Installed=BLLAN 2.0.45.0,Blue-Iris 3.1.3.33206,BULLET 4.8.4.0,Bulletseer 1.0.0.3,Chromecast 4.0.12.0,Device History 1.4.0.4,drhsEventEnabler 1.0.0.0,JowiHue 2.1.1.3,Kodi 3.0.1.14,MediaController 3.0.0.66,SNMP Monitor 1.0.0.2,TPLinkSmartHome 19.10.7.1,Tuya 4.0.19.0,Z-Wave 3.0.2.0
    Attached Files

    #2
    I've the same issue. IMO this PI isn't that comprehensive compared to John00 free PI
    https://forums.homeseer.com/forum/3r...r-3-homeseer-4
    It's too bad (for me) that John's PI only runs on a windows client.

    I'm trying to write a script myself for the couple of SNMP gets I need to perform
    https://forums.homeseer.com/forum/de...tingreferences

    Comment


      #3
      Hi tech2zero,

      Thanks for trying the plugin and feedback, I will work out why the samples you provided don't load and correct the issue ASAP and advise.

      Thanks
      Mat

      Comment


        #4
        Hi Alan_Smithee,

        Thanks for the Feedback. To be totally honest, I didn't even see his plugin when I wrote this one, i wouldn't have developed it otherwise.

        However, Its here now, so I'm happy to make changes and add features based on feedback.

        What features did you require and ill try and add them while im working on the plugin?

        Also, this plugin will work with Linux no problems.

        Let me know any feedback and ill be happy to look at including it.

        Thanks
        Mat

        Comment


          #5
          Hi tech2zero,

          Just letting you know, Beta 1.0.0.3 is uploaded with changes to allow your 2 MIB files, There were 2 issues, In the NAS file the MIB structure is poorly formatted and there where 2 items that had Extra blank Lines... the PF sense file had something I had not encountered before where the Master OID is referenced at the start of the file, So support has been added for this.

          Click image for larger version

Name:	SNMP Sample.JPG
Views:	47
Size:	30.0 KB
ID:	1424359

          Also, I have fixed the Description display on the Config page as this was wrong.

          Please let me know if you have any more trouble.

          Thanks
          Mat

          Comment


            #6
            Thanks for looking at this Mat.
            I'll update, test and report back.

            Thanks again.

            Comment


              #7
              Hey Matt, I've still not been able to upload the MIB files. They appear to upload, but then nothing appears in the list after the refresh.
              Happy to upload a debug file if you're curious, but the MIB file upload is a nice-to-have but not a show stopper for me so don't worry about further investigation for me.

              Aside from the above, it functions great. The nodes are updating and Im able to use the values in events etc. The trial is nearly up so I'll be purchasing soon.

              FYI, after further reading, the pfSense MIB actually calls other MIB files so there is an order in which to import the MIBS so that each dependency is satisfied before the next MIB can be imported.

              Thanks 👍

              Comment


                #8
                OK, a wierd thing just happened - the NAS MIB just imported fine! Its in the list and its pulled all the description data successfully.


                Comment

                Working...
                X