Announcement

Collapse
No announcement yet.

Frequently changing ipaddr

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Frequently changing ipaddr

    I recently installed UltraMon3 to better track network devices. It helped me identify a couple of network issues, but there is one that puzzles me. UltraMon3 keeps reporting one MAC address as constantly changing, frequently changing several times per minute. The device is the z-net controller (new version on a RasPi3). The ipaddr is set through the web interface to static. It keeps changing from the assigned address to an address in the DHCP range then back again. Is this an artifact of UltraMon3 somehow or is the ipaddr really changing that often? Has anyone else seen similar behaviors? The z-wave network occasionally drops commands and I am suspicious this may be the issue. The controller, HS3, Windows and the router/DHCP server have all been restarted - no joy.

    ...79 is the assigned address, the DHCP assignment range is ...100-200. The subnet is 192.168.0/24
    Attached Files

    #2

    Comment


      #3
      I didn't configure a wireless ssid yet - it's connected via ethernet. ifconfig shows eth0 has the correct ipadder and wlan0 has no linked ip. I'll try using a router assigned static address and see if that helps.

      Comment


        #4
        Having the router assign the static address outside the DHCP pool fixed it. Curious none of my other RasPis have that problem. Thanks for the suggestion.

        Comment


          #5
          My Raspberry Pi computers do this too. For reasons unknown, the Pi responds to an ARP for both MAC addresses even if only connected via Ethernet. I end up having to complete disabling the wlan0 when connected via Ethernet.
          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

          Comment

          Working...
          X