No announcement yet.

New Devices Not Displaying On Device Status Webpage But Are In HSTouch on iOS

  • Filter
  • Time
  • Show
Clear All
new posts

    New Devices Not Displaying On Device Status Webpage But Are In HSTouch on iOS

    I added a BrightSign XT1144 video overlay device to my network and Ultramon3 sent me an email with its MAC address promptly.

    I created some icons and a new device type and edited the device under the IP Subnets tab (I have 25 devices, many are custom device types with custom icons) and checked the "HomeSeer Device" checkbox to create the device.

    When I go to the device status webpage in HS at /deviceutility, the new device is nowhere to be found. I can go directly to the device configuration page because I know the device reference number... its Ultramon3 tab shows all of the information for the device. I can change it to a different room and set the Device Type to "Status" (like I've done with all of my other Ultramon3 devices) but it simply will not display on the device status page! Yes, I have set the Room & Device Type filter drop downs on the /deviceutility page and checked "Living Room" & "Status" so it's not hidden because of that. The "Hide Device From Views" checkbox is not checked on its configuration page. I even deleted the device from its configuration page and went back into the IP Subnets tab to recreate the device and it still will not show up on the device status page (/ or /deviceutility in the address bar). I know it recreated the device because its reference number incremented by one and going to the configuration page for the old device ref doesn't find a device.

    I CAN see the device in HSTouch on my iPhone, but not on the webpage. I can see every single other Ultramon3 device, but not this new one! SO frustrating!

    What can I do to see this device?
    • HS3 Pro Edition (Windows)
    • UltraMon3 3.0.6554.33094

    Ultrajones I am still having issues with UMon3. It is not behaving the way it used to. Now it's not remembering devices within the UMon3 pages and threw an error when I tried disabling/re-enabling it. Seems there is something wrong with database access?
    • I have created 6 other devices manually without any issues, unrelated to UMon3, since first noticing devices weren't showing up, so I don't think there's anything wrong with my HS3 install
    • The XT1144 is listed in the UMon3 tables but is still missing from the device management page, though it shows in HSTouch
    Now there are more issues with UltraMon3:
    • I connected another device to my wireless network yesterday, a Withings Sleep Pad
      • Ultramon3 sends me an email when it senses the device
      • I created a new device type for it with custom graphics
      • I go into the IP Subnets tab
        • click the Edit link to open the modal
        • Enter the name and check the HomeSeer Device checkbox
        • Click the Update button to close the modal
        • I verify I can see the new entry for that IP address
        • I can move back & forth through the paginated pages of the IP Subnets tab and the newly entered information remains
      • As soon as I click over to the Devices tab, it displays the total count of devices as the number before I just entered the new information for the new Sleep Pad device. ie.The total should be 26 but it is 25
        • If I go back to the IP Subnets tab, the information I had just entered is now gone
        • If the Sleep Pad turns back on, UMon3 sends me another warning email that it found a new device
    • I restarted Homeseer
      • Same issues
    • I restarted the computer
      • Same issues
    • I went into Manage Plugins and disabled UMon3
      • Got a threading error in the log during shutdown of UMon3:
        • Click image for larger version  Name:	Screen Shot 2019-08-25 at 12.08.56 PM.png Views:	0 Size:	327.3 KB ID:	1322698

    One last issue: I went to another working UMon3 device config page, went into the UMon3 tab and clicked Save without changing anything. That device is now also missing from my device management page.

    Is there any way I can access the database for each entry and possibly remove any bad entries or repair it? Does it even use a database or is the data stored in a file somewhere I could look at? Is there a debug log I can enable?

    Thanks for any assistance!


      I found the Logging Level setting under Options and set it to Debug. Went through the steps of entering the name, Mac Address & checked the HomeSeer Device checkbox and Updated. Verified it is not listed under the Device tab and is now missing under the IP Subnets tab. The log shows absolutely nothing from the plugin.

      UPDATE: I found the hspi_ultramon3_debug.log file. Can see it uses SQLite. Reading through the debug log, I can see where I tried editing the Sleep Pad twice, but I don't see any errors. I'll send you the log file in a PM (hope that's ok) rather than post it in this thread. I also read through ultramon3.xml and can see ping history for the XT1144 as well as other settings for the device. Everything seems similar to other working devices in the XML file (it's listed as online etc.) but it still doesn't show up in the device page.


        After almost a year of not seeing the last few devices I added, I finally found them!

        At some point maybe 2 years ago, I turned off the Location 2 (floor name) column on the main display page for Homeseer. When a new UJ3 device is created, it adds it to a new floor that is named for the manufacturer-model of the device. Since I am no longer viewing the Location 2 column and new floor names are NOT checked in the drop down by default, I could never see newly created devices. I couldn't click the Floor drop down because it doesn't show on the page when not viewing Location 2. A year's worth of "out of site, out of mind" combined with UJ3 putting a new device on a floor that isn't displayed by default had me chasing my tail!

        The "enabled" checkboxes for every device are STILL disabled on the IP Subnets tab of UJ3, so I cannot disable a device. Nor can I uncheck the "HomeSeer Device" checkbox in a device's popup.