Announcement

Collapse
No announcement yet.

UltraMon3 (Network Monitor) For HomeSeer3

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #91
    Hello

    I had to reinstall HS3 with the UltraMon plugin all works fine but there are no default icons under Device Types. This was a clean install.

    do you have any suggestions how to fix this?

    Thanks
    Mark

    Comment


      #92
      Originally posted by marekd1 View Post
      Hello

      I had to reinstall HS3 with the UltraMon plugin all works fine but there are no default icons under Device Types. This was a clean install.

      do you have any suggestions how to fix this?

      Thanks
      Mark
      Try shutting down HomeSeer, then removing ultramon3.db3 from the \HomeSeer HS3\Data\ultramon3 directory, then restarting HomeSeer.

      Regards,
      Ultrajones
      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

      Comment


        #93
        Thank you, this fixed it. Little strange though that fresh install would have corrupt DB. In any event thank you and as always your assistance is greatly appreciated!!!

        Comment


          #94
          Was TCP port monitoring on external networks ever added back in? My crappy cable modem keeps locking up and my crappy cable company won't do anything to fix it. I'd like to restart the power on the modem if a ping to an external IP address fails.

          There was discussion about this earlier in the thread, but the functionality wasn't there at the time. Just curious if it had made its way back in.

          thanks.

          Comment


            #95
            Originally posted by Ultrajones View Post
            Going forward, I will maintain a change log in the first post of this thread. Please review it for a list of bug fixes or features added.

            I highly recommend everyone upgrade to UltraMon3 HSPI version 3.0.5265.14408. This version fixes a bug that prevented a host that changed IP addresses to update properly.

            Regards,
            Ultrajones
            Thanks for fixing that. At least once a day my cable modem performs an absolute shell game with IP addresses. I have NO idea why, but the provider thinks it is just fine.
            HomeSeer Version: HS3 Pro Edition 3.0.0.500
            Operating System: Microsoft Windows 10 Pro - Work Station

            Enabled Plug-Ins:
            2.1.0.119: AmbientWeather | 3.0.21.0: BLLock | 2.0.24.0: BLUPS | 1.3.6.0: Device History | 3.0.0.56: EasyTrigger | 3.1.0.7: MeiHarmonyHub | 3.0.6681.34300: UltraCID3 | 3.0.6644.26753: UltraLog3 | 3.0.6554.33094: UltraMon3 | 3.0.0.91: weatherXML | 3.0.1.245: Z-Wave | 3.0.51: HS Touch Designer | 3.0.0.40 Z-Seer+

            Comment


              #96
              What if I wanted to run a shutdown command for a linux/unix machine? is there a way to call a script with the relevant variables rather than just the windows stuff?

              I can call SSH and run a script to do the actual shutdown, just not sure how I would fit that in.

              Comment


                #97
                Network devices not discovered

                Hi UltraJones, I've upgraded to HS3 last week. I also installed UltraMon3. It has registered 13 devices so far. I have 3 devices connected to my network that had never been discovered by the plugin (running for 5 days now).

                - 1 Xbox - wired
                - 2 Notebooks (Windows) - wireless

                All 3 devices are connected daily for a minimum of 2 consicutive hours. I provided screenshots of my router status page and also the plugin Ip Subnets.

                Can you help me solve this?

                Thanks
                Richard

                Current Date/Time: 2015-11-12 23:02:57
                HomeSeer Version: HS3 Standard Edition 3.0.0.208
                Operating System: Microsoft Windows XP Professional - Work Station
                System Uptime: 3 Days 2 Hours 8 Minutes 29 Seconds
                IP Address: 192.168.1.118
                Number of Devices: 97
                Number of Events: 68

                Enabled Plug-Ins
                3.0.0.5: AirplaySpeak
                2.0.49.0: BLLock
                2.0.17.0: BLUPS
                3.0.0.75: HSTouch Server
                3.0.0.17: iAutomate RFID
                3.0.5.20: Insteon
                30.0.0.29: RFXCOM
                2.6.2.0: SCSIP
                3.0.5755.18523: UltraMon3
                3.0.5614.14045: UltraNetCam3
                3.0.1.25: Z-Wave
                Attached Files

                Comment


                  #98
                  Originally posted by seguinr View Post
                  Hi UltraJones, I've upgraded to HS3 last week. I also installed UltraMon3. It has registered 13 devices so far. I have 3 devices connected to my network that had never been discovered by the plugin (running for 5 days now).

                  - 1 Xbox - wired
                  - 2 Notebooks (Windows) - wireless

                  All 3 devices are connected daily for a minimum of 2 consicutive hours. I provided screenshots of my router status page and also the plugin Ip Subnets.

                  Can you help me solve this?

                  Thanks
                  Richard

                  Current Date/Time: 2015-11-12 23:02:57
                  HomeSeer Version: HS3 Standard Edition 3.0.0.208
                  Operating System: Microsoft Windows XP Professional - Work Station
                  System Uptime: 3 Days 2 Hours 8 Minutes 29 Seconds
                  IP Address: 192.168.1.118
                  Number of Devices: 97
                  Number of Events: 68

                  Enabled Plug-Ins
                  3.0.0.5: AirplaySpeak
                  2.0.49.0: BLLock
                  2.0.17.0: BLUPS
                  3.0.0.75: HSTouch Server
                  3.0.0.17: iAutomate RFID
                  3.0.5.20: Insteon
                  30.0.0.29: RFXCOM
                  2.6.2.0: SCSIP
                  3.0.5755.18523: UltraMon3
                  3.0.5614.14045: UltraNetCam3
                  3.0.1.25: Z-Wave
                  Hello Richard, for the Windows devices, you'll need to enable ICMP ping. The solution depends on which Microsoft Operating System you're using and/or anti-virus software.

                  For reasons unknown, Microsoft no longer allows ICMP ping to the Xbox game consoles. I am not aware of any solution to enable it.

                  Regards,
                  Ultrajones
                  Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                  Comment


                    #99
                    That's right, my Norton Firewall was blocking ICMP pings.

                    Thank you for your help!

                    Richard

                    Comment


                      Originally posted by Ultrajones View Post
                      For Internet monitoring, I was thinking about adding a textarea (similar to the IP subnets) that allows you to specify from 0 to n IP addresses. Those IP addresses would be checked via ICMP ping, then I would update 2 HomeSeer devices to indicate an overall Internet health status. The first HomeSeer device would indicate the percentage of the number of devices that are online (so a device value from 0 to 100). The second device would track packet loss percentage (again, a device value from 0 to 100). Thoughts?
                      Sorry to pull an old post but things in life pushed my HA hobby to the background. I finally got to the point of installing UltraMon3 and was wondering if you would be able to add this ability.

                      I have several plugins that do things that need the internet up. If I can set a device based on if my connection is up or down, I can add that device as a condition in the events to keep them from running if the connection is down.
                      --
                      Jeff Farmer
                      HS 3, HSPhone
                      My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                      Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                      Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                      Comment


                        I finally upgraded to HS3Pro and purchased the Ultramon3 upgrade last night.

                        I was surprised to find no TCP ping monitoring in the new version.

                        This is primarily what I use the plugin for.

                        Is there any progress on implementing TCP?

                        Thanks for any information.

                        Comment


                          I have never been a fan of TCP monitoring by simply establishing a TCP connection to the remote port. Are the devices you need to monitoring on your local network?

                          Regards,
                          Ultrajones
                          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                          Comment


                            No, not on local network.

                            I have been using it (on HS2) to ping VPN hosts, servers and routers for some clients. It worked really well and we would be notified if a connection failed.

                            I upgraded to HS3 and Ultramon3 this week assuming it would have the same functionality. The lack of same caught me by surprise.

                            Comment


                              Me too! - I will purchase this instantly once I can monitor remote devices. I have several events I want to fire if remote devices become unavailable.

                              Comment


                                Any plans on supporting HS3 linux for this?

                                Comment

                                Working...
                                X