If you're like me, you have several inexpensive Raspberry Pi devices in your home connected to the network using the very popular Edimax WiFi wireless USB adapter. In my case, I have one Raspberry Pi dedicated to performing various Home Server functions and one dedicated as a PXE server. I also use UltraMon3 HSPI to monitor those critical devices to make sure they are always connected to the network.

I noticed UltraMon3 would usually indicate my Raspberry Pi devices were in a troubled state even though they were connected to the network. I also noticed a slight delay when attempting to log into the device via PuTTY or when attempting to use the command line after the device has been idle for several minutes.

After several hours of research, I have found the solution to this problem. It turns out the Edimax WiFi is entering some type of power saving mode. Follow the steps below to turn off this power saving feature so the network connection always stays responsive:

1) Connect to your device using PuTTY, then run sudo vi /etc/modprobe.d/8192cu.conf
2) Add the following contents to that new file you created:
options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

3) Save the file, then reboot your system.

Problem solved!

Regards,
Ultrajones
Attached Files