Announcement

Collapse
No announcement yet.

New - RainMachine Plug-in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Originally posted by noopara View Post
    I attempted to install it from the updater without success. I re-started HS and it still bombed. I uninstalled it and tried again with the same result. It shows an error in the updater indicating that there is no RainMachine. The ini file is blank. This is my first go at this plug-in. I never tried the original, so I'm a little in the dark. Is it supposed to automatically find my RainMachine or do I need to put something in the ini file?
    The .ini file shouldn't be blank. The installation should have placed a rainmachine.ini file with "PollInterval = 60000" in it.

    However, after adding a bunch of features, I never when back and tested a fresh install. The configuration screen crashes if you don't have the IP address and password of the RainMachine saved in the .ini file. So there's no way to use the plug-in to do the initial configuration. A bit of a catch 22 there.

    I've just submitted version 1.0.0.1 with this issue fixed.

    You should be able to work around the issue by manually editing the .ini file with the following:

    Password=<your rainmachine password>
    IPAddress=<your rainmachine ip address>ort
    PollInterval=60000

    Original RainMachines use port 443, the newer ones use port 8080

    With the info in the .ini file, it should start and connect to your rainmachine. There is one quirk in HomeSeer in that after starting the plug-in, you have re-load the bowser page to before the plug-in's configuration web page links will show in the menu.
    --
    Bob Paauwe
    ISYInsteon Plug-in
    http://www.bobsplace.com/ISYInsteon/

    Comment


    • #62
      Thanks. It's working great. Is the Poll Interval of 60000 in milliseconds?

      Comment


      • #63
        Originally posted by noopara View Post
        Thanks. It's working great. Is the Poll Interval of 60000 in milliseconds?
        Yes, milliseconds.
        --
        Bob Paauwe
        ISYInsteon Plug-in
        http://www.bobsplace.com/ISYInsteon/

        Comment


        • #64
          I tried to create an event and got this message: Error, Action number for plug-in RainMachine was not set. How do I set the action number?

          Also, I found that there is another forum section here https://forums.homeseer.com/forum/ir...machine-bpwwer

          I posted my question there too.

          Comment


          • #65
            Originally posted by noopara View Post
            I tried to create an event and got this message: Error, Action number for plug-in RainMachine was not set. How do I set the action number?

            Also, I found that there is another forum section here https://forums.homeseer.com/forum/ir...machine-bpwwer

            I posted my question there too.
            Yeah, when HomeSeer publishes the plug-in, they add a forum section for it so that section was just created. I answered the question there. I'll continue to monitor both, but long term, it's probably better to have questions/answers/etc in that forum section.
            --
            Bob Paauwe
            ISYInsteon Plug-in
            http://www.bobsplace.com/ISYInsteon/

            Comment


            • #66
              Any reason why the zone only runs for 8 seconds after I turn the zone on via voice command? Any way to change that to something like 5 minutes?

              Comment

              Working...
              X