Announcement

Collapse
No announcement yet.

EtherRain Error "unknown error while broadcasting"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • EtherRain Error "unknown error while broadcasting"

    Something has gone sideways...

    No changes...(yeah, I know everyone says that, but it was just a weekly reboot) and now sending perfectly good commands that worked before are now generating an error...

    "EtherTrain:runNamed - Error: unknown error while broadcasting"

    It smells like something wrong with a firewall setting...

    if I turn off Symantec Endpoint Protection's Firewall, it works as before....
    I had a rule that allows all local traffic from my local network to my HS server....everything's been fine....

    Just for giggles, I added another rule to explicitly allow all traffic between the EtherRain and the HS server (by explict IPs)..still no joy
    I also tried opening up just port 80, 8088, 8089...still nothing

    Can someone (Jim???) suggest something... I'm not a big fan of just blanket disabling the firewall on my HS server.

    I am able to connect and control the Etherrain device from the Etherrain config /admin app on the HS Server.....


    - Jim -
    My home is smarter than your honor roll student.

  • #2
    Unknown error while broadcasting...

    Just to paraphrase to make sure I understand the issue:
    When you turn off the Symantec firewall things work OK. When you turn the firewall on, you get "Unknown error while broadcasting...". Correct?

    If so, its possible that your firewall is not letting EtherRain's controller discovery packet out onto the network through Homeseer. You mentioned that EtherRain Admin does work even with Symantec Firewall on.

    I don't know how Symantec firewall is configured, but if it's similar to Windows Firewall, you have to open the ports for each program, so you have to open the discovery ports for HomeSeer: UDP 8088 and UDP 8089. Also, HomeSeer has to be allowed to send out a broadcast packet.

    If this continues to be a problem, contact me. I can send you a program that can be installed on another Windows machine on your network that will tell you if the broadcast packet is being allowed onto your network.

    Unclear as to why this started happening all at once, though could be an update to the Firewall, or a new configuration.

    Also, Symantec Firewall should have a log of all blocked traffic, if it's an enterprise firewall, so first step might be to search the Symantec log.

    Jim

    Comment


    • #3
      Thanks Jim.

      It's definitely a firewall thing, The only thing I could see being blocked is an arp 0x806.... I forced it to be allowed and it's still failing.

      I checked the UDP ports you listed and they're open as well.

      Shoot me the program and I'll give it a go.

      One of the guys who works for me just ordered an etherrain on my recommendation... and it's support like this that makes it easy to recommend. It's definitely NOT your probelm, but you're helping just the same.

      Thanks,

      - Jim -
      My home is smarter than your honor roll student.

      Comment

      Working...
      X