Announcement

Collapse
No announcement yet.

uploading pictures

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • uploading pictures

    Im trying to upload pictures in to the zones using the picture entry page.

    when saving the files / page the page reloads and pictures are lost/not uploaded. no error message or reference to image file in log.

    are there any special consideration needed to make the image part work?

  • #2
    You might try the same image file saved in a different file format. Possibly the plug-in does not accept the specific format you uploaded.

    Comment


    • #3
      Jpg is expected. Issues in the past have been with browser type, but I think I have evaluated I.E., edge and chrome. The other thing is that pictures require multipart form protocol. HS did not support it but I thought I intercepted and decoded for it. I am on vacation now but can review status when I return in a few days

      Comment


      • #4
        I See this is an old thread from 2017, but I'm seeing the same issue with photo uploads not accepted. I'm using version 2.19.4.8. now in 2019
        I tried Firefox, MS Edge, and Chrome, all with the same results.
        I reduced the image size down to 800x600 and less than 120Kb.

        What am I missing?

        Thanks!

        Comment


        • #5
          I recall in prior years that the HS server was not able to upload images (in at least the manner that mcsSprinklers is expecting as used in the standalone version). I will take a look.

          An easy way to do it is to copy the .jpg file with the exact same name as the Zone name, but with spaces replaced by underscores, into the /html/mcsSprinklers/pictures folder. Next time mcsSprinklers starts it will convert them to the correct size that it uses.

          Comment


          • #6
            I did just try it for uploaded Site and a Zone. Both worked as expected on Windows. Linux should work the same as there is no unique code in this sequence.

            From Picture Entry use the browse button to find a .jpg picture you want to use. You can do multiple if desired. When done use the Save button on the Picture Entry page. You can then click on the camera icon to popup the image or you can see it. You can also see it on the Touch and Layout pages. You can also see it as popup from the General Status or Zone Status pages via the camera icon.

            Comment


            • #7
              Success! The manual method of installing the images in the /html/mcsSprinklers/pictures folder worked. I believe you are correct that there may be a limitation to the HS web server, but I cannot figure out why I would experience that while your HS allows for uploads. Regardless, I'll leave that issue for another day, for now the images are installed. I would also like to install the site and area images. What is the naming structure for areas and the site image, etc?

              Thanks!

              Comment


              • #8
                Try again with the upload method. I tried it myself and worked without any issues. Make certain you do a Save after you have your pictures uploaded.

                To answer you question, look at the General Status page for names of every device. For the HS server I think the issue was with HS2. When jQuery was introduced in HS3 the method for binary upload became available with the server.

                Comment


                • #9
                  Still no luck. I can browse for the file and the file is accepted, however , as soon as press the save changes button, the page updates that clears the browsed file location, with no file uploaded. Anyway, it's OK for now - I have pictures in there now from the manual method.

                  Thanks for your help!

                  Comment

                  Working...
                  X