Announcement

Collapse
No announcement yet.

Problems with .16 of mcsSprinker Pro

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with .16 of mcsSprinker Pro

    Michael,

    Today I wanted to check the status of the zone because I knew some watered this morning as I had hoped. But when I went to zone status, I got the following messages. I tried to stop/start the plugin in the manage page, but when I disabled it, I see the status of the plugin is Loaded Remotely and cannot restart it. Had to restart HS3.


    Sep-12 1:23:09 PM Error Calling HSEvent in plugin MCSSPRINKLERSP, Instance :Object reference not set to an instance of an object.

    Sep-12 1:22:39 PM Error Calling HSEvent in plugin MCSSPRINKLERSP, Instance :Object reference not set to an instance of an object.

    Sep-12 1:22:36 PM Warning Cannot access remote plugin MCSSPRINKLERSP

    Sep-12 1:22:09 PM Error Calling HSEvent in plugin MCSSPRINKLERSP, Instance :Object reference not set to an instance of an object.

    It had been up without issue since the weekend update. Probably a one of... Thought I'd mention it, just the same.

    Robert
    HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

  • #2
    The plugin loading remotely means that HS3 did not start the plugin during HS3 startup or from the HS3 Manage page. This is normally the situation where the plugin is running on a different computer than HS3.

    Could this be related to use of the Other Page to load a different version of mcsSprinklers? If so the solution is just to use the Manage Page to disable/enable the plugin so it has a normal startup.

    In your case after restarting HS3 do you continue to have the same behavior of a remotely loaded plugin?

    Comment


    • #3
      Well it did it again today. The plugin starts normally at HS startup and I'm not running it remotely. It watered again today as expected... The issue seems that after it's up for a while (24 hours in my case) and I try to go into zone status, that the exception happens. I cannot shut down the plugin because it's still running. If I go into Manage Plugins and try to disable it, I get "Failed to get Interfacestatus" Object reference not set to an instance of an object.

      The only solution is a restart of HS.

      Sep-13 2:46:26 PM Warning Plugin MCSSPRINKLERSP is not responding but it is still running, not restarting yet.

      Sep-13 2:46:10 PM Error Calling HSEvent in plugin MCSSPRINKLERSP, Instance :Object reference not set to an instance of an object.

      Sep-13 2:46:09 PM Error Getting plugin GenPage: Object reference not set to an instance of an object.


      Robert
      Last edited by langenet; September 13th, 2017, 02:12 PM.
      HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

      Comment


      • #4
        You have an extra instance of mcsSprinklers.exe that is running. Use Task Manager to stop it or restart the PC to stop it. If there is also one running that was started by HS3 then stop that one from Manage plugin page.

        Comment


        • #5
          So I don't understand why I would have an extra instance of the plugin running??

          Checking via task manager isn't impossible as I'm not at home.

          I rebooted yesterday after the issue, everything seemed ok, the lawn was watered this morning. The only thing I did was go to zone status to check some 24 hours after the last reboot.

          Robert
          HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

          Comment


          • #6
            I rechecked and confirmed I have no issues with .16 going between pages and remaining connected to HS3. During startup the connection and initialization of the plugin should be shown in the HS3 log. Is this shown in your log? Based upon the irrigation occurring, but connection to HS3 does not exist it seems there was a startup issue. With .16 the redundancy status devices (89 and 90) were replaced with the download device and a spare. Do you have two S89 devices? If one is not Download Count then it can be deleted using Device Management page of HS3.

            Comment


            • #7
              It starts up fine and has always...

              Sep-13 9:44:20 PM Plug-In Finished initializing plug-in MCSSPRINKLERSP

              Sep-13 9:44:11 PM mcsSprinklers Version 2.17.0.16 | V2.17.0.16/2.17.0.16 (Professional) Copyright 2004-2017 mcsSolutions Registered with Homeseer

              Sep-13 9:44:11 PM Info Plugin MCSSPRINKLERSP has connected. IP:127.0.0.1:49945

              I only have one device id of S89. Everything works fine for a period of time after startup. It just seems that after a while while still watering, that navigating the screens fails.

              Robert
              HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

              Comment


              • #8
                When I am running with VS IDE and stop at a breakpoint too long HS3 seems to drop the connection and then I get the genpage error when I try to show a mcsSprinkler page via the HS3 server.

                There is no heartbeat that I recall to confirm HS connection still exists. I can put one in that may help with diagnostics. When the heartbeat fails then I am not aware of any auto recovery, but maybe could try restarting plugin so a new connection is established.

                I don't understand why it happens with .16 and not others as nothing that significant was done in .16.

                Comment


                • #9
                  Thanks Michael. There's one other variable here and that is that I upgraded to Windows 2016 on Sept 4th. everything seemed fine and so I upgraded to .16 on Sept 9th. It was after this that the problem was realized. Perhaps I didn't run under .15 long enough to notice. The watch-dog timer would be helpful I think. I'm not seeing any issues with any of the 19 other plugins I have however. Other than that, can you provide the link to .15. I'll give it another try.

                  The interesting part of this is that it waters as per usual. It just seems like an interface issue. So I'm not sure if it has disconnected from HS. If I stop the plugin without trying to view the zone status or anything first and then start the plugin, all is well - I can then use the interface. Going into Manage Plugins seems to support that the plugin hasn't lost connection to HS. However, if I go to the zone status first and have it hang there while it outputs the error to the log, trying to go into Manage plug in takes a quite while but I cannot stop/start the plugin again without an HS restart. One thing to try at your end is the same scenario - that is start the plugin and after 24 hours go to the pages. I can hop to any page after a restart. I can't see it being a Win2k16 issue as it is much like Windows 10 in many respects.

                  Hope this helps..

                  Robert
                  Last edited by langenet; September 15th, 2017, 10:33 AM.
                  HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                  Comment


                  • #10
                    Look at https://forums.homeseer.com/showthre...=190471&page=2 post #31 to get any prior version. You will want the hspi_mcsSprinklersP.exe and mcsSprinklers_2009.dll from the zip.

                    I tried the heartbeat and was not able to replicate the genpage failure that I have seen in the past. I will need to try to try to induce it.

                    Comment


                    • #11
                      Michael, I wanted to update you with my trial of .15. It appeared working for about 6 hours or so, but other than that, it behaved as .16 - still hanging.
                      So there must be something with Windows 2016 or running HS as a service.
                      Needs further investigation on my part...

                      Robert
                      HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                      Comment


                      • #12
                        Not sure if I'm of any help, when I updated it, it went into a remote plugin. I then reboot the server several times to get it back to normal. Hope this helps.

                        Sent from my SM-G935V using Tapatalk

                        Comment


                        • #13
                          Michael, I can see the s89 device in the general status but not in the device management, how do I get to see it there?
                          I only have 2 stations and I go over the 800 based on the device s89, how is it possible? Could you perhaps set a field where we would tell how many times or minutes we want to check the weather and would it make sense, what you think?
                          Aldo

                          Sent from my SM-G935V using Tapatalk

                          Comment


                          • #14
                            S89 has always existed as a redundancy management device. Its name has changed and button control added. If you find S89 as a mcsSprinklers device in Device Management then you can delete it and mcsSprinklers will recreate it with desired properties.

                            I am not in favor of adding user control of the update rate as the rates were chosen to achieved desired balance of usefulness of the data. The two most common reasons for excessive downloads is use of Wind as an inhibit and for a site not delivering expected format of the data or no data returned. Using Mist as the control strategy will also result in a similar behavior as Wind inhibit.

                            I think the Wind inhibit will result in a 5 minute interval for download of the Wind sensor. No/bad data results in a 1 minute interval. Both of these could be made smarter, but what you really want to do is fix the root cause. If you do not have the two conditions described above then you will get current conditions downloaded at 30 minute rate (2 x 24 = 48 downloads) and forecast at 60 minute rate (1 x 24 = 24). If Wind inhibit/Mist is enabled then (12 x 24 = 288) so even this is well under 800 unless you have 3 stations selected for download.

                            Look as \data\mcsSprinklers in Windows Explorer and observe how frequently the date changes on the download?.txt files. Open a frequently changing file and observe if normal data exists or some type of message from WU.

                            Comment


                            • #15
                              So investigating and trying a couple of things, it appears that after I disabled lldp (Responder and Mapper) protocol on the network adapter, accessing the plugin pages now seems to be working since the reboot last night under .16. I also applied an update Saturday - can't remember off hand KB number. But unchecking ldap and one other unnecessary protocol looks to have fixed it.

                              One request - somewhere along the revisions to the plugin, when my system watered, I quick look at the device utility page showed what zone watered for any given day. I think it was the on status or what. However, now the devices in the image below update periodically (not sure what triggers the update) but they all are updated to 1:07pm today in this case. I used to be able to quickly look at them and tell which were on during any given day. It would show the time it watered. Now, I need to go into the plugin (zone status) to look or check the HS log. Is it possible to revert the status update as before again?

                              Robert
                              Attached Files
                              Last edited by langenet; September 18th, 2017, 05:04 PM.
                              HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                              Comment

                              Working...
                              X