Announcement

Collapse
No announcement yet.

install interface problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • install interface problem

    mike, having this problem trying to reinstall
    Attached Files
    HS3 , Zwave, HometrollerS6, ELK M1G Ultra; mcs sprinklers; WGL800; BLRF; BLNetCallerID; BLSpeech

  • #2
    same message when i try with MCSS which i have had for years as you know. each time i update HS, your plug in goes down. something with an ini file? i dont recall from last time... frustrating. so i tried to uninstall and add... now I cant get it loaded.
    HS3 , Zwave, HometrollerS6, ELK M1G Ultra; mcs sprinklers; WGL800; BLRF; BLNetCallerID; BLSpeech

    Comment


    • #3
      here is mcss version install also
      Attached Files
      HS3 , Zwave, HometrollerS6, ELK M1G Ultra; mcs sprinklers; WGL800; BLRF; BLNetCallerID; BLSpeech

      Comment


      • #4
        I have HS3 installed on an old laptop dual core 1.7 GHz running W10. I installed mcsSprinklersB from Updater and enabled it from Plugin page. I had no issues with Interface Status as you showed.

        What I have seen in the past is an interface status that shows failure as yours when it takes too long to initialize such as when at a breakpoint during debugging.

        Could your situation be that your PC be on the slow side?

        With respect to HS3 shutdown the same situation could be happening. mcsSprinklers does through a shutdown procedure when requested by HS. If this takes longer than HS is allowing then HS may shutdown before mcsSprinklers completes and this could leave the .ini/database in an unpredictable state.

        During startup mcsSprinklers logs its progress in \HTML\mcsSprinklers\Data\StartupTrace.txt. If you post this file there may be some info that will shed light onto the situation.

        Comment


        • #5
          i am on their S6 hometroller... fast and relatively new...
          i recall in the past i had problems when updating HS3... something with ini file... any ideas what I can do.,.,., i cant enable the program now.
          HS3 , Zwave, HometrollerS6, ELK M1G Ultra; mcs sprinklers; WGL800; BLRF; BLNetCallerID; BLSpeech

          Comment


          • #6
            take a look at this from HS log
            Attached Files
            HS3 , Zwave, HometrollerS6, ELK M1G Ultra; mcs sprinklers; WGL800; BLRF; BLNetCallerID; BLSpeech

            Comment


            • #7
              MySQL.data.dll should be in \bin\mcsSprinklers. mcsSprinklersB.exe_config should be in the HS3 root and probing path in this file should include \bin\mcsSprinklers.

              Look at MySQL.data.dll properties detail and confirm the 6.2.3.0 version. Confirm there is not another MySQL.data.dll in the HS3 root. If there is then it also needs to be 6.2.3.0.

              Comment


              • #8
                mike. here's where we are. i went into HS3. i cant find the files you refer to. i cant get mcs downloaded. here is the log info. shall i erase all MCS files in HS? start clean? is there another way to load directly from you or a site? thanks
                Attached Files
                HS3 , Zwave, HometrollerS6, ELK M1G Ultra; mcs sprinklers; WGL800; BLRF; BLNetCallerID; BLSpeech

                Comment


                • #9
                  The dll is attached. It should go in \bin\mcsSprinklers relative to HS3 root. It can also be placed in the HS3 root. My experience is that the search path used is first HS3 root and then if a file of the same name does not exist there it will look in \bin and then look in \bin\mcsSprinklers.
                  Attached Files

                  Comment


                  • #10
                    Thanks Mike. This worked! replaced it in the hs3 root.
                    good now. tell me, this happens every time there is an HS3 update. anyway we can avoid? thanks again George
                    HS3 , Zwave, HometrollerS6, ELK M1G Ultra; mcs sprinklers; WGL800; BLRF; BLNetCallerID; BLSpeech

                    Comment


                    • #11
                      If HST puts the file they include in their update in the H3 root then then I am not aware of a way to avoid since the root seems to always be the first place .NET searches even though I specify a subdirectory in the .exe.config file. As a note, I do not have this issue when I update to new versions of HS3. I was not aware HS3 used MySQL. Could it be that there is another plugin that uses it and this plugin is the one that is causing the compatibility problems?

                      Comment


                      • #12
                        good question.
                        how would i determine that?
                        HS3 , Zwave, HometrollerS6, ELK M1G Ultra; mcs sprinklers; WGL800; BLRF; BLNetCallerID; BLSpeech

                        Comment


                        • #13
                          HS3 puts the SQL files it uses into the bin folder, not the root folder. If you see the files in the root folder, we need to determine how they are getting there. The HS3 update installer is not putting them there for sure. Maybe there is another plugin that is installing them there? Does this only happen when you update HS3?
                          website | buy now | support | youtube

                          Comment


                          • #14
                            rich i put them in the root folder and thats the only way i could get MCS to re-load. when hs3 was updated my mcs stopped working.
                            HS3 , Zwave, HometrollerS6, ELK M1G Ultra; mcs sprinklers; WGL800; BLRF; BLNetCallerID; BLSpeech

                            Comment


                            • #15
                              yes ONLY happens when i update hs3.
                              HS3 , Zwave, HometrollerS6, ELK M1G Ultra; mcs sprinklers; WGL800; BLRF; BLNetCallerID; BLSpeech

                              Comment

                              Working...
                              X