Announcement

Collapse
No announcement yet.

Something just broke

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Something just broke

    This has been working so well for so long -- today I was updating something else to resolve another problem and decided I might as well update MCSSprinklers to the latest (2.18.0.7). And now it doesn't work at all. I get this in the Plug-in status column of the Installed Plug-Ins page: WARNING: Failed getting InterfaceStatus from MCSSPRINKLERSP - the interface was not found in the list of active interfaces, the list may need to be refreshed. I vaguely remember it firing off an installer in the past---have you changed that, as no installer was started? Don't see how to get into your config any more. The plug-in drop down does not list MCS sprinkers (even though the installed plug-ins list includes it. Hopefully this is something stupid that you can easily point me in the right direction. A couple things I did right: HSProtect was disabled; I ran the updater on the Homeseer host machine (bnecause i expected it to fire off an installer).

  • #2
    There is no installer, just a zip file. \html\mcsSprinklers\data\startuptrace.txt contains the startup log recorded by mcsSprinklers. Post it to see what it did during startup.

    Current mcsSprinklers runs under .NET 4.0, just like HS3. Most significant change between 2.17 and 2.18 is a common code base between Windows and Linux.

    Comment


    • #3
      Here is the log.
      Also, found this in the Homeseer startup log:
      mcsSprinklers~!~RegisterCallback2 Line Line 0 Could not load file or assembly 'MySql.Data, Version=6.2.3.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x8013104
      Attached Files
      Last edited by pete@malibubeach.com; April 10th, 2018, 05:23 AM.

      Comment


      • #4
        I am guessing that you have another version of mySQL.data in the HS root or \bin that is seen before the one that should be in \bin\mcsSprinklers. Rename it or remove it. It is likely one used by an earlier version of mcsSprinklers before mcsSprinklers put the files in its specific folder.

        You can look at the detailed properties of mySQL.data to confirm version 6.2.3.0

        Comment


        • #5
          That fixed it. There was an old version in the root Homeseer directory. Deleted it and everything is back to normal. Thanks for the help!!

          Comment

          Working...
          X