Announcement

Collapse
No announcement yet.

Reset run icons

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Reset run icons

    Is there an easy way to reset all the 'zone running' icons?

    I changed some of them when I did my HSTouch screens and then decided to just use text on HST. Now some of the icons are missing so I can't see when zone is running or not from the general status page.

    Thanks

  • #2
    The zone icons are a rotating sprinkler with green, red and green animated. These are not selectable. mcsSprinklers will recreate the DeviceString with the ones it uses each time a status change occurs.

    Are you referring to some other icons?

    Comment


    • #3
      I'm referring to the ones that look like an animated 'throwing star'.

      Here's my general status page with a couple of them missing. It does regenerate them but not consistently

      https://1drv.ms/u/s!Aq5Z1mepjZh3hMcqOadPZ_CvBHyrVA

      Comment


      • #4
        If you manually turn a zone on then it will build the devicestring showing the animated icon. Manual Off will stop the animation. Even a failure will build a new red icon in the DeviceString. If you do the control from mcsSprinklers GeneralStatus then it will eliminate other variables of the On and Off commands getting to mcsSprinklers.

        Comment


        • #5
          Originally posted by Michael McSharry View Post
          If you manually turn a zone on then it will build the devicestring showing the animated icon. Manual Off will stop the animation. Even a failure will build a new red icon in the DeviceString. If you do the control from mcsSprinklers GeneralStatus then it will eliminate other variables of the On and Off commands getting to mcsSprinklers.
          Sorry - I'm not sure I understand what you mean.

          On the image I linked there is no information in the status column of A8 or A6. I was turning these zones on and off from the general status page while doing some maintenance.

          Comment


          • #6
            Next step would be to look at logs to see what may have happened that prevented the DeviceString from being built.

            Comment


            • #7
              Originally posted by Michael McSharry View Post
              Next step would be to look at logs to see what may have happened that prevented the DeviceString from being built.
              Will do.

              In the meantime I have one other thing I've noted.

              On the mobile page that you provide for zone control ( the /handheld page) it only loads this page the first time you enter it. Once you control a zone from here it then redirects you to the desktop version of the general status page.

              Comment

              Working...
              X