Announcement

Collapse
No announcement yet.

fault monitoring with EtherRain8

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • fault monitoring with EtherRain8

    Michael,

    I am using version 2.18.5.1 with two EtherRain8 rev C boxes.

    1) I have the option 'request status every minute' enabled. If I unplug the network cable, no fault is indicated by any HS device nor is there any message in the logs indicating this.

    2) If I specify an incorrect password (did this accidentally!) for the EtherRain8 box and then turn on a valve, the valve appears to be 'on' according to the HS device and the mcsSprinklers log. However the valve is not actually turned on. No fault is presented.

    I will send you debugging logs.

    I am attempting to improve the monitoring of the link between my HS box and every hardware subsystem. It would be great if the plug-in could provide a single HS
    device that indicates if communication is currently in an 'up' state or in a 'fault' state with communications to/from the external hardware. I would like to monitor this one device and then notify myself to investigate any fault. I get nearby lightning strikes frequently and sometimes the external hardware simply has to be power-cycled to recover.

    Would you consider implementing this?

  • #2
    I will look at the status reporting. I got from Jim what I need to do to get status-only from Rev C. Adding a device should be doable.

    Comment


    • #3
      Thanks for making this improvement. I have been running version 2.18.6.1 with the new S90 device that reports the link status. I can yank the network cable and get an email 5 minutes later indicating the EtherRain8 box has gone away (via a HS event, which is ideal). I verified that disconnecting either box properly generates the fault status. The 'connected' status returns 1 minute after plugging the cable back in. So cool...

      Comment

      Working...
      X