Announcement

Collapse
No announcement yet.

Water supply config problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Water supply config problem

    hi Michael.

    I've been running water consumption measurement and recording in my mcsSprinklers setup for several years. It's very valuable for evaluating water delivery and for troubleshooting leaks and faults.

    I have only just noticed an anomaly: I am not getting water consumption readings for all of my zones.

    Looking into it more deeply, it appears to be just Area 6 that is affected. I have 6 Areas configured, for different combinations of inhibit times etc. When I go to the Area Settings page, there is no "Water Supply" section for Area 6. Hence there is no place to put in the water meter feed information. Areas 1 to 5 all have the normal Water Supply section, but for Area 6 it's missing.

    Just to experiment I created a seventh Area temporarily. This also showed in the Area Setup page with no Water Supply settings.

    I have attached browser prints of these examples for evidence, along with my ini file.

    I presume this is not the expected behaviour?

    As an aside, it would make the Area settings page much easier to manage if the UI was re-arranged to edit the settings for just one Area at a time. It gets to be a very long page with six Areas configured. Just a thought.
    Attached Files

  • #2
    Michael,
    assuming you didn't get notified of this post either... perhaps you can take a look.
    cheers
    Damon

    Comment


    • #3
      Correct in that I missed it. It is likely related to the interview that probably setup 5 Areas and then a 6th was added later. Two ways to correct it. You will notice the following segment in your mcsSprinklers.ini. Make WATERMETER5 WATERMETER5SOURCE look like the first five.

      [code]
      WATERMETER0=djb.HaMonService.homeserverrivewayTop.WaterMeter
      WATERMETER0SOURCE=1
      WATERMETER1=djb.HaMonService.homeserverrivewayTop.WaterMeter
      WATERMETER1SOURCE=1
      WATERMETER2=djb.HaMonService.homeserverrivewayTop.WaterMeter
      WATERMETER2SOURCE=1
      WATERMETER3=djb.HaMonService.homeserverrivewayTop.WaterMeter
      WATERMETER3SOURCE=1
      WATERMETER4=djb.HaMonService.homeserverrivewayTop.WaterMeter
      WATERMETER4SOURCE=1
      WATERMETER5=
      WATERMETER5SOURCE=
      WATERMETER6=
      WATERMETER6SOURCE=
      WATERMETER7=
      WATERMETER7SOURCE=
      [//code]

      The second way is from the mcsSprinklers Other Page at the bottom and set from User to Expert mode. When you go to Area page then the water meter settings will be available and you can correct it. You can restore User mode to declutter the browser pages after the fix has been made.

      Comment


      • #4
        thanks Michael... fixed now

        Comment

        Working...
        X