Announcement

Collapse
No announcement yet.

Forecast Rain percentuale issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Michael McSharry
    replied
    The 0;0;0;0;0 is likely wrong. I submitted http://mcsSprinklers.com/mcsSprinkle...9_4_15_HS3.zip to the updater so it should soon be available for update via that mechanism.

    Originally forecast rainfall was provided as a percentage. This mapped nicely into an icon that is shown on the status page. Some providers now deliver forecast amount of rain. In mm this works, but with units of inches it does not and always shows as 0. To deal with it I scaled the inches amount up by 100. This needs to be done dynamically since some users have metric and some users select providers with amount and some with percentage.

    When setting forecast rainfall restrictions the scaling is not done so if the provider uses amount and imperial units are used then a forecast limit of 0.2 is entered for 0.2 inches.

    Leave a comment:


  • Michael McSharry
    replied
    When I looked further I see I was looking at current conditions and not forecast where only one value was being picked up. I did find the parsing issue. I also found OWM difficult to evaluate rainfall in current conditions. They will provide the rainfall the last hour, last 3 hours or provide no data if no rainfall in the current reporting hour/3-hours. It really needs to run throughout the day so each delta measurement can be accumulated. I uploaded http://mcsSprinklers.com/mcsSprinkle...9_4_14_HS3.zip. I also found a problem with APIXU on the evaluate button that was fixed as well.

    Leave a comment:


  • langenet
    replied
    Do you want to try my coordinates? Lat:45.27 Long:75.75

    Yet according to Environment Canada - Thursday: Cloudy. Periods of rain beginning this morning. High 22. UV index 3 or moderate.
    Rain 0; 0; 0; 0; 0

    Leave a comment:


  • Michael McSharry
    replied
    When I look under the hood I see OWM provides forecast for rainfall in three hour increments and I have been only using one rather than the sum of all eight for a given day.

    Leave a comment:


  • langenet
    replied
    Yes, I get data but forecast rain is all zeros. Interesting, in the OP the forecast is noted as "Forecast Rain Percentage" while I only have "Forecast Rain" in both the device management page and "General Status" page.

    Leave a comment:


  • Michael McSharry
    replied
    I use OWM and it does provide forecast rain for my location. Do you not get data when doing Evaluate Internet Download from Selected Stations and OWM was selected as your forecast provider?

    Leave a comment:


  • langenet
    replied
    Does Open Weather Map offer forecast rain? I don't see anything in this regards. Should I configure for APIXU instead?

    Leave a comment:


  • Automate
    replied
    Thanks Michael! Fixed and working now using 2.19.4.9!

    Leave a comment:


  • Michael McSharry
    replied
    I believe you will find the issue to be zip code which I suspect you have not entered since you are not USA. Either enter some dummy zip code or use http://mcsSprinklers.com/mcsSprinkle...19_4_9_HS3.zip. My upload is slow so do act immediately if you are going to upgrade.

    Leave a comment:


  • Automate
    replied
    Hi Michael,
    Thanks for the quick response!

    Now I have at least an hour since the update. I have had the issue since installation - I just updated from .7 to .8 to check to see if that would help. The forecast devices never seem to update - they show the time/date of the last reboot/startup and never update from there. Although the S87 device shows forecast updates, this doesn't match with the timestamp on the weather site download check. The forecast devices were set to PWS (see image below).

    I enabled debugging and see these lines of interest:

    Code:
    019-05-23 12:07:18 PM 636942100386048751 | mcsSprinklers Debug | Links=
    2019-05-23 12:07:18 PM 636942100386828752 | mcsSprinklers Debug | Links=
    2019-05-23 12:07:18 PM 636942100387028752 | mcsSprinklers Debug | DeviceValue S89=100
    2019-05-23 12:07:18 PM 636942100387078748 | mcsSprinklers Debug | SendXapBSC S89 rtbXapBSC=False, ContainsKey=True
    2019-05-23 12:07:18 PM 636942100387088744 | mcsSprinklers Debug | No internet data returned from TWC Forecast site https://api.weather.com/v3/wx/forecast/daily/5day?geocode=4X.80,-12X.61&units=e&language=en-US&format=json&apiKey=**API-KEY-REMOVED**
    2019-05-23 12:07:18 PM 636942100387088744 | mcsSprinklers Debug | TWCJson Data=
    2019-05-23 12:07:18 PM 636942100387088744 | mcsSprinklers Debug | GetPWSWeather DownloadCount=5, DownloadDeviceOn=True
    Click image for larger version  Name:	Screenshot (6).png Views:	0 Size:	258.1 KB ID:	1306879

    Leave a comment:


  • Michael McSharry
    replied
    Have you been running for at least 45 minutes since installing 2.19.4.8? None of your devices have been updated yet. I see you download of PWS, but do you have the individual sensors selected to come from a PWS source?

    Leave a comment:


  • Automate
    replied
    Hi Michael,

    I have an issue that seems related to the OP. My forecast data appears to be correct, however the HS devices do not indicate any forecast data.I'm running 2.19.4.8

    Thanks!


    Click image for larger version

Name:	Screenshot (4).png
Views:	88
Size:	329.4 KB
ID:	1306852

    Leave a comment:


  • alphatech
    replied
    Originally posted by Michael McSharry View Post
    It was showing the forecast rain, but expecting a percentage and APIXU was reporting forecast amount. You had less than 1 inch forecast. This is similar to a couple other providers so I took care of APIXU in 2.19.4.7 so it works in inches X 100 rather than a percent on the display. I will submit to updater.
    Thanks Michael

    Sent from my SM-G935V using Tapatalk

    Leave a comment:


  • Michael McSharry
    replied
    It was showing the forecast rain, but expecting a percentage and APIXU was reporting forecast amount. You had less than 1 inch forecast. This is similar to a couple other providers so I took care of APIXU in 2.19.4.7 so it works in inches X 100 rather than a percent on the display. I will submit to updater.

    Leave a comment:


  • alphatech
    replied
    Michael, thanks for your fast reply, please see attachments. The rain shows on the weather download test but not on the devices.

    Thanks,
    Aldo
    Attached Files

    Leave a comment:

Working...
X