Announcement

Collapse
No announcement yet.

Device problem now with Rain8 devices since latest update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Device problem now with Rain8 devices since latest update

    Michael,

    I updated the plugin on Sept 1st from 2.19.4.18 to 2.19.9.1 and now it appears that using my Rain8.net devices are extremely problematic.
    I have used a virtual server port (VSPE application which creates port 6) which connects to an iTech IP2SL device which then connects to the rain8 master module for 8 years now. With 2.19.4.18 and before this worked flawlessly. Never a problem across reboots or anything.
    Now since the latest release, I managed to get it to work once across 3 reboots and keep getting timeouts. As per the I/o log:

    9/8/2019 6:44:27 PM | 2073515 | NET(0) OUT | 40, 01, 41

    9/8/2019 6:44:32 PM | 2078531 | Net Send Timeout
    9/8/2019 6:44:32 PM | 2078531 | NET(0) OUT | 40, 01, 41
    9/8/2019 6:44:37 PM | 2083546 | Net Send Timeout

    Did you make changes here? As I have 20 days of BLBackups, what's the easiest way to roll this back to test if I need to or can you please take a look if there were code changes?

    Robert
    HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

  • #2
    No recent changes in any of the low level protocols since GoControl was added several months ago. A debug log is the next step.

    Comment


    • #3
      I'm not sure, but something has changed in my setup. I start HS as a delayed service such that the VSEP can run first and get all setup before HS starts.
      As a test, I'd like to restore 2.19.4.18 and test again but I don't see this as an option in the other's page to restore. Just older ones...

      If there is a way to roll back and if I go to Mange Plugins will I see the checkbox to update again or how is this best handled?

      Robert
      HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

      Comment


      • #4
        The files in updater format for 2.19.x.x are at http://mcsSprinklers.com. There have been changes to both HSPI...exe and MCSSPRINKLERS_2009.dll. You wlll want to get both and replace what is in your HS folder. Disable plugin and move the files. Reenable plugin. The sticky at the top of the thread has the log of changes for each version.
        Click image for larger version

Name:	Capture.PNG
Views:	23
Size:	85.5 KB
ID:	1325415

        Comment


        • #5
          Thanks I do have my own backups. So HSPI_MCSSPRINKLERSP.exe and MCSSPRINKLERS_2009.dll is all I need to replace in the HS3 root folder?
          HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

          Comment


          • #6
            Correct. I am running 2.19.5.0 on Linux standalone with some of my valves interfaced with Rain8Net and they have been functioning as expected the past week.

            Comment

            Working...
            X