Announcement

Collapse
No announcement yet.

mcsSprinklers Pro Faults

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mcsSprinklers Pro Faults

    Michael, need some help here. Recently changed to a RainNet+ with one Expansion unit. Also changed to three areas instead of one. Communications test shows green for a while, then goes to red. All the zones "fail" eventually. Have attached the .ini and can send recent log. log is too big ( even compressed) for this board. Don't know where to go from here. Your assistance is appreciated
    Attached Files

  • #2
    You can email the zipped log to mcsSolutions at CenturyTel dot net.

    A common issue with Rain8Net is the serial interface and the ability of it to actually reach/cross the zero level threshold. RS-232 goes +12V -12V but most adapters used today are 0V to 5V. The Pro version of the Rain8net has the Max32 device on the front end to better handle the more modern interfacing equipment. I am not saying this is your problem, I am just sharing information.

    Comment


    • #3
      Thanks for the response. Sent you a log. Changed the interface from a usb/serial adapter back to a serial port via a PCIe card, Still getting the "fail" even though the zone is still actually running. I had a Rain8net Pro that worked well.

      Comment


      • #4
        I do not see any attempt to control a valve in the debug output. Manual turn on and off from General Status is what I normally do to just test basic operation. After doing the manual test use the Other Page bottom to flush the debug cache onto the disk. This will create a new file so the one you want is not that last one, but the prior one when looking with explorer.

        I do see the following which shows that the three Area are not running due to not being scheduled for this day.
        Code:
        1/21/2020 12:01:00 AM 637151616603962917 | mcsSprinklers Debug | Sprinklers not enabled for area 1 because Day of Week Control Strategy for Day 2 is not selected
        1/21/2020 12:01:00 AM 637151616603962917 | mcsSprinklers Debug | rtiAreaRoundRobinDelay(1)=0, rtiAreaInterZoneDelay(iArea)=0, bPriorAreaInDelay=False, rtiAreaContinueStartedArea(iArea)=1, iAreaInhibit=0, rtiAreaDelayedETStartState(iArea)=1, bDoTurnOnByArea(iArea)=TruebAreaKeepZoneOn(iArea)=False
        1/21/2020 12:01:00 AM 637151616603962917 | mcsSprinklers Debug | Sprinklers not enabled for area 2 because Day of Week Control Strategy for Day 2 is not selected
        1/21/2020 12:01:00 AM 637151616603962917 | mcsSprinklers Debug | rtiAreaRoundRobinDelay(2)=0, rtiAreaInterZoneDelay(iArea)=0, bPriorAreaInDelay=False, rtiAreaContinueStartedArea(iArea)=1, iAreaInhibit=0, rtiAreaDelayedETStartState(iArea)=1, bDoTurnOnByArea(iArea)=TruebAreaKeepZoneOn(iArea)=False
        1/21/2020 12:01:00 AM 637151616603962917 | mcsSprinklers Debug | Sprinklers not enabled for area 3 because Day of Week Control Strategy for Day 2 is not selected

        Comment


        • #5
          I notice on your setup on the Interface/Devices/Rain8 page that you have specified 2 Rain8Net Master modules. In your case you have one Master and one Expansion so your setting for number of masters should be 1.

          Comment


          • #6
            Went back to Pro series. Everything seems to be okay now.

            Comment

            Working...
            X