Announcement

Collapse
No announcement yet.

New user, several questions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Do you have a predict issue of zones not being shown when they are not either manual control or disabled?

    Comment


    • #17
      Originally posted by Michael McSharry View Post
      Do you have a predict issue of zones not being shown when they are not either manual control or disabled?
      Yes, or so it seems, unless my understanding of the run list is incorrect. Following is the run list during an Area1 cycle this morning. The cycle is R1, R2, R3...R7. R4 is currently running. Instead of R5-R7 showing as the next zones to run, their start-time on the next scheduled day is shown.

      Click image for larger version

Name:	Capture0720.JPG
Views:	30
Size:	171.4 KB
ID:	1368911

      A few minutes later after R5 starts, same thing...
      Click image for larger version

Name:	Capture0724.JPG
Views:	24
Size:	169.5 KB
ID:	1368912

      At present I have all Areas scheduled for fixed days/times to start. I'm slowly figuring out that the PI may prefer to run on a more automated basis (ET calcs, etc.) and perhaps these pages aren't able to display the data correctly with start date/time constraints. I may eventually move to ET calcs but for now I'm more comfortable with scheduling.
      -Wade

      Comment


      • #18
        This is probably just a slightly different manifestation of the same issue in the previous post. These images were both take a few moments ago.

        Area 1 is scheduled to start at 7:00pm today. Inhibit device correctly reports this.
        Click image for larger version  Name:	Capture.JPG Views:	0 Size:	145.1 KB ID:	1369000

        But the run list doesn't show the Area 1 zones scheduled today at all. I'm confident they'll run, as they did this morning, but I can report back later to confirm if you'd like.
        Click image for larger version  Name:	Capture1.JPG Views:	0 Size:	172.6 KB ID:	1369001
        -Wade

        Comment


        • #19
          When I tried to replicate previously I observed that you had two zones scheduled for manual control. Can you provide your mcsSprinklers.ini file that reflects what you posted?

          Comment


          • #20
            Originally posted by Michael McSharry View Post
            When I tried to replicate previously I observed that you had two zones scheduled for manual control. Can you provide your mcsSprinklers.ini file that reflects what you posted?
            Sent via email.
            -Wade

            Comment


            • #21
              Another data point, FWIW. This morning around 7:00am I checked the run list and nothing showed scheduled for today, despite the Area A4 zones showing up yesterday for watering today (images in prior post). The A4 zones did run this morning as scheduled, though.
              -Wade

              Comment


              • #22
                When I looked this morning at run list I see A4 zones scheduled for their first run cycle today. I also noticed that R11 and R15 are programmed with 0 auto times. I will investigate further if the 0 causes any issues. I will also try some other scenarios to try to replicate your observations in the run list. If I do not have success then I will add debug to the prediction logic so a trace can be obtained from your system.

                Comment


                • #23
                  That's strange. My config shows R11 & R15 with 10 & 5 minutes auto, respectively. Have you loaded the config I emailed yesterday? I captured that config yesterday by using the Email button at bottom of the Other Setup page--which emails both the debug log and mcsSprinklers.ini.

                  Click image for larger version  Name:	Capture.JPG Views:	0 Size:	118.0 KB ID:	1369156
                  -Wade

                  Comment


                  • #24
                    I thought I captured yesterday's file. I have different test setups and perhaps saved it to the wrong one.

                    Comment


                    • #25
                      I did find an issue that was caused by javascript for the popup in rainfall device that was used to assess if predicted time will be affected by the current day's rainfall. I also added detail in the debug for prediction in general. After we confirm the prediction is working as expected then this debug should be pared down so the file does not get too big too fast.

                      The update will be at http://mcsSprinklers.com/mcsSprinkle...20_0_4_HS3.zip. The only file needed is MCSSPRINKLERS_2009.dll to replace the existing one in your HS folder. If want version to be updated to 2.20.0.4 in HS display then also replace HSPI_MCSSPRINKLERSP.exe.

                      Internet has been problematic today and upload just does not want to happen right now. I will try a little later. This often happens when Google, Apple, or Microsoft push updates that consume all my meager bandwidth.

                      Comment


                      • #26
                        Thank you Michael. I've copied over both the .dll and .exe.

                        On restart, the run list populated with the Area 4 zones scheduled to run and immediately began watering. Local time was 6:57, but the area was scheduled to start at 8:15pm. Once the first zone (R12) was done watering, it remained at top of the run list, showing a start time in the past (12am today).

                        Click image for larger version

Name:	Annotation 2020-03-10 190156.jpg
Views:	24
Size:	123.4 KB
ID:	1369244

                        Here's the run log showing R12 ran for 3 minutes.
                        Click image for larger version

Name:	Annotation 2020-03-10 190518.jpg
Views:	21
Size:	45.5 KB
ID:	1369245

                        Before I finished typing the post, the next zone finished. Here's the run list after R13 turned off.
                        Click image for larger version

Name:	Annotation 2020-03-10 1905182.jpg
Views:	21
Size:	106.9 KB
ID:	1369246
                        -Wade

                        Comment


                        • #27
                          It is hard to establish a starting state following a restart. There are many reasons that a restart occurs, such as a power outage, so wait until tomorrow when everythings gets a midnight restart. This can nearly be simulated with a Zone Satus Stop All, Restart button bushes.

                          Comment


                          • #28
                            Understood.

                            By the way, Area 4 has started at 8:15pm as scheduled so...so far so good.
                            -Wade

                            Comment


                            • #29
                              Originally posted by Michael McSharry View Post
                              It is hard to establish a starting state following a restart. There are many reasons that a restart occurs, such as a power outage, so wait until tomorrow when everythings gets a midnight restart. This can nearly be simulated with a Zone Satus Stop All, Restart button bushes.
                              Good morning Michael. After cycling through a few scheduled areas yesterday and this morning, all appears to be working well. I'll report back if I observe anything unexpected.

                              I have a couple other questions, but I'll start new threads for them to make tracking simpler (for me at least).

                              Thanks.
                              -Wade

                              Comment

                              Working...
                              X