Announcement

Collapse
No announcement yet.

Sonoff Failback Irrigation Controller

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Sonoff Failback Irrigation Controller

    I am trying to follow your guide in the mcsMQTT documentation for setting up a Failback Irrigation Controller (chapter 17.6) using two Sonoff 4CH Pro.

    I flash the devices with your mcsTasmota firmware (mcsTasmota6418_Irrigation.bin) and used "IrrigationValve" as topic in the MQTT parameters. In the Full Topic I used "IrrigationValve/Bakhus/" for the first device and "IrrigationValve/Uteplass/" for the second device. If I used "%topic%/" in the full Topic the mqtt message in the association table get overwritten, when the devices are reporting to the server every 5 minuts. Both clients reports the same topic.

    Click image for larger version  Name:	MQTT parameters.PNG Views:	0 Size:	11.8 KB ID:	1389147

    Because I use "IrrigationValve/Bakhus/" and "IrrigationValve/Uteplass/" in the full topic I get six HS devices for setup for irrigation control. I do not use the two last switches on the Sonoff. In the mcsSprinklers Interface Setup I do not have enough place to put in the two last hs devices.
    IrrigationValve/Uteplass/POWER1
    IrrigationValve/Uteplass/STATE:POWER4

    When I save the setup the devices showing as lightblue in the picture are not saved.


    Click image for larger version  Name:	MQTT valve.PNG Views:	0 Size:	52.6 KB ID:	1389148
    How can I fix this? The easiest way is to make changes to the mcsTasmota client's configuration I think.

    #2
    The table shown in the screenshot is setup with one row for a command in the first column and a corresponding status acknowledge in the second column. The topic xxx/cmnd/POWER4 will use xxx/POWER4 in the second column. You will not be using any xxx/STATE:yyy topics for the valves.

    mcsSprinklers provides 4 blank rows in the setup. Since the command topic is what controls the valve that is the column that is used as the count of number of display rows needed.

    Comment


      #3
      Thanks for the help Michael. After reading the your mqtt documentation I understand a more.

      I made a unique topic on each Sonoff like this:
      Click image for larger version

Name:	MQTT valve updated.PNG
Views:	96
Size:	11.5 KB
ID:	1389672

      Then I made a Auto Association of MQTT Command Topic and HS Device i mcsMQTT.
      Click image for larger version

Name:	hs devices from MQTT association.PNG
Views:	54
Size:	27.0 KB
ID:	1389673

      In the mcsSrinklers Device Setup I used the MQTT Command Topics and the corresponding status acknowledge .

      Click image for larger version

Name:	MQTT parameters_updated.PNG
Views:	62
Size:	46.2 KB
ID:	1389671
      Today I had my first automated watering and it worked.

      Comment


        #4
        That is great!

        I noticed that you are not using the monitoring features of the firmware in the Sonoff. The most typical configuration is to use "Only On Times". When this is selected then mcsSprinklers will send the mode configuration topic to the Sonoff and have it automatically turn off a relay if an Off command is not received within a minute or two of the expected duration.

        Comment


          #5
          Thank you for your feedback. I switched my nodemcu with switch to Sonoff 4CH Pro to get failover irrigation controller. Didn't realize it was as easy to configure as choosing "Only on times".
          Thanks again Michael

          Comment

          Working...
          X