Announcement

Collapse
No announcement yet.

Automatic scheduling not respecting times on Program Setup page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Automatic scheduling not respecting times on Program Setup page

    Michael,

    The automatic watering durations I've overridden in the Program Setup do not appear to be respected. I've overridden several to zero for one start time (highlighted yellow) but all zones in the Area are running their default auto durations**. Let me know if you would like me to send a detailed log.

    Click image for larger version

Name:	Capture.PNG
Views:	105
Size:	30.1 KB
ID:	1408282

    Click image for larger version

Name:	Capture1.PNG
Views:	81
Size:	96.4 KB
ID:	1408283

    ** The zones actually ran the first of what should have been 2 round robin cycles, so each zone ran half its default auto duration. The only inhibit that could have stopped the round robin cycling is rain, and my Rain Today and Rain Forecast inhibit devices haven't changed value since July 21 so that's not it.

    Click image for larger version

Name:	Capture2.PNG
Views:	76
Size:	82.2 KB
ID:	1408284
    Click image for larger version

Name:	Capture3.PNG
Views:	77
Size:	81.4 KB
ID:	1408285

    Thanks for looking into it.
    -Wade

    #2
    It is always preferable to look at actual data rather than trying to recreate it. mcsSolutions at CenturyTel.net via email or post a zip that contains the debug file. \Config\mcsSprinklers.ini is often helpful to understand the setup.

    Comment


      #3
      Originally posted by Michael McSharry View Post
      It is always preferable to look at actual data rather than trying to recreate it. mcsSolutions at CenturyTel.net via email or post a zip that contains the debug file. \Config\mcsSprinklers.ini is often helpful to understand the setup.
      log and settings files emailed
      -Wade

      Comment


        #4
        The assumption that I made in the Programs entry is that times are entered in increasing order. Program time 2 is after program time 3. I did not try to repeat based upon your data, but this is likely the cause. Swap the entries for Program time 2 and 3.

        Comment


          #5
          Originally posted by Michael McSharry View Post
          The assumption that I made in the Programs entry is that times are entered in increasing order. Program time 2 is after program time 3. I did not try to repeat based upon your data, but this is likely the cause. Swap the entries for Program time 2 and 3.
          Michael, this was indeed the issue. As it happens, I also had another Area where I had recently added a 3rd watering time during the day--due to drought conditions--so that one also was not watering properly. I had not noticed that one.

          This is not an intuitive constraint on configuration entries. I would like to request a change to remove the constraint or else provide some sort of data integrity check at those entry fields.

          Thank you.
          -Wade

          Comment


            #6
            I agree with you. I just wanted confirmation that this was the issue. Now mcsSprinklers will put the times in the proper order before saving them and does some minor time validation. http://mcsSprinklers.com/mcsSprinklersP_2_20_4_32.zip

            Comment


              #7
              Originally posted by Michael McSharry View Post
              I agree with you. I just wanted confirmation that this was the issue. Now mcsSprinklers will put the times in the proper order before saving them and does some minor time validation. http://mcsSprinklers.com/mcsSprinklersP_2_20_4_32.zip
              Michael, another oddity I'm seeing now with 2.20.4.32. The run list isn't showing the correct zones scheduled for tomorrow. I realize it would be more telling to wait until after the scheduled waterings tomorrow to see if the watering occurs, but just didn't show on the run list, or if the waterings don't occur at all. However, our drought watering restrictions only allow watering on Thursday so I'd like to ensure it's working.

              In the images below, note Area 1 that should be scheduled for all 7 zones to water. The run list only shows 2 zones scheduled--the two scheduled for 10:00am.

              Log and config files emailed.



              Click image for larger version

Name:	Capture1.PNG
Views:	59
Size:	41.6 KB
ID:	1410749


              Click image for larger version

Name:	Capture2.PNG
Views:	64
Size:	97.0 KB
ID:	1410747

              Click image for larger version

Name:	Capture.PNG
Views:	49
Size:	63.0 KB
ID:	1410748
              -Wade

              Comment


                #8
                The prediction and the execution logic are independent so I expect you will have normal operation on Thursday. I took a quick look at your data and I do not think there is much in the debug related to prediction. I will look again tomorrow morning.

                Comment


                  #9
                  Thanks for the quick look Michael. Relieved to know my thirsty turf likely will live to see another week!
                  -Wade

                  Comment


                    #10
                    Originally posted by Michael McSharry View Post
                    The prediction and the execution logic are independent so I expect you will have normal operation on Thursday. I took a quick look at your data and I do not think there is much in the debug related to prediction. I will look again tomorrow morning.
                    Scheduled operation did in fact run as intended this morning. Also, the Run List is currently correct for the next programmed time this evening. I'll check the run list from time to time to watch for further anomalies.
                    -Wade

                    Comment


                      #11
                      I found issue with predictions that occur with multiple programs after the first program's time and the prediction was for a future day. Update is at http://mcsSprinklers.com/mcsSprinklersP_2_20_4_33.zip or the upload facility on Other page for standalone.

                      Comment


                        #12
                        What a timely post. I was just coming in here to post a very similar situation. Gonna try the new ..._33 version and see if it works for me also. Thanks!

                        Comment

                        Working...
                        X