Announcement

Collapse
No announcement yet.

Accuweather stopped working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Accuweather stopped working

    Hi Michael, I stopped getting current and forecast data from Accuweather a couple of days ago. Did they change something to break the downloading process? I checked on their webpage, they still have it for my zip code. I am running standalone version .31

    #2
    I am running the same version of mcsSprinklers as you and I continue to get updates from Accuweather. The \Data\mcsSprinklers folder contains the URLs. URL1.txt is for the forecast. You can try it in a browser to test independent of mcsSprinklers.

    Comment


      #3
      I switched forecast sourse to NWS/NOAA earlier today to get around problems I had with Accuweather. Now I changed it back to Accuweather, saved settings, hit evaluate internet download button, still getting no forecast data (all blanks). Also noticed time stamp for url1.txt and download1.txt were stuck at about 20 minutes earlier. Restarted mcsSprinklers, those two files still not updating. Updated mcsSprinklers from v31 to .33, still no change.

      Here is the content of url1.txt file:

      http://www.weather.gov/forecasts/xml...&Submit=Submit

      Comment


        #4
        The URL1.txt that you posted is the one for NWS. Forecast is every hour so need to leave it at Accweather for at least an hour before URL1.txt will be updated and a download attempted.

        Comment


          #5
          I left it for a few hours, URL1.txt never got updated. It seem as soon as forecast source was changed to Accuweather, URL1.txt got stuck at old setting and never got updated. Its time stamp stayed at a few hours ago when it was first switch back to Accuweather and its content stayed the same as well (as NWS/NOAA).

          What I need to do to reset this? Would deleting URL1.txt and restart mcsSprinklers fix it?

          Comment


            #6
            Micheal, my URL1.txt just got stuck with NWS/NOAA from a few days ago despite I already changed to Accuweather. How do I fix this? If I restore to an older version of mcsSprinklers, will it reinstall everything without losing my configurations?

            Below is URL1.txt content, hasn't changed for two days:

            http://www.weather.gov/forecasts/xml...&Submit=Submit

            Click image for larger version

Name:	data.png
Views:	92
Size:	9.1 KB
ID:	1411904
            Attached Files

            Comment


              #7
              Do you have the download device turned off (S89)? Do you have a download max that is limiting your download ability?

              You can go back to earlier versions, but it is better to move forward and fix any issue that may exist. Also there could be issues if you are on 2.20.4.x and go back to a version 2.20.0.x. The "4" are changes to allow migration to HS4.

              Comment


                #8
                I noticed that S89 is hidden if either a weather source or forecast source is selected as NONE. This was fixed in http://mcsSprinklers.com/mcsSprinklersP_2_20_4_34.zip.

                Comment


                  #9
                  My internet went out for a few days during recent storm (power was still on), when internet came back I stopped getting Accuweather downloads. Could this cause downloads to exceed max? Or do you think some file might get corrupted?

                  After updating to .34, S89 is showing as blank with on/off button on right side. What do I need to do from here?

                  Comment


                    #10
                    Click the On button to assure the device is enabling downloads.

                    Comment


                      #11
                      I tested .34 and have a few observations:

                      after turning S89 to "on", I can get correct Accuweather data when hitting "evaluate internet download" on weather setup page and get correct download. Number of download displayed in S89 is also increasing, but forecast data from S73 to S76 do not update.

                      Also after a restart, S89 appears to default to off (evaluate internet download will not work, unless I manually turn S89 on again).
                      Click image for larger version

Name:	general.png
Views:	99
Size:	77.7 KB
ID:	1412004

                      Click image for larger version

Name:	test.png
Views:	73
Size:	11.4 KB
ID:	1412005

                      Comment


                        #12
                        Hi Micheal, some progress...after clearing browser cache and reset all weather setups, I got accuweather current and forecast download working. Only problem remaining is after a restart, S89 needs to be manually turned on again to download weather data. Is this expected behavior?

                        Comment


                          #13
                          No it is not expected. I will look at the initialization. Likely not saved in the standalone, but will look tomorrow.

                          Comment


                            #14
                            I ran a test and got the expected behavior with the S89 state persisting a restart. What do you have entered for the download limit count on the Weather Sensor Setup page? It is under the text boxes for entered the weather provider licenses.

                            Comment


                              #15
                              That box was left blank (actually I don't remember touching it, just copied over old config files from HS2 days a long time ago...). What number should I set it to? I only use Accuweather for both current and forecast data.

                              Comment

                              Working...
                              X