Announcement

Collapse
No announcement yet.

strange behaviour Pump control

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    strange behaviour Pump control

    first my setup.Just "migrated "" from to a waterpump setup. I use version 2.21.4.3 on homeseer 3 and a etherrain device (7P with the latest revision ). Setup details can be found in the pictures .

    When i select manually on for the residence (see picture general status windows ) pump is activated and also al 4 valves. Working is ok.When i push the off button the valves are closed but the pump is still running.


    The reason i use the "general page" on-off functions is that this function can be configured in the homeseer mobile app.

    I added the logfile


    Attached Files

    #2
    The 7P has seven valves managed by mcsSprinklers. The pump is managed by EtherRain module. You should not attempt to setup valve 8 in mcsSprinklers. It should not be enabled on the Wiring Page.

    Comment


      #3
      I deleted the pump on the wiring page,but it isn't working. Valve opens but no pump activities.


      This is what i earlier posted.
      "One thing that is important to understand about using the timed relay commands with an EtherRain 7P is that the pump control port does not automatically open when one of the timed zone commands is issued like it does when using the sequential irrigation command. You have to manage the pump control port manually - that is, you have to first send a command to run zone 8 (the pump control port) and set the desired run time, before you send a command a standard irrigation zone if you want the pump control to operate."


      @michael: are you sure i need to delete the pump on the wiring page.
      I know deleted the pump at the wired setup , but still have it configured on the layout page otherwise the pump is not running.

      But on the general page on and off opens and closes the valves but the pump starts running with on and is not stopping with the off .

      I think the problem is related to "" general page" because what i find strange is :

      click "residence van Kraaij" on started the pump and opens the valves.The green sprinkler symbols rotating and watering starts .

      Click the off button stops wathering. Pump is still running and the symbols still rotating .
      Click image for larger version

Name:	green symbols.png
Views:	165
Size:	8.3 KB
ID:	1546026

      To stop the pump i have to go to the "touch zone" and click every "stop " button at each area to finaly stop the pump
      Click image for larger version

Name:	stop.png
Views:	121
Size:	79.2 KB
ID:	1546028

      Just for the record.If i use the touch area for stopping and starting it works ok. Start and stop watering and stop the pump.
      Attached Files

      Comment


        #4
        small detail. Because all valves runs simultanius the total time left will be 5 min instead of 4*5 = 20 min
        Attached Files

        Comment


          #5
          and a small update: when using the ON button in the general page and i let run the whole program during the whole time (in my case 30 min) after the 30 minutes it stops automaticly watering and also stops the pump .

          So that is working wel. I added the logfile
          Attached Files

          Comment


            #6
            I was not aware that the Rev C firmware does not always automatically control the pump on the 7P. I need to look into the implications for mcsSprinklers as I do not think I try to assess the type of Etherrain 8 vs. 7P and then control the 8th valve as a pump. This will take some research as I have not worked with this in some time. At first blush it appears Rev C EtherRain firmware does not have any difference in operation of the 8 vs. 7P for the way mcsSprinklers is using the EtherRain.

            In the original EtherRain the constraint was one valve at a time. This means that if a user that needs pump control are required to use the 7P since mcsSprinlkers could not control more than one valve at a time.

            Comment


              #7
              Thnx. And if i need to test something, please let me know

              Comment


                #8
                I did confirm with Jim that your are correct with the 7P and 8 have no difference when operated in this mode.

                I still need to see how to integrate pump control with Etherrain

                Comment


                  #9
                  I did get setup to test this and see that I hade the Rev C pump control implemented. I forgot about this. In my normal test of automatic control of two simultaneous zones the pump valve worked as expected with on, two valves on, two valves off, off. I will look at the detail your provided in this thread tomorrow.

                  Comment


                    #10
                    I tried to replicate a failure mode without success. I found a few things related to configuration such as case sensitivity in the .ini settings, but from the operation of the pump I could never get it to fail.

                    The original design intent of the General Status page zone on/off buttons was to control that specific zone. When simultaneous multi-zone control was added there was not an attempt to modify the original design intent. If you want to control multiple zones manually then two types of choices exists.

                    One is by individually selecting the desired set of zones to be manually controlled on the Zone Status page and then start selected manual button.

                    The other is from the General Status page by controlling an Area (S45 to S52) or Site (S53). This does the same thing as the Zone Status page where a set of zones are marked for manual operation and then they are run in sequence based upon flow or valve count limits.

                    In all cases the pump operation is monitored to turn it on when needed and turn it off when no zones are running.

                    The version I was using for testing is attached. It replaces file of the same name after unzipping. Enable the Debug from the Other Page so there is a history of the control actions that can be used for analysis if problem still exists.

                    Attached Files

                    Comment


                      #11
                      Thnx. I can test this version end of this week.

                      t used the “s53” scenario. The way i used it is because this link i use with the homeseer mobile app.

                      Comment


                        #12
                        2 logs.zip

                        I did 2 test today with the new DLL.

                        First:
                        form the web interface :
                        start with the general page / S53 to on
                        The after a minute general page / S53 off

                        Pump doesn't stop and i stop it via the touch zone interface.After stopping all zones the pump stops


                        another test via the mobile app

                        Comment


                          #13
                          I was able to replicate. The update with desired behavior is 2.22.0.5 at http://mcsSprinklers.com/MCSSPRINKLERS_22205.zip

                          Comment


                            #14
                            yes , thanks.This release fixed the issue.

                            Comment

                            Working...
                            X