Announcement

Collapse
No announcement yet.

Unexpected behavior in 2.11

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Unexpected behavior in 2.11

    The good news - my communications problems with the Global Cache WF2SL device appear to be completely gone. The bad news - the logic that turns the sprinkler heads on and off doesn't seem to work properly.

    It has been very rainy in Northern Virginia lately. I have the plug-in setup to use ET to decide when to turn on the zones. I have 12 zones configured in two areas. The system decided to run last night for the first time. In the touch zone screen, you can see the projected schedule by hovering over "Auto Program." It looked perfect prior to the watering event. It had all of the zones activating sequentially for 20 minutes each and the areas activating sequentially. What actually happened was this:

    4/27/2011 1:01:00 AM _17 Rain8 Harness1 Wire 1 ON
    4/27/2011 1:02:00 AM _25 Rain8 Harness1 Wire 9 OFF
    4/27/2011 1:06:00 AM _25 Rain8 Harness1 Wire 9 ON
    4/27/2011 1:10:02 AM _17 Rain8 Harness1 Wire 1 OFF
    4/27/2011 1:10:02 AM _25 Rain8 Harness1 Wire 9 OFF
    4/27/2011 1:11:00 AM _17 Rain8 Harness1 Wire 1 ON
    4/27/2011 1:11:00 AM _25 Rain8 Harness1 Wire 9 ON
    4/27/2011 1:21:00 AM _17 Rain8 Harness1 Wire 1 OFF
    4/27/2011 1:22:00 AM _17 Rain8 Harness1 Wire 1 ON
    4/27/2011 1:22:00 AM _25 Rain8 Harness1 Wire 9 ON
    4/27/2011 1:25:00 AM _25 Rain8 Harness1 Wire 9 OFF
    4/27/2011 1:41:00 AM _17 Rain8 Harness1 Wire 1 OFF
    4/27/2011 1:41:00 AM _18 Rain8 Harness1 Wire 2 ON
    4/27/2011 1:42:00 AM _17 Rain8 Harness1 Wire 1 ON
    4/27/2011 1:42:00 AM _26 Rain8 Harness1 Wire 10 OFF
    4/27/2011 1:43:00 AM _26 Rain8 Harness1 Wire 10 ON
    4/27/2011 1:48:17 AM _17 Rain8 Harness1 Wire 1 OFF
    4/27/2011 1:48:18 AM _18 Rain8 Harness1 Wire 2 OFF
    4/27/2011 1:48:20 AM _26 Rain8 Harness1 Wire 10 OFF

    Is there a more stable version of 2.11?

    #2
    The most current version should be visible in one of the last status device on the General Status page. It is also visible on the change log in the stick at the top of this subforum. Now it is 2.11.0.3. The last update related to multiple module valve identification which may or may not affect your results. Keep the general debug logging enabled on the Other Page and the output produced from that will identify why scheduling does what it does.

    Comment


      #3
      I'm running the latest version. I'll turn on the debug log to gather more information.

      Comment


        #4
        Here is a debug log showing two zones starting simultaneously even though both areas are configured for "Zones part of a single master sequence" and "Maximum simultaneous Zones by Site = 1."
        Attached Files

        Comment


          #5
          The high level control is shown below where mcsSprinklers does turn ON, OFF, ON, OFF the valves so only one is ON at a time. It also shows a final OFF where it saw it needed to turn off a valve when the status reported it was ON unexpectedly

          4/27/2011 8:00:50 PM 634395312507828750 | mcsSprinklers Debug | CommonExecX10, Rain8NetUPB HouseCode=_, Device=_25, State=ON, rtoX10CollectionCount=0, iType=-1
          4/27/2011 8:01:00 PM 634395312600953750 | mcsSprinklers Debug | CommonExecX10, Rain8NetUPB HouseCode=_, Device=_25, State=OFF, rtoX10CollectionCount=0, iType=-1
          4/27/2011 8:01:00 PM 634395312605172500 | mcsSprinklers Debug | CommonExecX10, Rain8NetUPB HouseCode=_, Device=_17, State=ON, rtoX10CollectionCount=0, iType=-1
          4/27/2011 8:02:38 PM 634395313582516250 | mcsSprinklers Debug | CommonExecX10, Rain8NetUPB HouseCode=_, Device=_17, State=OFF, rtoX10CollectionCount=0, iType=-1
          4/27/2011 8:02:38 PM 634395313588141250 | mcsSprinklers Debug | CommonExecX10, Rain8NetUPB HouseCode=_, Device=_25, State=OFF, rtoX10CollectionCount=0, iType=-1

          At the next level down the command to the Rain8net is partially correct with 31's being ON and 41's being OFF. The second byte is the module ID.

          4/27/2011 8:00:50 PM 634395312508297500 | mcsSprinklers Debug | NET(0) OUT | 40, 02, 31
          4/27/2011 8:00:53 PM 634395312533922500 | mcsSprinklers Debug | NET(0) OUT | 40, 02, F0
          4/27/2011 8:01:00 PM 634395312601578750 | mcsSprinklers Debug | NET(0) OUT | 40, 02, 41
          4/27/2011 8:01:02 PM 634395312627828750 | mcsSprinklers Debug | NET(0) OUT | 40, 01, 31
          4/27/2011 8:01:05 PM 634395312654078750 | mcsSprinklers Debug | NET(0) OUT | 40, 02, F0
          4/27/2011 8:01:10 PM 634395312706110000 | mcsSprinklers Debug | NET(0) OUT | 40, 02, 31
          4/27/2011 8:01:13 PM 634395312731891250 | mcsSprinklers Debug | NET(0) OUT | 40, 02, F0

          The status responses to the F0 (Status Request) show that both valves are ON at 8:02.

          4/27/2011 8:02:00 PM 634395313207672500 | mcsSprinklers Debug | Rain8Net Response Back 2 :40, 02, 01
          4/27/2011 8:02:03 PM 634395313233610000 | mcsSprinklers Debug | Rain8Net Response Back 2 :40, 01, 01

          The problem occurs at 4/27/2011 8:01:10 PM 634395312706110000 where a ON command was sent to module 2. It is likely the same issue that caused problems for the 2.11.0.3 correction but for a different scenario. I will need to dig deeper to see exactly what is happening.

          These are issues related to supporting the option to either poll on command or to poll periodically that was introduced late in V2.10 due to some communiation reliabilty issues where the polling was trying to be reduced.

          Comment


            #6
            You should be good to go with V2.11.0.4. The links are at the version log at the top of the mcsSprinklers subforum.

            Comment


              #7
              Thanks! I'll let you know if I have any problems.

              Comment


                #8
                So far so good. I'm starting to really like this sprinkler system.

                Comment

                Working...
                X