Announcement

Collapse
No announcement yet.

mcssprinkers update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    mcssprinkers update

    I am using mscsprinklers v2.11.0.29 pro within HS 2.5.0.23
    For updating MCSS i use the "old" processus :
    - download http://mcssprinklers.com/mcsSprinklers_2110nn.zip from homeseer forum
    - stop HS
    - uncompress and put the *.dll in homeseer directory
    - restart HS

    I met some problems with the latest beta DLL (sprinklers open immediatly when HS restart but it is during inhibit hours...)

    I see that i can directly uptate via HS, MCSS, other setup... But that dont run for me (i am always with V2.11.0.29)
    And another question : with the "new" processus it is version 2.11.0.37 and with the old it seems to be 211035. Why this difference?

    thank you

    Michel

    #2
    It would be good to understand why the automatic update process does not work for you. Perhaps there is some information in the HS log?

    The development "macro" will create the information for the automatic updates so when one it made it is almost immediately available. The HS board update is a manual process that will occur at a convenient later time.

    At the beginning of each day mcsSprinklers will look at the web site to determine the latest available version and show it in the General Status device and the Other Page Config Mgmt section. It can also be manually refreshed more often with the Other Page Refresh button.

    Recent updates have broken and then fixed both scheduling and between-hours inhibit logic so it is best is you do have the most current version installed.

    Comment


      #3
      When i try an update, the only msg in HS log after one minute is :

      Version 2.11.0.9 | V2.11.0.9/2.11.0.29 (Professional) Copyright 2004-2011 mcsSolutions Registered with Homeseer

      so i never get V211037!!!

      What version you suggest i can manually install?

      Thank you

      Comment


        #4
        Just after asking for the update, i see "status valve failure" in zone status and the general status list is empty!!! (see attachement files)

        If i stop HS, all is ok when i restart it (but MCSS is not updated!)
        Attached Files

        Comment


          #5
          .37 is the latest one at this time.

          After you click the Udate button then there will be a delay as the new version is downloaded and then a new page will show that is blank other than large text indicating the update is in progress. During this time you will not be trying to navigate to other mcsSprinklers pages. When the update is complete a normal mcsSprinklers page will show which should be Other Page.

          The \Backup folder will contain the prior .dll and the downloaded one will be in the main HS folder. For errors you should be looking in the HS log for the time running when the update was started. When HS restarts a new display log starts, but the log file will contain everything.

          Comment


            #6
            I retry carelully the update, i have exactly the same behaviour :

            - from other (image attached) i click update
            - i wait with the message "update and reinitializing - please wait"
            - after one minute the browser return to the"other" page (no restart of HS).
            - if i look to zone status, i have alwas "status valve failure"
            - the general status page is empty
            - if i manually stop and restart HS all is OK... but no update of MCSS

            If i look in general status i have the ]94 available version device (image attached) and i can download mcssprinklers_211037.dll.
            How can i manually install that updated dll?

            Thank you
            Attached Files

            Comment


              #7
              I suspect you never updated via the HS Updater to V2.11.0.29. There was an update to mcsSprinklersS (not mcsSprinklers that you normally update manually) that contains the logic to complete the auto update process.

              If you have not used the HST updater for this then you need to manually do the beta update which is with downloading the .zip file from the link on the mesage board or the link from the beta status device. In the zip case it is uncompressed and placed in the HS root folder. HS cannot be running at this time. In the beta link case after you downloaded the file stop HS. Rename the downloaded file to MCSSPRINKLERS_2009.dll and place it in the same HS root folder. Start HS.

              I'm going to be putting 2.11.0.37 in the HST Updater today so you can just wait for that and do the download from there and it will then give you the autoupdate capability for the future too.

              Comment


                #8
                I dont remember if i use HSupdater or manual process...
                If i run HSupdater now i have the information you can see on the attached jpg
                I am surprised with the "no" at the left of the line "mcssprinklersP"...
                Perhaps it is because i migrate from S to P with your help (out of HS because it was not possible in HS)

                Can you confirm that and tell me if it is a problem or not...

                Thank you

                Michel
                Attached Files

                Comment


                  #9
                  I believe the No means that you do not have 2.11.0.37 installed. You will want to use the updater to install it. You will then be able to do beta updates from the mcsSprinklers Other Page in the future too.

                  Comment


                    #10
                    Thank you
                    I update to .37 with HS updater
                    It seems to run fine...
                    Just a question
                    Usually, i run MCSS using ET calculated control strategy.
                    With my problems, i temporarely use day-of-week control strategy

                    After update to .37 i put back one zone (the third on attached file) to ET calculated.

                    it was midday

                    You see "projected for to day 1:27..."

                    Why that when soil if far from target?
                    And why 1:27 and not 13:27??

                    Thank you

                    Michel
                    Attached Files

                    Comment


                      #11
                      The projected is based upon recent trends in moisture loss. Your graph shows an excessively high rate of moisture loss so the projecting is based upon this high rate. You should watch your daiily ET calculation to assure it is somewhere in the ballpark of the historical average and if not then look at the sensors used to compute it. The UV being the most critical one.

                      Comment


                        #12
                        i have no problem with my ET calculation (coming in fact from a Davis weather station)
                        The strange history is because problem with bad update of MCSS

                        My question is also :
                        when it is midday how understand "projected for to day 1:27..."

                        actually it is 19:30 and it is indicated : "projected for to day 9:29..."???

                        thank you

                        Comment


                          #13
                          I see when the ET is based upon mm rather than inches that the prediction rate is off by a factor of 25 so that make the predicted moisture loss rate occur much too quickly. I do not know why it was showing dates in the past. Update to 2.11.0.38 and see if that type of problem still occurs for you.

                          Comment


                            #14
                            I update (automaticaly ) to .38
                            It works good (see jpg attachement)
                            But this was taken at 16:00 and the first zone indicate "projected for today 11:55" is it 11:55AM or PM???

                            And why the projected time does not considere the area start time and/or the area inhibit time?

                            Thank you

                            Michel
                            Attached Files

                            Comment


                              #15
                              update of my precedent post :

                              at 18:12 you can see that (see attachement)

                              So there is really a problem with projections...

                              Michel
                              Attached Files

                              Comment

                              Working...
                              X