Announcement

Collapse
No announcement yet.

RainNet8 doing strange things

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RainNet8 doing strange things

    Excited and Purchased RainNet8.

    Can open valves from Status page by clicking ON button.

    OFF button on Status page doesn't work.

    Only way to turn off valve is by ALL VALVES OFF.

    Go/No Go Device is set to NONE

    Turning ON via EVENTS doesn't work at all.

    All Valves Off on EVENTS doesn't work either.

    Log reports:

    10/7/2007 6:55:23 PM - Rain8Net Error - Rain8Send() Failed - Response was:--> @2


    Help is appreciated.

    Ben

  • #2
    Originally posted by benmorris View Post
    Excited and Purchased RainNet8.

    Can open valves from Status page by clicking ON button.

    OFF button on Status page doesn't work.

    Only way to turn off valve is by ALL VALVES OFF.

    Go/No Go Device is set to NONE

    Turning ON via EVENTS doesn't work at all.

    All Valves Off on EVENTS doesn't work either.

    Log reports:

    10/7/2007 6:55:23 PM - Rain8Net Error - Rain8Send() Failed - Response was:--> @2


    Help is appreciated.

    Ben
    Hi Ben,

    Which version of the plugin are you using? I will look into it as soon as I verify which version, I probably messed up a pointer or something. Also can you describe how you are setting up events? Another thing you can do is turn on debug from the config page and post the log file.

    Thx.
    -Larry

    A member of "The HA Pioneer Group", MyWebSite

    Plugins:
    VWS, AB8SS, lrpSpeak, Calendar, Arduino, Harmony, BlueIris, Sprinklers, ZipBackup...

    Hardware:
    Intel NUC8i7BEH1 running Windows 10 Pro headless, HS3 Pro, Plex running on Synology dual High Availability DS-1815+ NAS (24Tb each), Synology Surveillance Station running on DS-416 Slim (8Tb), Samsung SmartThings, Google Home, Alexa, Hubitat Elevation, ZNET, Ubiquiti UniFi Network, Davis Vantage Pro II Weather Station. Whole house speaker system using a couple of AB8SS switches. Vantage Pro II Weather Station, Rain8Net Sprinklers, Hubitat Elevation, Google Home, Alexa, DSC Security System, Ubiquiti UniFi Network.

    Comment


    • #3
      Thanks for quick reply

      Thanks for quick reply.

      Version: 2.2.0.7

      I'm setting up events in a normal manner.

      Add Event, Trigger is Time, Action is: Device Action, Device is: Rain8Net Device (1 -8)

      Turned on Debug.

      I will be posting log shortly too.

      I think my Device Database might have issues but not sure. I think every time the Homeseer starts it recreates the devices...

      Let me know ...

      Ben

      Comment


      • #4
        Database items are deleted and re-created each time HS starts this was by design...

        Event Actions must be in the form of script commands...
        ie. &hs.plugin(Rain8Net).somecommand(someparm)
        These should be documented in the help file "Rain8Net.html" accessable from main page "Help"...


        The ON/OFF issue I am looking into.
        -Larry

        A member of "The HA Pioneer Group", MyWebSite

        Plugins:
        VWS, AB8SS, lrpSpeak, Calendar, Arduino, Harmony, BlueIris, Sprinklers, ZipBackup...

        Hardware:
        Intel NUC8i7BEH1 running Windows 10 Pro headless, HS3 Pro, Plex running on Synology dual High Availability DS-1815+ NAS (24Tb each), Synology Surveillance Station running on DS-416 Slim (8Tb), Samsung SmartThings, Google Home, Alexa, Hubitat Elevation, ZNET, Ubiquiti UniFi Network, Davis Vantage Pro II Weather Station. Whole house speaker system using a couple of AB8SS switches. Vantage Pro II Weather Station, Rain8Net Sprinklers, Hubitat Elevation, Google Home, Alexa, DSC Security System, Ubiquiti UniFi Network.

        Comment


        • #5
          Thanks. Where's the Help File

          Hmmm.... There's no Rain8net.html help file. The link is there but it leads to Rain8net-Doc.htm
          Went to the help directory for rain8net and it's empty...

          ....that's strange too...

          Not too fluent with scripts....Any clues? Just want something simple...

          Appreciate your help.


          Comment


          • #6
            My mistake, it is "Rain8Net-Doc.html", if that is missing then I will post it tonight when I get home.

            Thx.
            -Larry

            A member of "The HA Pioneer Group", MyWebSite

            Plugins:
            VWS, AB8SS, lrpSpeak, Calendar, Arduino, Harmony, BlueIris, Sprinklers, ZipBackup...

            Hardware:
            Intel NUC8i7BEH1 running Windows 10 Pro headless, HS3 Pro, Plex running on Synology dual High Availability DS-1815+ NAS (24Tb each), Synology Surveillance Station running on DS-416 Slim (8Tb), Samsung SmartThings, Google Home, Alexa, Hubitat Elevation, ZNET, Ubiquiti UniFi Network, Davis Vantage Pro II Weather Station. Whole house speaker system using a couple of AB8SS switches. Vantage Pro II Weather Station, Rain8Net Sprinklers, Hubitat Elevation, Google Home, Alexa, DSC Security System, Ubiquiti UniFi Network.

            Comment


            • #7
              There were a couple of problems in my update file, so here is a new zipped file with the correct files included, that were missing or incorrect.

              Files should located as follows:

              Rain8Net-Readme.txt, ---- HomeSeer Directory\Docs
              Rain8Net-Doc.htm, ------ HomeSeer Directory\html\Rain8Net

              The Rain8Net-Doc.htm is the better source...

              Thx.
              Attached Files
              Last edited by lpitman; October 9th, 2007, 07:44 PM.
              -Larry

              A member of "The HA Pioneer Group", MyWebSite

              Plugins:
              VWS, AB8SS, lrpSpeak, Calendar, Arduino, Harmony, BlueIris, Sprinklers, ZipBackup...

              Hardware:
              Intel NUC8i7BEH1 running Windows 10 Pro headless, HS3 Pro, Plex running on Synology dual High Availability DS-1815+ NAS (24Tb each), Synology Surveillance Station running on DS-416 Slim (8Tb), Samsung SmartThings, Google Home, Alexa, Hubitat Elevation, ZNET, Ubiquiti UniFi Network, Davis Vantage Pro II Weather Station. Whole house speaker system using a couple of AB8SS switches. Vantage Pro II Weather Station, Rain8Net Sprinklers, Hubitat Elevation, Google Home, Alexa, DSC Security System, Ubiquiti UniFi Network.

              Comment


              • #8
                I never did see a resolution to this problem -- and the exact same thing is plaguing me after a brand new installation of HS2 and the Rain8Net plugin (version 2.2.0.8).

                My rain8net.log shows:

                Code:
                5/29/2008 11:01:24 PM~Entering DeleteDevices()....
                5/29/2008 11:01:24 PM~Entering InitHW()....
                5/29/2008 11:01:24 PM~Entering InitDevices()...
                5/29/2008 11:01:24 PM~Entering EnumerateDevices()...
                5/29/2008 11:01:24 PM~Entering CreateDevices()....
                5/29/2008 11:01:24 PM~Entering GetDeviceCode()....
                5/29/2008 11:01:24 PM~GetNextFreeIOCode returned 92 (\)
                5/29/2008 11:01:25 PM~Entering InitCommon()....
                5/29/2008 11:01:25 PM~Entering InitRain8Net()....
                5/29/2008 11:01:25 PM~Entering ComPort()....
                5/29/2008 11:02:00 PM~Entering ButtonPressEx()....
                5/29/2008 11:02:00 PM~In ButtonPressEx for Rain8Net - Master-Valve, button pressed is On
                5/29/2008 11:02:00 PM~Entering SetRain8Zone()....
                5/29/2008 11:02:00 PM~SetRain8Zone()...Unit: 1 ...Name: Master-Valve ...Zone-8 - ON
                5/29/2008 11:02:00 PM~Entering Rain8Send()....
                5/29/2008 11:02:00 PM~Rain8Send()...Sending:--> @8
                5/29/2008 11:02:00 PM~SetRain8Zone()...Rain8Send(ON) returned Failed
                I get the same "Rain8Send(ON) return Failed" for any zone I try to turn on or off from the HS web page.

                Further, after somebody else pointed out the documentation installation failure back in October, I note that the error still exists in the current plugin installer -- I had to manually rename Rain8Net-Doc.htm to Rain8Net-Doc.html to get the plugin to install completely.

                Finally, none of the Rain8Net devices appear in the Maestro Irrigation module, although that may be a Maestro issue.

                Is this plugin actually supported? Is anybody using it successfully?

                -M.

                Comment


                • #9

                  Comment


                  • #10
                    Thanks Dave -- your procedure worked exactly as written. HS was identifying the device type as "Sprinkler Zone". All of the zones are now appearing as Sprinkler devices in Maestro. I'm running Maestro Core 2.5.0.11, which I believe is the current version.

                    Unfortunately, none of the devices actually work (i.e., the sprinklers don't actually turn on). Does Maestro Irrigation use the Rain8Net plugin module to control the sprinklers? It seems like it must, since I don't know how it would otherwise know the COM port to use to talk to the Rain8Net controller.

                    My HS log shows:
                    Code:
                    5/30/2008 9:12:03 PM  - MAESTRO - IRRIGATION: User Requesting Toggle Of Zone (\3)
                    5/30/2008 9:12:03 PM  - MAESTRO - IRRIGATION: Turning On Sprinkler (\3)
                    5/30/2008 9:12:03 PM  - Database Item - Saving Event maestro_irrigation_checker
                    5/30/2008 9:12:03 PM  - MAESTRO - IRRIGATION: User Request Done
                    5/30/2008 9:12:04 PM  - Database Item - Saving Event maestro_irrigation_checker
                    5/30/2008 9:12:04 PM  - Database Item - Saving Event maestro_irrigation_checker
                    
                    5/30/2008 9:13:27 PM  - MAESTRO - IRRIGATION: User Turning All Sprinklers Off
                    5/30/2008 9:13:27 PM  - MAESTRO - IRRIGATION: Turning Off Sprinklers
                    5/30/2008 9:13:32 PM  - MAESTRO - IRRIGATION: Verifying Sprinklers Are Off
                    5/30/2008 9:13:32 PM  - MAESTRO - IRRIGATION: Sprinklers Are Off
                    Any suggestions for futher debugging?

                    Thanks again,

                    -M.
                    Last edited by MarkHargrove; May 30th, 2008, 10:11 PM. Reason: Added more information

                    Comment


                    • #11
                      I will look into this tonight.
                      -Larry

                      A member of "The HA Pioneer Group", MyWebSite

                      Plugins:
                      VWS, AB8SS, lrpSpeak, Calendar, Arduino, Harmony, BlueIris, Sprinklers, ZipBackup...

                      Hardware:
                      Intel NUC8i7BEH1 running Windows 10 Pro headless, HS3 Pro, Plex running on Synology dual High Availability DS-1815+ NAS (24Tb each), Synology Surveillance Station running on DS-416 Slim (8Tb), Samsung SmartThings, Google Home, Alexa, Hubitat Elevation, ZNET, Ubiquiti UniFi Network, Davis Vantage Pro II Weather Station. Whole house speaker system using a couple of AB8SS switches. Vantage Pro II Weather Station, Rain8Net Sprinklers, Hubitat Elevation, Google Home, Alexa, DSC Security System, Ubiquiti UniFi Network.

                      Comment


                      • #12
                        Mark, can you turn on debug in Rain8Net plugin and send me the log file generated...it should be located in a Logs directory under your HS root directory, and will be named Rain8Net.log..

                        Thanks.
                        -Larry

                        A member of "The HA Pioneer Group", MyWebSite

                        Plugins:
                        VWS, AB8SS, lrpSpeak, Calendar, Arduino, Harmony, BlueIris, Sprinklers, ZipBackup...

                        Hardware:
                        Intel NUC8i7BEH1 running Windows 10 Pro headless, HS3 Pro, Plex running on Synology dual High Availability DS-1815+ NAS (24Tb each), Synology Surveillance Station running on DS-416 Slim (8Tb), Samsung SmartThings, Google Home, Alexa, Hubitat Elevation, ZNET, Ubiquiti UniFi Network, Davis Vantage Pro II Weather Station. Whole house speaker system using a couple of AB8SS switches. Vantage Pro II Weather Station, Rain8Net Sprinklers, Hubitat Elevation, Google Home, Alexa, DSC Security System, Ubiquiti UniFi Network.

                        Comment


                        • #13
                          I renamed the attachment to Rain8Net.txt because it wouldn't upload with a .log extension, but the log is otherwise untouched.

                          This is quite representative of the problem.

                          In all cases a valve will turn on but not off. 'All Off' works. Turning a valve on through a device action in a HS event does not work.

                          This is exactly the problem described by the original poster in the thread, including the identical errors in the log file.

                          -M.
                          Attached Files

                          Comment


                          • #14
                            This error may be the result of an HS bug that was recently uncovered.
                            This bug has been fixed in a recent HS beta (.77f). I do not believe this beta is yet available to the public.

                            The errors you are seeing sound like ones uncovered with LutronRA devices.
                            Here is the solution from Geoff at HS:

                            "I have found and corrected the problem. The "hs.ExecX10" command with the "wait" parameter was not controlling devices that belong to a plugin.

                            I'm amazed that this hadn't been discovered in the past, but I guess it's rare that one plugin controls devices that belong to another plugin.

                            I have tested the fix with Maestro controlling RadioRA devices, and it works perfectly now.

                            The fix will be available in the next beta version of HS2. Because there are other changes in this new beta version that still need further testing, there will likely be some delay, but we'll try to get it out as soon as we can.

                            Geoff"

                            Thanks,
                            Dave

                            Comment


                            • #15
                              Thanks for the info Dave. I also will compile a new version of the plug-in this weekend, that will provide more debug information, as well as changing the device re-creation mechanisim, and fixing the documentation issue.

                              Also Mark, can you tell me more about your environment, so I can try and re-create the same environment here? Windows Version, HS version, how is the Rain8Net connected (direct serial port or through a Edgeport or similar conversion). Have you tried the Rain8Net configuration program from WGL Designs? This helps verify connectivity to the device. Thanks for your help...
                              Last edited by lpitman; June 4th, 2008, 09:40 AM.
                              -Larry

                              A member of "The HA Pioneer Group", MyWebSite

                              Plugins:
                              VWS, AB8SS, lrpSpeak, Calendar, Arduino, Harmony, BlueIris, Sprinklers, ZipBackup...

                              Hardware:
                              Intel NUC8i7BEH1 running Windows 10 Pro headless, HS3 Pro, Plex running on Synology dual High Availability DS-1815+ NAS (24Tb each), Synology Surveillance Station running on DS-416 Slim (8Tb), Samsung SmartThings, Google Home, Alexa, Hubitat Elevation, ZNET, Ubiquiti UniFi Network, Davis Vantage Pro II Weather Station. Whole house speaker system using a couple of AB8SS switches. Vantage Pro II Weather Station, Rain8Net Sprinklers, Hubitat Elevation, Google Home, Alexa, DSC Security System, Ubiquiti UniFi Network.

                              Comment

                              Working...
                              X