Announcement

Collapse
No announcement yet.

Failed to get responst to authentication request

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Failed to get responst to authentication request

    Hi,
    Just installed your plugin to connect to my Rain Machine HD12 and it will not connect under port 8080 or 443. I am getting the following messages in the log.

    - Failed to get responst to authentication request: The remote server returned an error: (401) Unauthorized.
    - Attempting to authenticate with https://192.168.1.104:8080/api/4/auth/login
    - RainMachine HW version: 3 SW version: 4.0.1129 API: 4.6.1

    Tried both ports with no success, but I am able to login to the Rain Machine UI from the IP address shown above with my password.

    Thanks,
    Forrest

  • #2
    Mine has the same firmware version and API version and authenticates fine so I suspect it's an issue with the password.

    I'm not aware of there being any restrictions in what characters can be used in the password for authentication with the API, but the rainmachine is rejecting what was sent for some reason. I'd suggest re-entering the password in the config screen and if that doesn't work, may try changing the password to something fairly simple (alpha numeric characters only). Let me know what the results are.
    --
    Bob Paauwe
    ISYInsteon Plug-in
    http://www.bobsplace.com/ISYInsteon/

    Comment


    • #3
      That did not fix the issue. I changes the password several times and can login to the local webpage, but still getting same errors. Another thing I noticed was on the main HomeSeer Plug-INS management page under "Plug-in Status column, the plug-in currently has a message reading, "INFO: RainMachine Configured." I tried to uninstall and reinstall plugin, but it did not fix the issue.Any other thoughts?

      Comment


      • #4
        Rebooted and now it says "INFO: RainMachine Initializing"

        Comment


        • #5
          Initializing means it's waiting for you to configure the IP address and password. Once those are entered it should change back to Configured. After it authenticates, it changes to Querying, and once it gets the info from the rainmachine it changes to Running.

          I don't have any other ideas at this point. The plug-in is able to connect to the rainmachine since it is able to get the API version and log that. It is the rainmachine that is rejecting the authentication request. When I configure mine with an invalid password, I get the same responses that you are.

          This website has some information on doing the authenticating via a Linux command line that would be useful for testing if you have access to a Linux machine http://wikipage.rainmachine.com/inde...rough_REST_API

          This page https://support.rainmachine.com/hc/e...PI-environment has instructionsfor accessing the API via a browser plug-in.

          The plug-in is using the same API methods as the two websites above describe so if they work, then the plug-in should work.
          --
          Bob Paauwe
          ISYInsteon Plug-in
          http://www.bobsplace.com/ISYInsteon/

          Comment


          • #6
            I got this error in the log. Does this help?
            Posting back to plugin web page RainMachine_config: Object reference not set to an instance of an object.-> Server stack trace: Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.PostBackProc(String page, String data, String user, Int32 userRights) at Scheduler.proxyPage.postBackProc(StateObject& state, String Data)

            Comment


            • #7
              I see that error too when running the version from the store. I believe I have it fixed in the next version, but it doesn't actually effect the running of the plug-in. The error is thrown when the configuration is saved. However, about 10 seconds after saving, mine will connect with the rainmachine and finish initializing.

              After you save the configuration does it attempt to authenticate?

              If it's still failing to authenticate, have you been able to try any of the other methods to test the connection via the API?
              --
              Bob Paauwe
              ISYInsteon Plug-in
              http://www.bobsplace.com/ISYInsteon/

              Comment

              Working...
              X