Announcement

Collapse
No announcement yet.

RainRelay8 in HS3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    RainRelay8 in HS3

    I haven't touched HS3 until today. I figured while I'm waiting for UPB I should at least look at it so I picked the RainRelay8 since it will at least give me devices to play with.

    I installed the plug-in, on the same machine that HS2 is installed on, after shutting down HS2 of course. I set the com port to the same as is used on HS3 and set all the settings the same as HS2 in the HS3 plug-in configuration.

    I expected things to come right up but they didn't. I get this in my log.

    12/2/2013 8:26:25 AM ~!~Info~!~Remote application or plugin has connected: 127.0.0.1:3445
    12/2/2013 8:26:25 AM ~!~Info~!~Remote application or plugin has connected: 127.0.0.1:3446
    12/2/2013 8:26:25 AM ~!~Info~!~Plug-in Rain8 has connected successfully
    12/2/2013 8:26:25 AM ~!~Warning~!~Cannot find requested INI file: D:\Program Files\HomeSeer HS3\Config\Rain8.ini
    12/2/2013 8:26:25 AM ~!~Warning~!~Cannot find requested INI file: D:\Program Files\HomeSeer HS3\Config\Rain8.ini
    12/2/2013 8:26:25 AM ~!~Plug-In~!~Finished initializing plug-in Rain8

    My HS3 rainrelay8 is

    [Settings]
    RefIDs=7430

    My HS3 rainrelay8 is

    [controllers]
    addresses=1
    [settings]
    poll_interval=1

    Obviously something didn't take. Have I missed a step somewhere. It's almost like the settings are not writing to the ini file when i filled them in on the config page. Does anyone else have this working in HS3?
    Marty
    ------
    XPpro SP3 /w HS Standard 2.5.0.80, HSTouch Server - 1.0.0.70, HSTouch Client 1.0.0.73 HSTouch Android - 1.0.0.2, HSTouch iPhone - 1.0.0.2
    Playing with HS3 a bit but it's just play at this point.

    #2
    Is no one using this plug-in in HS3 yet?
    Marty
    ------
    XPpro SP3 /w HS Standard 2.5.0.80, HSTouch Server - 1.0.0.70, HSTouch Client 1.0.0.73 HSTouch Android - 1.0.0.2, HSTouch iPhone - 1.0.0.2
    Playing with HS3 a bit but it's just play at this point.

    Comment


      #3
      I have made some progress, although I'm not sure why. After starting and shutting down HS3 half a dozen times the relay8 controller is finally seen, through no fault of my own since i didn't change anything.

      Being new to HS3 i have no idea what a parent/child type device is but I have them in the devices that relay8 created. I have no idea what I'm supposed to do with those.

      I do get an error in my log that I can't quite figure out and have no idea what it's trying to tell me. In the rain8relay configuration I see no where to set the polling times. That was in the configuration of the HS2 version but I don't see it in the HS3 plug-in. Would anyone know where I can set that?

      Dec-04 8:35:35 AM Rain8 Error in Poll Thread, Conversion from string "0F" to type 'Long' is not valid.
      Marty
      ------
      XPpro SP3 /w HS Standard 2.5.0.80, HSTouch Server - 1.0.0.70, HSTouch Client 1.0.0.73 HSTouch Android - 1.0.0.2, HSTouch iPhone - 1.0.0.2
      Playing with HS3 a bit but it's just play at this point.

      Comment


        #4
        Seriously, is this message getting out? Does anyone at all use this plug-in? Maybe HomeSeer could comment on weather this thing works or not. I've been trying for days now to get just this little bit of HS3 to work. I grant you I'm not at all comfortable with HS3 yet, this was a trial, failed at the moment.

        I get all kinds of weird things. Error messages like above, but not tall the time. I turn on one relay and get 3 others that turn on while the one i turned on goes off. Not all devices show up on the device status page, just some of them.

        I'm beginning to think that this plug-just doesn't work. I've used this equipment and plug-in in HS2 for a long time and it's just great, still is, but I'm not experienced enough with HS3 to know for sure exactly what's going on or what to report or where.
        Marty
        ------
        XPpro SP3 /w HS Standard 2.5.0.80, HSTouch Server - 1.0.0.70, HSTouch Client 1.0.0.73 HSTouch Android - 1.0.0.2, HSTouch iPhone - 1.0.0.2
        Playing with HS3 a bit but it's just play at this point.

        Comment


          #5
          OK, so it seem I'm the only one trying to get this HS3 plug-in working. Since yesterday I also noticed that I no longer have the buttons to turn all on or off, aside from being missing the box to setup the polling.

          Perhaps HomeSeer can just answer this one question for now. Does this plug-in work or not.
          Marty
          ------
          XPpro SP3 /w HS Standard 2.5.0.80, HSTouch Server - 1.0.0.70, HSTouch Client 1.0.0.73 HSTouch Android - 1.0.0.2, HSTouch iPhone - 1.0.0.2
          Playing with HS3 a bit but it's just play at this point.

          Comment


            #6
            Bump

            c'mon HomeSeer I'm sitting here for days with my thumb up my butt hoping for a simple answer on the relay8 plug-in.
            Marty
            ------
            XPpro SP3 /w HS Standard 2.5.0.80, HSTouch Server - 1.0.0.70, HSTouch Client 1.0.0.73 HSTouch Android - 1.0.0.2, HSTouch iPhone - 1.0.0.2
            Playing with HS3 a bit but it's just play at this point.

            Comment


              #7
              and today's bump, who knows, HSTech could see it.
              Marty
              ------
              XPpro SP3 /w HS Standard 2.5.0.80, HSTouch Server - 1.0.0.70, HSTouch Client 1.0.0.73 HSTouch Android - 1.0.0.2, HSTouch iPhone - 1.0.0.2
              Playing with HS3 a bit but it's just play at this point.

              Comment


                #8
                marty,
                I've been distracted by life for the last couple years, and have come back to the board to lurk every now and then. your post caught my attention because i use the rainrelay8 in hs2, i have a purchased copy of hs3, but have not installed it yet because of concerns re:
                ess (the extinct next gen of ab8ss)
                upb
                rain8
                the custom hvac script written for me by fellow board guy here'


                sorry to hear you are having trouble. i'll continue lurking to see how it goes!

                Ian
                Plugins:
                BLLogMonitor, BLGarbage, BLBackup, BLOutGoingCalls, BLUps, BLRfid, JvEss, DooMotion, Applied Digital Ocelot, AC RF Processor, UltraMon, PJC AVR 430, UPB, Rain8net, DSC Panel, JRiver Media center, Windows Media Player, SageMediaCenter, SnevlCID, MCSTemperature.

                Comment


                  #9
                  Hope springs eternal that someone from HS Tech will see this message and answer. There isn't really anything I can do with it just now, so i wait. I do appreciate seeing a post on here besides my own though, I thank you for that.
                  Marty
                  ------
                  XPpro SP3 /w HS Standard 2.5.0.80, HSTouch Server - 1.0.0.70, HSTouch Client 1.0.0.73 HSTouch Android - 1.0.0.2, HSTouch iPhone - 1.0.0.2
                  Playing with HS3 a bit but it's just play at this point.

                  Comment


                    #10
                    Don't feel lonely Marty, I also have this project in hold, first attemp it didn't work, so I desided to work on others things. But some day I may have to face the issue.
                    Hector
                    ____________________________________
                    Win.2003 OS, HS3
                    BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                    BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                    MyTrigger,ACRF2,W800,Zwave
                    AP800,Honeywell Stat

                    Comment


                      #11
                      Thanks Hector, always nice to know you're not alone.

                      This was my first foray into HS3 while I was waiting for HS to get their UPB plug-in out. I chose it because it gave me devices that I could play with and setup test events for to get familiar with HS3, so much for that thought, back to waiting.
                      Marty
                      ------
                      XPpro SP3 /w HS Standard 2.5.0.80, HSTouch Server - 1.0.0.70, HSTouch Client 1.0.0.73 HSTouch Android - 1.0.0.2, HSTouch iPhone - 1.0.0.2
                      Playing with HS3 a bit but it's just play at this point.

                      Comment


                        #12
                        Since I just found out that HS3 is released I figured HS would have more time to at least answer this, even if they don't fix it yet!

                        So consider this todays bump
                        Marty
                        ------
                        XPpro SP3 /w HS Standard 2.5.0.80, HSTouch Server - 1.0.0.70, HSTouch Client 1.0.0.73 HSTouch Android - 1.0.0.2, HSTouch iPhone - 1.0.0.2
                        Playing with HS3 a bit but it's just play at this point.

                        Comment


                          #13
                          I'm using(not really it's winter) rain 8 with HS3. And it was working. now I'm getting:

                          Dec-14 9:09:55 AM Error Calling SetIOMulti in plugin Rain8:Object reference not set to an instance of an object.

                          In the log, So it seams it's time to submit another ticket to bugzilla.

                          P.S. More people might notice your questions in the HS3 forum, I stumbled across this post looking for something else.
                          If it ain't broke, don't fix it!

                          Comment


                            #14
                            Edit:
                            Somewhere in all the updates my rain8net devices were orphaned from the plugin, deleted the old devices, reconfigured the plugin, it recreated the devices and now I can control them again with no errors in the log.
                            If it ain't broke, don't fix it!

                            Comment


                              #15
                              I have submitted a bugzilla report yesterday. BTW this is for the Rain8Relay as opposed to the Rain8net plug-in, as I understand they are different, as least as far as I know. I don't use this for sprinklers but rather for the relays to operate LED decorative lighting around the house so it's kind of important.

                              I have not tried deleting the plug-in and devices and just reinstalling yet. I just wasn't comfortable enough with HS3 to start deleting things and retrying. This was my first foray into HS3 so I've still feeling my way around.

                              I put the questions in this forum since it was for the rain8relay plug-in and figured that's where it should be. Maybe the forums need seperate forums for HS2 and HS3 plug-ins to avoid confusion between the two?
                              Marty
                              ------
                              XPpro SP3 /w HS Standard 2.5.0.80, HSTouch Server - 1.0.0.70, HSTouch Client 1.0.0.73 HSTouch Android - 1.0.0.2, HSTouch iPhone - 1.0.0.2
                              Playing with HS3 a bit but it's just play at this point.

                              Comment

                              Working...
                              X