Announcement

Collapse
No announcement yet.

Documentation or hints on how to use?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Documentation or hints on how to use?

    I am trialing UltraFlowMeter3. I am relatively new to both HomeSeer and the plugin. I am in the process of migrating my SmartThings setup to HS4. I was able to install the plugin (I think) and get it set up. It seems to be connected to the meter and displaying flow, etc. What I’d like to do is the following:
    - Set an alarm if flow exceeds a certain amount of time (probable leak)
    - During the day, notify me of this fact
    - At night turn the water off
    - Set an alarm if the flow rate exceeds a certain amount (burst pipe) and turn the water off
    - Set an alarm if consumption exceeds a certain amount at night (backup leak detect) and turn the water off
    - Notify me when usage exceeds certain amounts on my way to a “goal” usage

    I did all of these things with SmartThings and expect that they can be done here, but I’m not sure where to start. Also, where do I go to see the graphs? If there is any documentation on this, just point me to it and I’ll happily muddle my way through.

    Thanks,
    Mark

    #2
    I found the documentation... now I am trying to figure out how to create events to do what I want. I’d still appreciate screenshots of events that others have created that do similar things.

    Thanks,
    Mark

    Comment


      #3
      Here is an example screenshot on how to set up an event to trigger when the water has been flowing for over 30 minutes. You should be able to adopt that for your use cases listed. You should be able to define a similar condition for the "Flow Rate [Current]" device.

      Click image for larger version  Name:	screenshot_flowmeter3.png Views:	0 Size:	226.2 KB ID:	1417999
      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

      Comment


        #4
        Just following up... Thank you. I was able to get it to work and knock on wood have been able to create rules which I believe have implemented all of the scenarios that I was targeting. FYI, I am doing this on HS4 running on Ubuntu so while I wouldn’t consider it “tested” it clearly seems to work. I do have some questions/comments:
        • While I was able to create a consumption meter that pushed notifications via HS Buddy (or txt) as I progressed towards my daily goal, it would have been nice to have a feature in the plugin to enable this. I think that it would have eliminated a bunch of events and/or made them cleaner.
        • I am not sure that I understand the difference (if there is one) when creating a rule when you select say, Flow Duration/Is greater than “a custom value of” or “set to any value”, or “(value) Gallons”
        • It would be nice if there was a feature (custom device?) in the plug in that allowed me to specify a time range and it would return the consumption during that time period. I use this to detect leaks. My rationale is that in my house at night water usage is limited to the ice maker and an occasional toilet flush so I set a consumption trigger that allows these activities but anything greater is probably a running toilet or other leak so I have it turn the water off so I can deal with it when I wake up. For the current version of the plugin, I did this by having my nighttime period start at midnight and made a rule that only looked at it before 6am. I suppose that there is a way to use a counter and make more complicated rules to do this for a custom time period, but it would be nicer if you could facilitate this in the plugin.
        • I like the consumption graph. I wonder if there is an easier way to access it than what I’ve been doing (going through HS4 web UI to the plugin). Is there a way that I could look at it directly through a URL or in HS Mobile or Buddy or send it via email?
        Anyway, thanks for doing this plugin. It is super valuable to me and assuming that it keeps working I’ll definitely become a paying customer.

        Mark

        Comment


          #5
          Hmmm... maybe I spoke too soon. Something strange is going on. The plugin claimed that I hit 218GPM a while ago. Clearly this is wrong. It hit 26GPM early on but I chalked that up to an issue somehow with the initial setup. Here is the graph...

          Click image for larger version

Name:	81999963-AF01-4917-920A-08765787B207.png
Views:	24
Size:	200.6 KB
ID:	1418850
          Any ideas?

          Mark

          Comment

          Working...
          X