Announcement

Collapse
No announcement yet.

API not working?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • API not working?

    Hello,

    I just installed a Rachio Gen2 16 zone controller and got through the setup, no problem.

    I am trying out the UltraRachio plugin before spending the money, but it doesn't seem to want to log in to the Rachio server. I eventually found the API Key (the menu is no longer 3 vertical bars on the left, it's now a person silhouette on the top right), and copy-and-pasted over, but it has yet to succeed. The Failures # keeps climbing.

    I have tried multiple reboots of HS and the plugin itself, as well as the PC running the software.

    I bumped the Log level up to Debug, and I see "https://api.rach.io/1/public/person/info/ The underlying connection was closed: An unexpected error occurred on a send. Unable to retrieve the id for the person entity currently logged in through OAuth."

    I haven't had any luck searching for this error on the Rachio site, or on here, so I thought it was worth a post.

    Any ideas?


    HS Info:
    Current Date/Time: 5/7/2017 5:02:06 PM
    HomeSeer Version: HS3 Standard Edition 3.0.0.318
    Operating System: Microsoft Windows XP Professional - Work Station
    System Uptime: 0 Days 0 Hours 30 Minutes 6 Seconds
    IP Address: 192.168.86.50
    Number of Devices: 146
    Number of Events: 161
    Available Threads: 100

    Enabled Plug-Ins
    1.1.2.0: Device History
    3.0.0.32: EasyTrigger
    3.0.0.104: HSTouch Server
    1.0.17123.357: MyQ
    3.0.0.14: NetCAM
    3.0.6104.19146: UltraRachio3
    3.0.1.87: Z-Wave

  • #2
    Hello,

    I originally had an issue with my API Access Token and Rachio support had to fix it. Can you reach out to them to make sure your API Access Token is correct? If Rachio support is unable to find any issues, then please make a post here.

    Regards,
    Ultrajones
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      I finally heard back from Rachio yesterday, but unfortunately I don't know how to answer his question:
      Right now it looks like you are calling 1/public/person/info... I believe that should return you a person ID. What does your Authorization header look like? it should say Authorization: Bearer {token}.
      (I also thought I sent this as a PM yesterday but I didn't see it in my sent items, so if this is a duplicate, I apologize in advance. I tried to PM this morning, but apparently your stored message quota is full.)

      Thanks again for your time...
      -LxMeister

      Comment


      • #4
        Hello LxMeister,

        I just noticed you're using Windows XP. I am wondering if your system is no longer able to establish a TLS connection to the Rachio API servers because the CA roots are not valid on your Windows XP system. Do you have a more recent operating system you can use instead of Windows XP?

        Regards,
        Ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • #5
          That seems to be it! I temporarily installed HS3 on my Win7 laptop, downloaded the plugin, copied over the API key from Rachio, and it worked instantly.

          Thank you for troubleshooting that with me. Guess this is another point towards upgrading my HS box... ;-)

          Thanks again!

          -LxMeister

          Comment

          Working...
          X