Announcement

Collapse
No announcement yet.

Plug in not communicating with Rachio

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Plug in not communicating with Rachio

    I have been using this plug in for over a year with no issues up until a couple of days ago. I can't seem to figure it out. It appears the plug in is not communicating with Rachio. I have reinstalled the app, checked the API address, and restarted HS. It would work for a minute and then stop again.

    I use my irrigation system along with beam sensors around the perimeter of my yard to keep deer away. They are really bad in our neighborhood. They eat EVERYTHING! My system works really well up until now. Needless to say they have been eating well the last few nights. I gotta fix this!

    Thanks!


    Plug-In Status
    Name: UltraRachio3
    Status: OK
    Version: 3.0.6104.19146
    Rachio API Status
    Success: 0
    Failure: 500


    Current Date/Time: 2/27/2018 9:01:28 AM
    HomeSeer Version: HS3 Pro Edition 3.0.0.368
    Operating System: Microsoft Windows 10 Pro - Work Station
    System Uptime: 0 Days 4 Hours 6 Minutes 17 Seconds
    IP Address: 192.168.1.90
    Number of Devices: 326
    Number of Events: 110
    Available Threads: 800

    Enabled Plug-Ins
    3.0.0.29: EnvisaLinkAdemco
    3.0.0.25: ImperiHome
    3.0.1.52: PHLocation
    0.0.0.38: Pushover 3P
    3.0.6104.19146: UltraRachio3
    3.0.6542.35207: UltraWeatherWU3
    3.0.1.190: Z-Wave

  • #2
    I figured out the issue. Rachio is limiting 1700 calls to the API within a 24 hr period.

    http://community.rachio.com/t/api-calls-failing/10751/9


    Ultrajones - is this something you can tweak to correct the issue? I changed the update time to 60 mins to see if that helps.

    Comment


    • #3
      Mine has stopped working too.
      Rachio updated their app a few days ago with a complete redesign. Not sure if this is related or not.
      Marty
      iCore5 Win 10 Pro x64 SSD

      HS3 Pro Edition 3.0.0.435 Windows

      BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

      Comment


      • #4
        I just tried logging in with my account and see this error:

        Your account is outdated. Please log in to your account on a mobile device to automatically update your account. You will then be able to access your Rachio account normally on any platform.

        I logged in using my mobile account, but it didn't upgrade anything
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • #5
          Originally posted by Ultrajones View Post
          I just tried logging in with my account and see this error:

          Your account is outdated. Please log in to your account on a mobile device to automatically update your account. You will then be able to access your Rachio account normally on any platform.

          I logged in using my mobile account, but it didn't upgrade anything
          The fix is to delete and reinstall the Rachio app on the iPhone.
          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

          Comment


          • #6
            So, I'm a little confused.

            My updated app on Android devices (phone and table) is working fine. I can start and stop zones etc using the app.

            But the plugin is not working properly despite rebooting HS. I can start a zone but the device status does not update. As such I can't stop it with the plugin and have to use the app to stop the zone.

            I have also rebooted the Rachio itself.

            Are you saying deleteing the app on my phone and reinstalling it will fix the plugin?
            Last edited by mminehan; March 3rd, 2018, 09:54 PM.
            iCore5 Win 10 Pro x64 SSD

            HS3 Pro Edition 3.0.0.435 Windows

            BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

            Comment


            • #7
              Rachio recently made significant changes and all users accounts need to be updated. If you're unable to get connected via the UltraRachio HSPI, then it's more than likely related to your user account not being automatically updated like mine. If you are still having issues logging in, then I suggest you call Rachio for assistance.

              Regards,
              Ultrajones
              Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

              Comment


              • #8
                I reviewed the original post and confirm Rachio has implemented rate limiting without notifying anyone of this change. I'll review host often my plug-in queries and will implement rate limiting within the plug-in to not exceed the limits Rachio now enforces.

                Regards,
                Ultrajones
                Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                Comment


                • #9
                  So I logged into the Rachio website and am able to control watering using both the website and the app.
                  But the plugin is is not functioning as it used to.
                  The zone control devices and the zone watering state device do not change. The weather devices are updating though. The plugin reports API failures.
                  I did check the API token which has not changed.
                  I'll wait to see if other people are experiencing similar issues before uninstalling and reinstalling the pluggin as this will create a whole lot of new device number etc.
                  iCore5 Win 10 Pro x64 SSD

                  HS3 Pro Edition 3.0.0.435 Windows

                  BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                  Comment


                  • #10
                    I have been trying to sort this out. It seems the 'online' and 'standby' have become inverted.

                    When I change the 'Rachio Device Status' to 'online' using the plugin the Rachio web site changes to 'standby' and vice versa (screen shots attached).

                    Could this be causing the problems?

                    See here: https://community.rachio.com/t/smart...-with-v3/10820
                    Attached Files
                    iCore5 Win 10 Pro x64 SSD

                    HS3 Pro Edition 3.0.0.435 Windows

                    BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                    Comment


                    • #11
                      I came here to check on the same thing - Standby and Online have inverted.

                      Also, it seems the Weather graphics are always showing the sun, despite the text changing, and my weather always says updated as of 1000+ minutes ago. Haven't checked the accuracy of the other fields yet, though...

                      Thanks!

                      Comment


                      • #12
                        Originally posted by LxMeister View Post
                        I came here to check on the same thing - Standby and Online have inverted.
                        Thanks!
                        Are you able to control your zones from the plugin since Rachio updated to V3? I can turn them on, but the HS device does not change. And I can't turn them off.
                        Last edited by mminehan; March 6th, 2018, 12:48 PM.
                        iCore5 Win 10 Pro x64 SSD

                        HS3 Pro Edition 3.0.0.435 Windows

                        BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                        Comment


                        • #13
                          Originally posted by mminehan View Post
                          Are you able to control your zones from the plugin since Rachio updated to V3? I can turn them on, but the HS device does not change. And I can't turn them off.
                          I hadn't tried that... I was just able to turn on a zone by the plugin, but not turn it off by setting it back to "zone off." I was able to stop it by going to the device Watering State and selecting "Stop Watering."

                          I'm beginning to think Rachio made quite a few changes behind the scenes that are going to take some looking into. My weather forecast indicates a high today of 0 and a low of 0.

                          Comment


                          • #14
                            Originally posted by LxMeister View Post
                            I'm beginning to think Rachio made quite a few changes behind the scenes that are going to take some looking into. My weather forecast indicates a high today of 0 and a low of 0.
                            Yes, I am seeing exactly the same thing. Let's hope it's not too much trouble for UltraJones to update the plugin to accomodate the changes.
                            iCore5 Win 10 Pro x64 SSD

                            HS3 Pro Edition 3.0.0.435 Windows

                            BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                            Comment


                            • #15
                              +1 for the plugin on our system. I logged into the Rachio account, and like said, now HS can start a zone, but no indication that it's active, and can't turn it off.
                              I use Rachio to keep the pool full, and when I noticed the water low I came to check the plugin as it crashes every now and then.
                              Let's hope Ultra is working on putting in back in working order.
                              Blair

                              HomeSeer: HS3 Pro 3.0.0.548
                              Hometroller S6 | Devices: 832 | Events: 211
                              Plug-Ins: Z-Wave .252 | HSTouch | RFXCOM | UltraRachio3 | Sonos
                              BLLAN | BLPLEX | BLLOCK | NetCAM | Global Cache Pro | Blur-Iris4

                              Comment

                              Working...
                              X