Announcement

Collapse
No announcement yet.

Bluetooth Connector 0.30 (for HS 2.1 and HS 2.0)

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Bluetooth Connector 0.30 (for HS 2.1 and HS 2.0)

    Here are two new versions of the Bluetooth Connector plugin:

    - Version 0.30.2.1 is for HomeSeer 2.1. It's a native .Net 2.0 plugin.
    - Version 0.30.2.0 is for HomeSeer 2.0. It's a native .Net 1.1 plugin

    Change Log:

    - Changed one help message in the Web configuration interface.
    - Fixed a bug with UP / DOWN buttons in the Web configuration interface.
    - Compiled new version 0.30.2.1 with .Net 2.0
    - Tested with HS 2.1.8

    To install or upgrade:

    1) Download the right attached .ZIP (0.30.2.1 for HS2.1, 0.30.2.0 for HS2.0)

    2) Unzip the archive without flattening the file tree (there are subdirectories that must be kept)

    3) Shutdown HomeSeer

    4) If you are upgrading, DELETE the HomeSeer 2/html/hspi_bt directory

    5) Copy all unziped files and subdirectories to your HomeSeer 2 directory

    6) Restart HomeSeer

    7) Enjoy

    [EDIT] Attachment for HS2.1 removed, as a new version is available from the Forum. Attachment for HS2.0 kept, as it's the last version compatible with HS2.0
    Last edited by stipus; December 4, 2009, 07:10 PM.
    --
    stipus

    #2
    Up and running on HS 2.1.

    I was having performance problems running under HS 2.0 (too many running plugins!) but the performance is great with this new version under HS 2.1.

    Well done Stipus!

    Comment


      #3
      Unknown error "19-03-2006 01:18:54 - Error - Initializing interface: BT Connector->E

      Hi Stipus

      I get an error in the log at HS startup: "19-03-2006 01:18:54 - Error - Initializing interface: BT Connector->Error looking-up SID: 1332 ". I can't find anything on this error?

      Another issue - when my mobile has been in and out of the are, and sometimes when I positivly know it has been in range, it is still lost by BT Connector. If I search for it in "My Devices" it there - it seems that the communication between the BT-stack and the plugin is hangin?

      Still - I think this is a great plugin

      /Mav

      Comment


        #4
        I get an error in the log at HS startup: "19-03-2006 01:18:54 - Error - Initializing interface: BT Connector->Error looking-up SID: 1332 ". I can't find anything on this error?
        Error 1332 means the association between your COMPUTER_NAME and the COMPUTER_ACCOUNT_ID cannot be found in the registry.

        What version of the plugin are u using ?
        What version of HomeSeer ?
        What version of Windows ?
        Do you have a domain controller or a special Windows setup ?
        Did you just change your computer name ?
        Did you always get this error, or is this the first time ?
        Did you try to reboot your computer ?

        Another issue - when my mobile has been in and out of the are, and sometimes when I positivly know it has been in range, it is still lost by BT Connector. If I search for it in "My Devices" it there - it seems that the communication between the BT-stack and the plugin is hangin?
        What Bluetooth stack are you running ?
        What stack version ?
        What's the polling method and other polling parameters for your device ?
        Did you try to use another polling method ?
        --
        stipus

        Comment


          #5
          Have upgrade the BT Connector for hs 2.1.18 but when I tried to press the config button i recive a error and nothing more hapend.


          <TABLE cellSpacing=2 cellPadding=0 width="100%" border=0><TBODY><TR><TD class=LOGDateTime1 noWrap align=left>2006-03-20 17:42:00 </TD><TD class=LOGType1 align=left colSpan=3>ConfigIO </TD><TD class=LOGEntry1 align=left colSpan=8>Calling ConfigIO for BT Connector</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>2006-03-20 17:42:01 </TD><TD class=LOGType0 align=left colSpan=3>Error </TD><TD class=LOGEntry0 align=left colSpan=8>Error processing plug-in config links for /style.css requested by from 127.0.0.1, Index was out of range. Must be non-negative and less than the size of the collection.Parameter name: index</TD></TR></TBODY></TABLE>
          Please excuse any spelling and grammatical errors I may make.
          --
          Tasker Plugin / Speech Droid
          Tonlof | Sweden

          Comment


            #6
            If you see Calling ConfigIO for BT Connector when you click the CONFIG button, this means the plugin is not correctly registered with HomeSeer.

            Did you click the "SAVE" button before clicking "CONFIG"
            Did you try to restart HomeSeer ?
            Did you try to reboot ?

            --
            stipus

            Comment


              #7
              Yes, I have done all of it. Under the startup i get this error.
              Initializing interface: BT Connector->Error: bluetooth manager can't be found


              If I put BlueToolsMS.dll back and restart HS the config works.

              By the way I bougt a new BT Interface
              In the registry I found widcomm table that reefer to the right catalog for this device so i think is a widcomm BT?

              Please excuse any spelling and grammatical errors I may make.
              --
              Tasker Plugin / Speech Droid
              Tonlof | Sweden

              Comment


                #8
                In the next version of the plugin, I will add a way to force which stack the plugin use, in case both MS and Widcomm stacks are installed.
                --
                stipus

                Comment


                  #9
                  Thanks
                  Please excuse any spelling and grammatical errors I may make.
                  --
                  Tasker Plugin / Speech Droid
                  Tonlof | Sweden

                  Comment


                    #10
                    I bought my third usb bluetooth device, the Linksys BT100 that I whas recommended in the early in the threads. http://board.homeseer.com/showthread...sys#post702719

                    I start thinking that I doing something wrong. Have removed BlueToolsMS.dll from hs2 directory.
                    Initializing interface: BT Connector->Error: bluetooth manager can't be found

                    PS.
                    Thanks for all support and great plugin.
                    Please excuse any spelling and grammatical errors I may make.
                    --
                    Tasker Plugin / Speech Droid
                    Tonlof | Sweden

                    Comment


                      #11
                      I reinstall my xp-machine, that solved many problems with the bluetooth and sip plugin.

                      /Tony
                      Please excuse any spelling and grammatical errors I may make.
                      --
                      Tasker Plugin / Speech Droid
                      Tonlof | Sweden

                      Comment


                        #12
                        You did reinstall the OS ?

                        Now does the BT plugin work as expected ?
                        --
                        stipus

                        Comment


                          #13
                          Yes I start over and install a fresh windows xp, a new install of HS 2.0 /2.1 and the drivers for the BT device. So now is it running perfect with widcomm.
                          Please excuse any spelling and grammatical errors I may make.
                          --
                          Tasker Plugin / Speech Droid
                          Tonlof | Sweden

                          Comment


                            #14
                            I tried to insert more fields but it seems not to work.
                            It says Bellow -10 or 0 in the status.

                            I have attach the BT debug and the screendump of the settings.

                            Have I done anything wrong?
                            Attached Files
                            Please excuse any spelling and grammatical errors I may make.
                            --
                            Tasker Plugin / Speech Droid
                            Tonlof | Sweden

                            Comment


                              #15
                              Hi there,

                              The signal strenght doesn't work with the Autodiscovery poll method.

                              To access signal strength, the plugin must physically (over the air) connect to the Bluetooth device, and this requires the "ConnectService" or the "DiscoverService" poll method.

                              Regards,

                              stipus
                              --
                              stipus

                              Comment

                              Working...
                              X