Announcement

Collapse
No announcement yet.

I need to see the light....well alright flashing bluetooth LEDS

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    If autodiscovery is enabled on the network, and you are only using autodiscovery on all devices, this is not related to the bug I was talking about.

    It's another one ! Hanging on startup is caused by the Bluetooth library 1.20 not releasing resources, and the next time the plugin wants to acquire the BT stack, it hangs.

    You may try killing/restarting HS several times. It usually works.

    I'll try to go back to Bluetools 1.10, which does not have this behavior.

    stipus
    --
    stipus

    Comment


      #32
      Stipus,

      This is happening on a cold boot...which sort of suggests that its a race condition...

      HS hangs just after initialising the plugin....recording the networks and devices Normally a couple of other plugins get the chance to register then it stops dead.

      Cheers,

      Darren

      Comment


        #33
        I just replaced Bluetools 1.20b with Bluetools 1.10, and I don't get any hanging problem anymore.

        The tray icon is ready, and very nice !

        I'll try to add HomeSeer auto-reconnect and device discovery at the client before posting a new version tonight.

        If you want to experiment with it this afternoon, I can post it. Just tell me.
        --
        stipus

        Comment


          #34
          Stipus,

          Yes if you want to go ahead and post it...I will load up and test for you.

          Thanks,

          Darren

          Comment


            #35
            Just posted V0.34.2.2 to the forum.

            - The Bluetooth Client now goes to the system tray, with all fancy balloons...etc. It was not as easy as I thought, but it now works quite well !

            - Downgraded BT support dlls to 1.10 because 1.20 and 1.20b can hang.

            http://board.homeseer.com/showthread.php?t=115872
            --
            stipus

            Comment


              #36
              Stipus,

              I did the upgrade and I had a clean startup/shutdown...will try a cold start-up tomorrow. I really like the systray applet...excellent.

              I'll report back more tomorrow.

              Cheers,

              Darren

              Comment

              Working...
              X