Announcement

Collapse
No announcement yet.

Bluetooth Connector 0.40.2.2 + Bluetooth Client posted

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    What about the BT Connector trial. Is there a way to reset?
    Thanks for the quick response.

    Comment


      #17
      Plugin authors have no way to interact with the licensing system.

      You have to open a HS ticket and ask for a new trial license. As far as I know, they always accept.
      --
      stipus

      Comment


        #18
        Thanks Stiptus

        Comment


          #19
          Events not triggering

          Hi,

          I am a HS and BT newbie and started playing with it last night.

          The discovery seems to work reliably (ie. I see in the Debug log it is finding my phone and setting the status to 1 and vice versa when the phone goes away) but the HS events I have setup are not triggering reliably. I set up 2 events one to switch a light on when phone is in range and then to switch it off again when the phone goes away.

          This works the first time and sometimes the first couple of times but then doesn't trigger. The only way I can get it to start working again is to edit the event and save it (making no changes).

          I am using the Microsoft stack with a MS Bluetooth receiver (from a MS BT Keyboard).

          Would be grateful for anyones thoughts on this. If I can get this reliable it is a great plugin / feature.

          One more piece of info - I was testing by enabling and disabling BT on my phone (rather than going in and out of range) - not sure if that is part of the problem.

          Cheers

          Andy

          Comment


            #20
            What is the HS version you are running ? Do you happen to have a HS Pro 100 ?
            --
            stipus

            Comment


              #21
              Hi,

              I am using the latest free trial download (downloaded and installed HS last week and the Bluetooth plugin yesterday). So I assume it is 2.2.0.66 (HS2) - not at home at the moment so can't check it.

              Andy

              Comment


                #22
                I'll have a look next Monday.
                --
                stipus

                Comment


                  #23
                  Any word on the Vista version of the remote?

                  I know you haven't had your Vista machine long, but I'd like to know if you have made any progress.

                  Thanks

                  Comment


                    #24
                    I got my Vista computer a week ago (delivery was postponed twice!).

                    Are you talking about this error message you got ?

                    Warning: remote network Network1 unreachable. Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
                    --
                    stipus

                    Comment


                      #25
                      Very good news: Franson just released a new version of the Bluetooth Library !

                      New features:
                      * BlueTools is now linked to the latest Widcomm SDK, which hopefully will improve Widcomm stability.
                      * DeviceClass is now reported correctly for detected devices.
                      * RadioStatus implemented on Network. Allows you to change the status of the radio on stacks that supports this. (i.e. MS supports shutting down bluetooth entirely whereas Widcomm only disables the radio but do not power down.)
                      * DiscoverAll property on Network. Allows you to always detect devices in your bluetooth neighbourhood even if they are detected.
                      * AutoPowerOn on Manager. Allows you to disable BlueTools ability to turn on the blutooth radio if it is off.
                      I have been waiting for a library update for more than a year !

                      I'm going to release a new version of the Bluetooth Connector soon, using this updated Bluetooth Lib.
                      --
                      stipus

                      Comment


                        #26
                        The latest Bluetooth lib seems to work very well here.

                        I did build a new version of the Bluetooth Connector with this lib, and tested on XP, Windows 2000 and Windows 2003. One more test on Vista, and I can release a new version.

                        I have also updated the Web Configuration Interface, and added Bluetooth signal strength information when you click a BT Device on the main HS Status page?

                        I'm also going to create a Windows installer file for the Bluetooth Client, so that it's easier to setup on a remote computer.
                        --
                        stipus

                        Comment


                          #27
                          that sounds great Stipus...thanks

                          Comment


                            #28
                            The Bluetooth Client had problems with Vista: It kept unregistering from the plugin. I think I found a solution .... the Bluetooth Client now checks every 5 second if it is correctly registered.

                            It has now been working fine for a few hours, but I'll let it run for at least 24 hours before releasing this new version.

                            I also changed the way Bluetooth Device default Configuration is initialized. Now if you have several Bluetooth networks, the default configuration will automatically get the right default boolean expression, such as:

                            <TABLE id=configGridView style="BORDER-COLLAPSE: collapse" cellSpacing=0 rules=all border=1><TBODY><TR><TH scope=col>Order</TH><TH scope=col>Up</TH><TH scope=col>Down</TH><TH scope=col>Device Value</TH><TH scope=col>Device String</TH><TH scope=col>Boolean Expression</TH><TH scope=col>Edit</TH><TH scope=col>Delete</TH></TR><TR><TD>0 </TD><TD>Up</TD><TD>Down</TD><TD>1 </TD><TD>Device Detected </TD><TD>@(Network0)>=0 || @(Network1)>=0 || @(Network2)>=0 </TD><TD>Edit</TD><TD>Delete</TD></TR><TR><TD>1 </TD><TD>Up</TD><TD>Down</TD><TD>0 </TD><TD>Device Away </TD><TD>true </TD><TD>Edit</TD><TD>Delete</TD></TR></TBODY></TABLE>
                            --
                            stipus

                            Comment


                              #29
                              Bluetooth detection is really a mistery :

                              I have my Treo 650 phone next to my XP computer (with an old Widcomm stack). The phone is not accurately detected.

                              I have my new Vista computer far fom the phone (with a new Widcomm stack for Vista): the phone is always correctly detected, despite it's near the other computer...

                              Maybe it's too close to my XP computer...
                              --
                              stipus

                              Comment


                                #30
                                It has been running fine on 3 computers (Vista - XP - 2003 Server) for more than 24 hours now.

                                I have tried to:

                                - Shutdown my WIFI router, and check client reconnection on restart.
                                - Put client laptop on standby, and check client reconnection on wake up.
                                - Shutdown and restart HomeSeer, and check client reconnection on restart.

                                No problem detected.

                                I have also built the BluetoothClient Windows Installer file, and added a few comments to the Web Configuration Interface (Warning for bonded devices...).

                                I'll send this new version to the updater
                                --
                                stipus

                                Comment

                                Working...
                                X