Announcement

Collapse
No announcement yet.

event trigger

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    event trigger

    <TABLE cellPadding=3 width="100%" border=0><TBODY><TR><TD>i try to create a events in my pro100 with bt device
    and i scearch in device status change the fonction equal to or not equal to
    were it s this fonction
    ?
    </TD></TR></TBODY></TABLE>

    if i go to the device value change in zwave device i ave -equal to -not equal to -greater than -less than -any value - set to -set to any -in the range
    And i go to bt device i ave just - become -for at least - for exactly
    i try to this fonction and this not detect my device on or off
    and is not easy for widcom stack (is not just on or off!!)
    thanks for check

    #2
    You should create a Device value change event. (not device status).

    The Bluetooth connector changes the value of the device, according to the rules you set in the BT Connector configuration.

    Regards,

    stipus
    --
    stipus

    Comment


      #3
      i try that
      and i ave the same option
      and the probleme there it s everytime the stack bluetooth detect my device my event run (every +-1 min)
      in older version this is work perfect
      and in last version this is not work

      my objetif it s
      1 if arrive in my home the homeseer detect my phone and i receive a welcome msg
      2 if no phone (4 phone) in my home homeseer disable all light and go in random light

      this scene work perfectly before

      Comment


        #4
        Honestly I don't know what's happening.

        I doubt this is a problem with the BT Connector plugin, as it doesn't interract at all with the event system.

        It may be a problem with the HomeSeer version running on your Pro100.

        Try to see if you have the same event triggers with other HS devices (not created by my plugin).
        --
        stipus

        Comment


          #5
          Originally posted by gregdeux View Post
          i try that
          and i ave the same option
          and the probleme there it s everytime the stack bluetooth detect my device my event run (every +-1 min)
          in older version this is work perfect
          and in last version this is not work

          my objetif it s
          1 if arrive in my home the homeseer detect my phone and i receive a welcome msg
          2 if no phone (4 phone) in my home homeseer disable all light and go in random light

          this scene work perfectly before
          What version of HomeSeer are you running on your PRo-100?
          -Rupp
          sigpic

          Comment


            #6
            my version of homeseer pro is 2.2.0.11
            and for bt connector is 0.42.2.2

            i ave write a ticket to homeseer and the responce for that is

            This is a 3rd party plugin so I would suggest asking the plugin author/developer about this. It appears he is over ridding the default device value triggers in his plugin. This should be posted on the HomeSeer bulletin board in the plugins forum.




            in your homeseer triger ave you "-equal to -not equal to -greater than -less than -any value - set to -set to any -in the range "
            i ave that just for zwave device and not for bt device

            Comment


              #7
              I just double-checked my code to be sure.... and this plugin is really doing nothing to change triggers.


              // TRIGGERS SUPPORT
              publicbool SupportsTriggerUI()
              {
              LogDebugString(
              "SupportsTriggerUI() called" );
              returnfalse;
              }
              Can you try to delete the HS devices connected to BT devices, and restart HomeSeer ?

              I'm really puzzled about this. If you still have a problem after recreating the devices, I'll open a HS ticket myself, and try to understand what's happening with HS developpers. Can you give me your HS ticket number as a reference ?

              I think I have already seen some messages on the board about similar problems (not specific to the BT connector).

              There must be some condition that change the HS trigger interface... I'm sure we are going to find the reason.

              Do you have any other pluggin that may change triggers for all devices ?
              --
              stipus

              Comment


                #8
                i try all before create my ticket and before write here
                i ave edit file hspi_bt.ini and i remove my all device
                in status device to
                and i ave remove my event
                i ave reinstall to the bluetooth connector
                same probleme

                my ticket is 13566

                if you go in triger and you put a device zwave you ave all option
                and if in the same triger you chane this device in a bt device after +-1 sec you receive just 3 otion triger

                thanks for your help
                and sorry for my english (i m a belgium people and i speak just in french lol )

                Comment


                  #9
                  I'm french
                  --
                  stipus

                  Comment


                    #10
                    --
                    stipus

                    Comment


                      #11
                      je sais je l ai vu dans ton prof c est pour ca que je te l ai dit
                      maintenant je vit au quebec

                      j ai deja fait ca le probleme c est que lorsqu il detecte "ou qu il n est pas present" le telephone il relance c ette evenement a chaque x qu il relance 1 scan du bluetooth
                      essaye tu veras
                      donc meme le changement de valeur ne fonctionne pas corectement
                      par contre pour les autre device "zwave" la j ai pas de probleme cette commande fonctionne bien


                      on peut continuer en eng pour les autre qui on le meme probleme si tu prefere

                      Comment


                        #12
                        juste peut etre si ca peut t aider
                        les valeur du triggger sont les meme que pour les deteceur de mouvement
                        se peut t il qu il faut mettre 1 autre classe pour le bt dans la database ?

                        Comment


                          #13
                          ave you test or news for me ?

                          Comment


                            #14
                            I think I understand the problem:

                            If HS device values and associated text messages are set, Homeseer changes the possible triggers.

                            The solution is to remove the value settings.

                            - Shutdown HS
                            - Create a backup copy of Config/hspi_bt.ini
                            - Edit hspi_bt.ini
                            - For each BT Device, remove all HsConfigXX lines from the config.
                            - Restart HS.

                            You'll get original values from -15 to +15 without any text, and HS triggers should be normal.
                            --
                            stipus

                            Comment


                              #15
                              no ok



                              i remove my all HsConfigXX line in my ini file
                              and realy all option triger come back

                              in status homeseer device is 0 or 1
                              in event triger i try to put " from -15 to +15 " or any other value this is not work
                              i go in bluetooth connector and go in configure of 1 device

                              i choice widcomm or microsft stack
                              and trigeer option for this device comeback in limited choice
                              in config of device in bluetooth connector i config 1 device without devicestring or devicevalue or booth its same

                              Comment

                              Working...
                              X